upgrade from 42.3 to 15.1 unsuccessful

Before upgrading my system to the latest version I was trying to upgrade a VM with the same version to at least get a feeling that is going to work and at least learn on how to correct at least some of the issues. I tried few times over the last year to upgrade to 15.0 w/o success and now that I have some time off I was trying to test it again again with the same result(failure).
the VM has this list of repositories:

sudo zypper lr -d
#  | Alias                     | Name                                    | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                      | Service                                                                                                                   
 1 | openSUSE-Leap-42.3-0      | openSUSE-Leap-15.1-0                    | No      | ----      | ----    |   99     | yast2  | cd:///?devices=/dev/disk/by-id/ata-VBOX_CD-ROM_VB2-01700376              |                                                                                                                           
 2 | repo-debug                | openSUSE-Leap-15.1-Debug                | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/debug/distribution/leap/15.1/repo/oss/      |                                                                                                                           
 3 | repo-debug-non-oss        | openSUSE-Leap-15.1-Debug-Non-Oss        | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/debug/distribution/leap/15.1/repo/non-oss/  |                                                                                                                           
 4 | repo-debug-update         | openSUSE-Leap-15.1-Update-Debug         | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/debug/update/leap/15.1/oss/                 |                                                                                                                           
 5 | repo-debug-update-non-oss | openSUSE-Leap-15.1-Update-Debug-Non-Oss | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/debug/update/leap/15.1/non-oss/             |                                                                                                                           
 6 | repo-non-oss              | openSUSE-Leap-15.1-Non-Oss              | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.1/repo/non-oss/        |                                                                                                                           
 7 | repo-oss                  | openSUSE-Leap-15.1-Oss                  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.1/repo/oss/            |                                                                                                                           
 8 | repo-source               | openSUSE-Leap-15.1-Source               | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/source/distribution/leap/15.1/repo/oss/     |                                                                                                                           
 9 | repo-source-non-oss       | openSUSE-Leap-15.1-Source-Non-Oss       | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/source/distribution/leap/15.1/repo/non-oss/ |                                                                                                                           
10 | repo-update               | openSUSE-Leap-15.1-Update               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.1/oss/                       |                                                                                                                           
11 | repo-update-non-oss       | openSUSE-Leap-15.1-Update-Non-Oss       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.1/non-oss/     

all of them were changed from 13.2 to 15.1. a long list of conflicts was presented in yast and I selected to downgrade to lp151 for most or remove the components if that option was not presented. after installing and rebooting the system i’m getting this error:
"Unable to create I/O slave. klauncher said: Error loading ‘/usr/lib64/qt5/plugins/kf5/kio/desktop.so’ . the file exists:

ll /usr/lib64/qt5/plugins/kf5/kio/desktop.so                                                                                                    
-rwxr-xr-x 1 root root 39856 Nov 19 11:02 /usr/lib64/qt5/plugins/kf5/kio/desktop.so

trying to update using zypper:

sudo zypper up
[sudo] password for root: 
zypper: symbol lookup error: /usr/lib64/libproxy.so.1: undefined symbol: _ZN9libmodman14module_manager8load_dirENSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEEb

Any suggestions? please let me know if I need to provide any other details. This is a VM so I can try anything that is suggested.

Leap 15.1 is still in alpha testing, so it really doesn’t count as “the latest release” – it isn’t yet a release.

Of course, there is nothing wrong with your testing this upgrade. But it might be a bit early in the 15.1 test cycle to expect a smooth upgrade.

thanks nrickert. My issue is that it was the same to upgrade from 43.2 to 15.0. I tried 2 or 3 times w/o success. or maybe I should give up and just use fresh install?

A fresh install is probably safer. That’s what I normally use. I did try an upgrade of 42.3 to 15.0 (in a virtual machine), but I didn’t like the way that went.

It’s fairly normal to get some conflicts in an upgrade. The new upgraded packages will replace old ones. But if you have packages that are not in the new distribution, they would be left alone – unless there are conflicts. And that’s probably the conflicts you are seeing.

I don’t know what caused that “undefined symbol” issue.

You never mentioned what exact command you used to “updrade”.

nrickert- there were lots of conflicts maybe around 40 and most probably one of the options I selected was not the correct one.
to answer your question arvidjaar - I changed in yast the repositories to point to the new version(15.1 and before in another few attempts to 15.0) and then I selected the option to upgrade all the packages. Please let me know if you need more details. I have 2 computers where I would like to upgrade instead of fresh install, but if I don’t find a solution in the next few months i will have to eventually do a fresh install. The VM’s have a minimal number of things on top of the standard basic image(mariadb,php,-- the LAMP stuff)

AFAIK zypper dup is the only way to upgrade short of using an iso. Don’t think doing it from Yast would work. Also ALL base repos must be switched before the upgrade and any extraneous ones disabled.

You may try a zypper dup to try and repair just be certain you have no older repos in the mix

Correct. Which is why it is always important to provide information what exactly had been done.

hy, this summer I did upgrade from 42.2 to 42.3 to leap 15.0 and after some problems I succeed with the suggestion in this forum, try to search my posts about leap 15.0
and try to follow that suggestion and you will succeed :wink:


I still think you should take the advice about the status of 15.1 serious. Are you realy prepared to start testing it? And to report the problems you find to the development team?

And not many people here are testing 15.1, thus coming here with 15.1 problems might not get you much response. Most here are just users (like you) and thus run one of the supported versions.

I also strongly advice not to skip a version. Thus first upgrade from 42.3 to 15.0. When that succeeds you may be ready to try for 15.1. I understand from the above that you encountered problem going to 15.0. As long as those problems are not addressed, IMHO it is not very wise to go for 15.1

thanks for all the replies.
i was attempting to do the upgrade from yast and it got me at the error mentioned before "Unable to create I/O slave. klauncher said: Error loading ‘/usr/lib64/qt5/plugins/kf5/kio/desktop.so’ "
As per suggestions I modified the repos remotely from command line to use 15.0 as per bellow:

zypper lr --uri
Repository priorities are without effect. All enabled repositories share the same priority.

#  | Alias                     | Name                                    | Enabled | GPG Check | Refresh | URI                                                                     
 1 | openSUSE-Leap-42.3-0      | openSUSE-Leap-15.1-0                    | No      | ----      | ----    | cd:///?devices=/dev/disk/by-id/ata-VBOX_CD-ROM_VB2-01700376             
 2 | repo-debug                | openSUSE-Leap-15.0-Debug                | No      | ----      | ----    | http://download.opensuse.org/debug/distribution/leap/15.0/repo/oss/     
 3 | repo-debug-non-oss        | openSUSE-Leap-15.0-Debug-Non-Oss        | No      | ----      | ----    | http://download.opensuse.org/debug/distribution/leap/15.0/repo/non-oss/ 
 4 | repo-debug-update         | openSUSE-Leap-15.0-Update-Debug         | No      | ----      | ----    | http://download.opensuse.org/debug/update/leap/15.0/oss/                
 5 | repo-debug-update-non-oss | openSUSE-Leap-15.0-Update-Debug-Non-Oss | No      | ----      | ----    | http://download.opensuse.org/debug/update/leap/15.0/non-oss/            
 6 | repo-non-oss              | openSUSE-Leap-15.0-Non-Oss              | Yes     | ( p) Yes  | Yes     | http://download.opensuse.org/distribution/leap/15.0/repo/non-oss/       
 7 | repo-oss                  | openSUSE-Leap-15.0-Oss                  | Yes     | ( p) Yes  | Yes     | http://download.opensuse.org/distribution/leap/15.0/repo/oss/           
 8 | repo-source-non-oss       | openSUSE-Leap-15.0-Source-Non-Oss       | No      | ----      | ----    | http://download.opensuse.org/source/distribution/leap/15.0/repo/non-oss/
 9 | repo-source-oss           | openSUSE-Leap-15.0-Source-Oss           | No      | ----      | ----    | http://download.opensuse.org/source/distribution/leap/15.0/repo/oss/    
10 | repo-update-non-oss       | openSUSE-Leap-15.0-Update-Non-Oss       | Yes     | ( p) Yes  | Yes     | http://download.opensuse.org/update/leap/15.0/non-oss/                  
11 | repo-update-oss           | openSUSE-Leap-15.0-Update-Oss           | Yes     | ( p) Yes  | Yes     | http://download.opensuse.org/update/leap/15.0/oss/                     

so all of them are at 15.0 and then I tried to do a zypper dup and got this error:
zypper dup
Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See ‘man zypper’ for more information about this command.
Retrieving repository ‘openSUSE-Leap-15.0-Non-Oss’ metadata --------------------------------------------------------------------------------------------------------------------------------------------------------------------]zypper: symbol lookup error: /usr/lib64/libproxy.so.1: undefined symbol: _ZN9libmodman14module_manager8load_dirENSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEEb
which seems to show that zypper cannot update(zypper up previously) and or do a distribution upgrade(zypper dup). so probably some packages were upgraded and some were not and is stuck in the middle with some packages which prevent an update.
i was trying to read the post mentioned by <pier_andreit> but i cannot access it. the search returns nothing for some unknown reason

should i just give up? i don’t know what else to try but willing to listen to any suggestions. thanks for your replies

I would suggest a clean install at this stage.

It is actually possible, when “zypper” is broken, to use the “zypper” from the iso with the “-R” option to tell it where to install. But it is tricky, and a clean install will be easier.

this was just a VM and after all the tips and info received I decided with that broken system to reinstall 13.2 and afterwards after changing all the repositories to 15.0 to do another attempt this time as per gogalthorp advice to do a zypper dup as he indicated to be the most likely way to upgrade. Only this way I was successful. now I have the confidence to upgrade a system to which I need to connect remotely and to do the upgrade. Thanks to everyone.