Upgrade from 42.2. Default graphics driver doesn't work

At last, I have updated my Leap 42.2. system to 42.3 . All went smoothly except that I can not boot into KDE with the default kernel as setup by the upgrade. When I am at the grub2 boot screen, I chose the second boot option, and then chose the 4.4.104-39 kernel option (by trial and error) and the boot proceeded properly to the DM and, after logging in, to the KDE environment. My video card is an Nvidia GeForce GTX750 (yeah, I know, no where near the latest and greatest).

Is there something that I should do to better configure the boot process and/or load a better kernel? My goal is to have the most up to date kernel boot properly without my having to manually make a selection on boot up.

(I suspect this is very easy. I just don’t know how to accomplish it)

If I need to provide more information, just ask.

Thanks very much,


If 42.2 worked fine, then uninstalling drm-kmp-default (which contains updated drivers from kernel 4.9) should help.

But: Are/were you using the nvidia driver?
Then you’d probably just have to reinstall it.

If not, it would probably a good idea to install anyway.

Btw, a GTX750 is not really “old” IMHO… :wink:


4.4.104-39 is the latest kernel on Leap 42.3.
What exactly do you mean with “second boot option”? That should be “Advanced Options”…
And what is the first one?

Or do you boot the 2nd option in “Advanced Options…”? That would be “recovery mode”, and use a generic fallback video driver.

Maybe post a picture of your boot menu for clarification…

Rather than a picture, I’ll post the text:
(This is the grub2 screen):

First set of choices:

OpenSUSE Leap 42.3
Advanced Options for OpenSUSE Leap 42.3

{I select “OpenSUSE Leap 42.3” and get a blank screen)
(I select “Advanced Options for…” and I get the following menu of 3 choices}

OpenSUSE Leap 42.3 with Linux 4.4.104-39
OpenSUSE Leap 42.3 with Linux 4.4.104-39
OpenSUSE Leap 42.3 with Linux 4.4.104-18.44

(I choose the first or second entry and just get a large mouse pointer on the middle of the screen. I choose the third entry and boot into KDE normally)

I hope this helps…


Ok, so kernel 4.4.104-39 does not work, but 4.4.104-18.44 does.
I wonder where you got that from though, it is not in the standard repos…

Could you please post the Xorg log with kernel 4.4.104-39?
That should hopefully show what’s going wrong, and will at least show what graphics driver you are using.
I.e. boot to kernel 4.4.104-39, the first option until the graphical session would start (what happens exactly btw? you didn’t actually describe the problem), then reboot to the working kernel and post the file /var/log/Xorg.0.log.old (which is the log from the previous boot).
If the file is too big, please upload it to some share/paste site like paste.opensuse.org and post a link.

PS: you could of course set the working kernel as default, or uninstall the broken one, but it’s probably better to look at least what might be broken.

Ah, it seems to be the latest 42.2 kernel… :wink:

Ok, so please try to uninstall the package drm-kmp-default as mentioned (with YaST->Software Management, or “sudo zypper rm drm-kmp-default”). The two kernels should be more or less identical otherwise AFAIK.

The log may still be interesting though I suppose.

Sorry this too longer than I wanted it to. The log file as on pastebin.com
user name neidorff
file name: Xorg.0.log.old

Would you please tell what I am removing if I remove drm-kmp-default as suggested earlier.

Many thanks,

Can you please post a link?
I can’t find it…

Would you please tell what I am removing if I remove drm-kmp-default as suggested earlier.

drm-kmp-default contains updated kernel graphics drivers, from Kernel 4.9.
If you uninstall it, you basically use exactly the same drivers as with Leap 42.2.

The new drivers may have a bug that affects your specific graphics card/chip… (nouveau is quite unstable anyway)

OTOH, that would be irrelevant when using the nvidia driver.

Sorry. (blush: it has been a long time since I’ve used pastebin) Here’s the URL: https://pastebin.com/UCJKWYwb

Ok, so you actually do have the nvidia driver installed, but it’s not working:

     9.256] (EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the
     9.256] (EE) NVIDIA:     system's kernel log for additional error messages and
     9.256] (EE) NVIDIA:     consult the NVIDIA README for details.

You’d need to reinstall it to make it work with the newer kernel.

How did you install it in the first place?
Via the repo?
Then this should be enough:

sudo zypper in -f nvidia-gfxG04-kmp-default

If you used the .run installer, you’d need to reinstall it (or recompile the kernel module at least) after every kernel update.
In that case, you’d also have to manually uninstall drm-kmp-default, otherwise it’s not going to work.

Well, I looked in YAST and saw that nvidia-gfxG04-kmp-default was installed. (I don’t recall downloading the driver from nvidia) so I ran the above command. I received several screens of warnings. Please see


for full command output. Are these warnings benign, or do I have a problem?

Thanks very much,

If you use the .run installer from nvidia, it wouldn’t show up in YaST… :wink:

for full command output. Are these warnings benign, or do I have a problem?

These warnings are about the 42.2 kernel, i.e. 4.4.104-18.44.
That’s more or less “normal”, as the two kernels are not compatible, i.e. the modules will either work with the one or the other (as you noticed before).

The latest one (4.4.104-39) should be fine now.

And the next kernel update will replace the older 42.2 kernel (4.4.104-18.44) and therefore disable those warnings anyway.
openSUSE keeps 2 kernels by default.

OK. Many thanks for all the help. (now to see what happens after a reboot. No news is good news!!!)