Upgrade from 31.2 to Leap 42 Lost Codecs for VLC?

Hi there I appear to have lost access to codecs for vlc now that I’m on Leap 42.1 Pretty sure I could play just about everything at 13.2 I’ve had a look at the forums and done everthing that’s been suggested, i.e. uninstall, install entirely from Packman. When I did this at 13.2 I got a LOT more packages to install than the relatively few in 42.1

My question is are they simply not there yet on the Packman Repository for 42.1?

The 2 I’m having difficluty with are the very old DV avi codec for a JVC Camcorder bought in 1997 and the newer AVCHD (MTS) codec.

The AVCHD plays fine on Dragon Player though, avi files can’t play on anything but I can convert using handbrake.

I did read about some legal issues with codecs.

Thanks.

those legal issues are aincient and the same for all opensuse versions, vlc is the same (well build from the same source) for 13.2 and LEAP so no changes there, afaik dragon uses gstreamer as a backend, do you have vlc-codecs installed, where did you get vlc from, did you do a vendor change to packman?
post your repo list

zypper lr -d

Check that you installed the separate vlc codecs package from packman and that vlc is indeed the packman version.

| Alias | Name | Enabled | GPG Check | Refresh | Priority | Type | URI | Service

—±---------------------------------±----------------------------------------±--------±----------±--------±---------±-------±--------------------------------------------------------------------------------±-------
1 | AdobeFlash | AdobeFlash | Yes | ( p) Yes | Yes | 99 | rpm-md | http://linuxdownload.adobe.com/linux/x86_64/ |
2 | KDEapps | KDEapps | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/KDE:/Applications/openSUSE_Leap_42.1/ |
3 | KDEextra | KDEextra | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_Leap_42.1/ |
4 | Mozilla | Mozilla | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_Leap_42.1/ |
5 | Packman | Packman | Yes | (r ) Yes | Yes | 99 | rpm-md | Index of /pub/linux/misc/packman/suse/openSUSE_Leap_42.1/ |
6 | PlexRepo | PlexRepo | No | ---- | No | 99 | NONE | http://plex.r.worldssl.net/PlexMediaServer/fedora-repo/release/x86_64/ |
7 | google-chrome | google-chrome | Yes | (r ) Yes | Yes | 99 | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64 |
8 | http-opensuse-guide.org-b51d78de | libdvdcss repository | Yes | (r ) Yes | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_42.1/ |
9 | openSUSE-42.1-0 | openSUSE-42.1-0 | Yes | (r ) Yes | No | 99 | yast2 | cd:///?devices=/dev/disk/by-id/ata-hp_DVD_A_DH16ACSH_388217917322 |
10 | repo-debug | openSUSE-Leap-42.1-Debug | No | ---- | Yes | 99 | NONE | http://download.opensuse.org/debug/distribution/leap/42.1/repo/oss/ |
11 | repo-debug-non-oss | openSUSE-Leap-42.1-Debug-Non-Oss | No | ---- | Yes | 99 | NONE | http://download.opensuse.org/debug/distribution/leap/42.1/repo/non-oss/ |
12 | repo-debug-update | openSUSE-Leap-42.1-Update-Debug | No | ---- | Yes | 99 | NONE | http://download.opensuse.org/debug/update/leap/42.1/oss |
13 | repo-debug-update-non-oss | openSUSE-Leap-42.1-Update-Debug-Non-Oss | No | ---- | Yes | 99 | NONE | http://download.opensuse.org/debug/update/leap/42.1/non-oss/ |
14 | repo-non-oss | openSUSE-Leap-42.1-Non-Oss | No | ---- | Yes | 99 | NONE | http://download.opensuse.org/distribution/leap/42.1/repo/non-oss/ |
15 | repo-oss | openSUSE-Leap-42.1-Oss | Yes | (r ) Yes | Yes | 99 | yast2 | http://download.opensuse.org/distribution/leap/42.1/repo/oss/ |
16 | repo-source | openSUSE-Leap-42.1-Source | No | ---- | Yes | 99 | NONE | http://download.opensuse.org/source/distribution/leap/42.1/repo/oss/ |
17 | repo-update | openSUSE-Leap-42.1-Update | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/leap/42.1/oss/ |
18 | repo-update-non-oss | openSUSE-Leap-42.1-Update-Non-Oss | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/leap/42.1/non-oss/ |

I put everything over to packman using zypper dup, that broke amarok so i changed that & only that back to the original opensuse repository.

Thanks for your help.

Please run this:

sudo zypper dup --from 5

And Amarok should work.

Just done that a vlc still doesn’t decode AVCHD and avi and Amarok doesn’t work now.

Did it again to make I didn’t make a mistake;

ajwillis@linux-9i86:~> sudo zypper dup --from 5
root’s password:
Loading repository data…
Reading installed packages…
Computing distribution upgrade…

Nothing to do.
ajwillis@linux-9i86:~>

So back to the old version of Amarok and I will uninstall vlc and perhaps reinstall after a new release. It’s only the avi files that are troubling me, i can see AVCHD on Dragon Player so it’s not a show stopper just a bit irritating.

Thanks for your help.

regarding amarok I’m just speculating here but it seams that you have some newer libraries from kde-extra that might be causing problems, run amarok from a console and see why it crashes, I have amarok from packman and it’s running fine.
If dragon (which is just a frontend) can play avchd files which in turn should be h264 files vlc should play them too, again open vlc from a console and then try to load those files what’s the error.
repo #6 the PlexRepo looks strange did you install an rpm from it as it seams to be a fedora repo it might be causing problems but it seams to be down.

you don’t need repo #1 as packman already has flash-player you can remove it.
what kind of graphic card and driver do you have as some intel cards have problems with VDPAU.

ps do you have vlc-codecs installed it’s not in the oss repo and it might not get pulled by a dup

Yes I have vlc-codecs installed.

I ran it from a console as suggested and got this;

ajwillis@linux-9i86:~> cvlc /home/ajwillis/Videos/20150726130637.MTS
VLC media player 2.2.1 Terry Pratchett (Weatherwax) (revision 2.2.1-0-ga425c42)
0000000000cccac8] dummy interface: using the dummy interface module…
00007f3084c017d8] ts demux: HDMV registration not implemented for pid 0x1100 type 0x81
00007f3084c82518] core decoder error: Codec `h264’ (H264 - MPEG-4 AVC (part 10)) is not supported.
00007f3084c82518] core decoder error: Codec not supported
00007f3084c82518] core decoder error: VLC could not decode the format “h264” (H264 - MPEG-4 AVC (part 10))

Any ideas?

Thanks for your help.

Did you install from packman the one that comes from openSUSE does not support proprietary codecs.

Go to Yast - software management search for vlc be sure all the vlc stuff you have installed all comes from packman. use the version tab bottom right

Opened amarok from console and I got this.

linux-9i86:~ # amarok /home/ajwillis/Music/Blur/The Magic Whip/02 New World Towers.mp3
amarok: error while loading shared libraries: libvo-aacenc.so.0: cannot open shared object file: No such file or directory

Went back to previous version and ran it through the console and it opened fine.

well you ignored some dependencies while installing something
you just need libvo-aacenc0 from packman as the oss repo does not carry aac encoding libraries

sudo zypper in libvo-aacenc0

just checked my system and libvo-aacenc.so.0 is in \usr\lib64\ it was pulled automatically when I installed amarok or another application that needed aac encoding, as you have packman I’m not sure why it was not installed on your system.

OK Thanks for your help, I installed via Yast and assumed all the dependencies would be automatically accounted for. Anyway I added it and Amarok works, well sort of, it’s a little buggy and crashes on me so I will go back to the stable version.

As for vlc I haven’t got this working at all, I notice that there is no official leap 42.1 version anyway and I shall wait a while and try again. I have spent far too much time on this already.

On the plus side I have learnt a bit more about opensuse Linux and I thank you all for your prompt posts to my queries.

Cheers.

If you have checked that all libraries and codecs involved are indeed from packman, and vlc still cannot play your films, may be you can try this configuration through the vlc settings (tools/preference) :

  1. in video : uncheck Accelerated video output and select X11 video output (VCB)
  2. in Input/Codecs : select VA-API video decoder via X11
  3. in a konsole regenerate the vlc plugin registry with : sudo /usr/lib64/vlc/vlc-cache-gen -f /usr/lib64/vlc/plugins

It worked on my hardware (a Dell Vostro 260). I did not need to modify the default settings of vlc on a laptop, with exactly the same packages installed.
If this works you can try to check back the option Accelerated video output and see how it goes.

LEAP/LXDE on very old hardware (HP pavilion 6000)
Installed the codecs, first using the “one click” method for Gnome and then again for KDE.

The codecs work fine in Totem (the default player) but does not work in VLC.
Tried the steps described above, except that no decoder is specified in the application settings (checked both simple and advanced)

  1. So, there may be an issue with the default settings with VLC. I’m preparing this laptop for someone else, am weighing if it’s worth the effort to go find another decoder.
  2. The “One Click” page should probably specify which codec install (Gnome or KDE) should be installed for “other” Desktops. Based on personal experience with LXDE, I guessed Gnome so installed that first but don’t really know if either choice should actually matter (are there really Desktop-specific packages required?)

Bottom line for now is that VLC is an issue, but other players may work for now.

TSU

VLC works fine here (in a Leap VM).

But you’ll have to install vlc-codecs (I’m not sure if the 1-click install you used contains them), and you should do a full switch to Packman to get the full featured ffmpeg.
Nothing new for Leap, the same is true for previous releases.
But as Leap does contain a (crippled) ffmpeg now (13.2 and before didn’t), the second part (full switch to Packman) might be important, the package dependencies cannot cater for that.

I have never done a 1 click install but vlc works fine for me, actually I am using wolfi’s build of kaffeine 1.3.1 with the libvlc back-end and that one works good too, I’ve opened mp4/mkv/webm/avi/ containers with xvid/h264/vp8 video and mp3/aac audio. I haven’t tried mpeg2 dvd’s or brd’s.
It is strange but installing vlc does not pull vlc-codecs, the same seams to be true for xine libxine2 does not install libxine2-codecs.

The one-click install (see the sticky for this forum) does install packman and install the vlc-codecs package from there.

TSU

Ok, but it definitely doesn’t do a full switch to Packman.

And as I wrote, Leap 42.1 contains (crippled) ffmpeg/libav* packages in the standard repos, so you might have installed them instead of the full-featured Packman versions.

Do a “full repository vendor change” update to Packman, and VLC’s codecs should work:
https://en.opensuse.org/SDB:Vendor_change_update#Full_repository_Vendor_change