Upgrade from 11.0 to 11.1 don't work

Hi,

I have OpenSuse 11.0 installed inside VirtualBox.
I try to upgrade to 11.1 in order to get the latest version of some software (gnuplot,GIMP).
When I add the 11.1 update repository Index of /update/11.1 in Yast I get the following error:

linux-tspw:/home/victor # zypper refresh
Downloading repository ‘Main Repository (NON-OSS)’ metadata [done]
Building repository ‘Main Repository (NON-OSS)’ cache [done]
Downloading repository ‘Main Repository (OSS)’ metadata [done]
Building repository ‘Main Repository (OSS)’ cache [done]
Repository ‘Main Update Repository’ is up to date.
Building repository ‘Main Update Repository’ cache [done]
Error building the cache database:
‘repo2solv.sh’ ‘-o’ ‘/var/cache/zypp/solv/Main_Update_Repository/solv’ ‘/var/cache/zypp/raw/Main_Update_Repository’
into unknown: [0]relogin_suggested (from: 18)

Skipping repository ‘Main Update Repository’ because of the above error.
Repository ‘openSUSE Education’ is up to date.
Repository ‘Packman Repository’ is up to date.
Some of the repositories have not been refreshed because of an error.

Does somebody have an idea how I can remove the error and upgrade?
Thank you.

Victor

  1. you have to change all repos to 11.1
  2. then you have to update zypper and lizypp
  3. then you have to do a distribution upgrade (zypper dup)

There’s a How-To in the WIKI and though it says it’s not “officially” supported for 11.0 I can tell you it works.

Thank you!

indeed after updating the zypper with the command zypper in zypper in works.

Victor