Upgrade failure and workaround

I used the “zypper dup” method to upgrade from 13.1 to 13.2. Reference
The procedure worked well, up until it was time to reboot and start the new install,
at which time it was clear things were not well with Grub2.

My system is a relatively old Asus MB from early in the transition to EFI.
This bios supports both MBR and EFI booting.
I had installed openSUSE (12.2 probably) using MBR method, as I had no need for EFI, and used ‘zypper dup’ to upgrade several times.
For whatever reason, the 13.2 zypper dup process failed to update the MBR (or install Grub2 properly), I got no Grub menu and messages flying by about bad vmlinux images, etc.

I was able to usesTHIS how-to to get Grub2 running again from the MBR.

It has saved my bacon on several occiassions, keep a link handy.
A final note - I booted from the 13.2 upgrade DVD to “Boot the Rescue from the DVD”.
If you want to install an MBR record, make sure you boot the DVD in normal, not UEFI, mode.
My bios tends to want to default to UEFI.
If the DVD is booted in UEFI mode, the grub2-install step does not work.

So how far does the boot get? and What video and what drivers were you using in previous version and can you boot to terminal?

What I did get was no Grub2 Gui, it tried to load/display something which scrolled across the screen.
It finally left a message something like ‘both menu items bad’.

There was no opportunity to boot to level 3

Since I had a suspicion (similar issues migrating / to an SSD) I went directly to the Rescue option and did the reload of Grub2.
That worked, I am up and running again