Upgrade fail

Hi,My system is running over LVM2, so I can make a snapshots for restoring system, changing hdds, mirroring partitions to several hdds…I have a problem to upgrade my 42.3 opensuse to tumbleweed. There are more ways I’have tried.1) online upgradeI have added repos for tumbleweed, changed priority, disabled old repos, logged out from graphic environment, logged in text console, run zypper shell and dup inside of it.Results?After downloading more than 5GB and starting installation, there are a lot of “warning: unsuported version of key: V3” messages.A critical “error: unsuported version of key: V3” message and after that, zypper disappear. No information why, no information about crash, error. There is standard “command prompt” in console. No way to run zypper (or yast) again due uncomplette install of theirs packages.This happen everytime when I start online upgrade.Only LVM2 snapshots save my system and data…2) offline upgradeThis behavior is not new, it last at least several months/years, yast in NET install/upgrade doesn’t support LVM2.I’ve downloaded bootable iso for NET istall (x86_64) on 20th 12. 2018. It should be still working. No matter, if I select “Upgrade” or “Install” there aren’t system partitions detected in YAST. There are only a few of them from LVM volume group.After reboot in this point of Upgrade or install, before it write something to hdds , everything is ok and 42.3 is working - system partitions exist.I am using “zypper dup” for long time (more than 5 years, probably more than 7) and this missing partitions are nothing, I can remember.There are a lot of configurations in my system and I don’t want to lost them. Is there a way to upgrade opensuse 42.3 to tumbleweed? (15.0 is not working well at all)Nice Chrismas.Preema

Hello,

I see this is your first post here. Welcome.

That said, IMHO your post is very difficult to read. No paragraphs, it is one loooong mass of characters.
Please be aware that all here are openSUSE users like you and try to help in their spare time. I am almost sure that some here that started reading will have given up halfway down.

Yes, it is. Apart from the formatting, there is too much detail. So it is hard to get what the question is.

I’m pretty sure those are related to GPG. The latest versions of GPG have deprecated some older key formats. And there are probably some of those older keys in the RPM database.

Perhaps delete the older keys before you add the new repos, and then try repeating the “zypper dup”. You can remove keys with Yast Online Repositories (and click the “GPG Keys” button).

When you add and refresh the new repos (for Tumbleweed), that should add back any keys that you need for those repos.

if 15.0 doesn’t work well, why should tumbleweed be better? i would first see if 15.0 could be made running the regular upgrade path - as tumbleweed is not as stable as you may expect.

to get the upgrade working with very old partitions that may not be detected due to changes in filesystems as btrfs is now default for root. There are Suse descriptions how to make a fresh btrfs-partition creating subvolumes, copy the files from old root and then “mount --bind” system ressources & chroot + setup new system (mkinitrd / install bootloader). If you can you should switch to uefi having a small seperate boot partition. After switching you old system that way to new partition and running it, you should be able to upgrade it in regular a way.

That worked for me migrating to a new setup from 42 to 15 from old hardware and should not touch your running system at all. It was fun and a bit of work, but went well.