Upgrade: 12.2 to 12.3 - Lost GUI

I updated my Dell XPS 8300 (Intel i7) from openSuSE 12.2 to openSuSE 12.3 (both 64 bit) and upon reboot, I can no longer get into graphics mode. I use Gnome as my desktop. In investigating this, I believe it to be driver related. My system has an Nvidia GeForce GT 530 (GF108). Based on that, I’m unsure when looking here: SDB:NVIDIA drivers - openSUSE which driver to install. In dumping the information displayed after booting 12.3, this is what I get:

beast:~ # lspci | grep VGA
01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 530] (rev a1)

beast:~ # hwinfo --gfxcard
19: PCI 100.0: 0300 VGA compatible controller (VGA)
[Created at pci.319]
Unique ID: VCu0.UCvZyosW3kA
Parent ID: vSkL.DJs1WhQjic7
SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
SysFS BusID: 0000:01:00.0
Hardware Class: graphics card
Model: “nVidia VGA compatible controller”
Vendor: pci 0x10de “nVidia Corporation”
Device: pci 0x0de5
SubVendor: pci 0x1b0a
SubDevice: pci 0x90a1
Revision: 0xa1
Memory Range: 0xfa000000-0xfaffffff (rw,non-prefetchable)
Memory Range: 0xf0000000-0xf7ffffff (ro,non-prefetchable)
Memory Range: 0xf8000000-0xf9ffffff (ro,non-prefetchable)
I/O Ports: 0xe000-0xefff (rw)
Memory Range: 0xfb000000-0xfb07ffff (ro,non-prefetchable,disabled)
IRQ: 11 (no events)
I/O Ports: 0x3c0-0x3df (rw)
Module Alias: “pci:v000010DEd00000DE5sv00001B0Asd000090A1bc03sc00i00”
Driver Info #0:
Driver Status: nvidiafb is not active
Driver Activation Cmd: “modprobe nvidiafb”
Driver Info #1:
Driver Status: nouveau is not active
Driver Activation Cmd: “modprobe nouveau”
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #9 (PCI bridge)

Primary display adapter: #19

Any hints as to which Nvidia driver I need to install to get 12.3 to boot into the GUI like my 12.2 installation did?

Thanks in advance.

How exactly did you update 12.2 > 12.3

What about adding nomodeset? Did you try?

I upgraded by burning a DVD with the 12.3 image and booting off of that. After rebooting, I went in through yast (character mode) and did an update after the install.

No, I haven’t tried adding the nomodeset. Please, more details about where to put that.

Ok, got it figured out. I had to go here:

 [Drivers - Download NVIDIA Drivers](http://www.nvidia.com/Download/index.aspx?lang=en-us)

and download Nvidia’s driver for my card, install that and it now comes up in the GUI.


You would need either the G02 or the G03 driver.
If you want to use the 1-click install, just take the first one. (“For all NVIDIA current cards…”)