Upgrade 100.0 -> 11.2 (incl. KDE3->KDE4) -> no mouse and no keyboard in X

I upgraded from 11.0 to 11.2 (the step to 11.3 seemed to big to me) incl. KDE3 to KDE4 update. After the first start it worked quite good. Then I made a zypper dup, and since that I cannot login at kdm because the mouse and the keyboard don’t work. I tried some recommended hacks licke reinstalling hal, setting some options in xorg.conf like disabling kbd (setting AllowEmptyInput to off and AutoAddDevices to off) and some more things. Nothing worked. Today, I tried again a new zypper dup but it didn’t help again. So I’m extremely disappointed after using SUSE for over 10 years now. So far I never had such problems getting a new release to work.
So I’ve made an account here now. I would like to post my xorg.conf and my xorg.0.log but obviously I’m not allowed to post attachments.

Sorry for the typo in the title. I meant 11.0 -> 11.2 of course.

That would not be disabling kbd but disabling evdev and using Driver “kbd” (or “keyboard” ) and Driver “mouse”, respectively in the keyboard and mouse InputDevice sessions.

Try to remove (or rename) it completely!

Your first sentence makes me wonder: How did you upgrade? A new install (keeping a seperate /home partition untouched? I ask because you say you did a zypper dup AFTER that upgrade, where* zypper dup * IS an upgrade to a new level (only realy supported from 11.2 onwards.

I did the update not via new installation but via “system update” (I booted from a burned 11.2 DVD and choosed the system update). After that upgrade I tried a yast online update to get new package updates online which failed somehow. Then I did the zypper dup (on my new 11.2 system) which updated a lot of packages.

I’ve tried that. Didn’t work. But I’ll try it again.

How can I post any attachment?

As long as I’m not be able to post attachment, see the following lines in my Xorg.0.log that make me wonder:

(II) LoadModule: “kbd”
(WW) Warning, couldn’t open module kbd
(II) UnloadModule: “kbd”
(EE) Failed to load module “kbd” (module does not exist, 0)
(II) LoadModule: “mouse”
(WW) Warning, couldn’t open module mouse
(II) UnloadModule: “mouse”
(EE) Failed to load module “mouse” (module does not exist, 0)

It says that the modules don’t exist?? How can that be?

As the “System update” from the install disk never worked satisfactory before 11.2 (that means having 11.2 as a starting point, not as the goal) for most (many posts on these forums) I do not know what you have now as a result…

In principal a *zypper dup *is to go to a next level (you first change all of your repos to the ones for the new level and then do zypper dup) and this is what imho the “system update” on the install disk does.

A zypper up updates packages that have new versions from your normal repos (e.g. Packman).

You can put images and the like other on web services like imagehost and then post the URL here.

Maybe somebody can tell me how to post attachments here.

find /usr/lib*/xorg/modules -name "kbd*" -o -name "mouse*"

Remove or edit the ModulePath option in your /etc/X11/xorg.conf or - probably better - remove or rename /etc/X11/xorg.conf.