Updating to OpenSuse 12.1 when using Nvidia driver

I managed to update my installation of OpenSuse to 12.1 but I found it very unfriendly to do because I had been using the Nvidia driver on my Nvidia card on my previous version. The install process simply dumped me at the command line once the install had completed. and I had to navigate the help (via another box) online to to find the magic incantation to get X working again.

Simple enough but not really good enough, there should be more clues in the update process to tell the naive user what to do. I know that you cannot include the Nvidia or ATI Drivers in the distribution but as the cards are very common and to use OpenGL we often have to use the propriety drivers, you (OpenSuse) could be a bit more informative once you detect that they were used or perhaps used in the previous configuration.

I have not use the update feature. I always do a clean install. My guess if you are using the nvidia proprietary driver prior to update, maybe switch to the nouveau driver first and proceed with the update.

So doing a upgrade to openSUSE 12.1, if that is what you did, is not recommended by myself. Doing a OS upgrade is an option and it most often ends with a copy of openSUSE that boots are starts up, but may leave mixed application versions and orphaned applications. My normal suggestion is to do a clean install, but you only mount and do not format the /home area, leaving all of your application settings. You must reload all previous applications, but once loaded, they use your existing personnel settings. With the install of openSUSE 12.1, you get a new kernel and it will not include your old video driver install, even with an upgrade. When you start the install, change your video setup to VESA. Next, when you get to the point to start the install, edit the install and your Grub menu.lst file and add in the kernel load option** nomodeset**. Next, let the install complete and after the first reboot, update your system as normal, download the most recent nVIDIA driver into your Downloads folder if not already there and reboot. On the second reboot, enter the kernel load option 3 (to select run level 3 and to not load the desktop). The kernel load option nomodeset, should already be there. Log in as root and change to your old user Downloads folder and run the nVIDIA driver install. Once complete, reboot your system again.

For more info on install the nVIDIA driver, read through the following two blogs.

Installing the nVIDIA Video Driver the Hard Way - Blogs - openSUSE Forums

http://forums.opensuse.org/blogs/jdmcdaniel3/lnvhw-load-nvidia-driver-hard-way-runlevel-3-version-1-10-32/

Thank You,

I take it you did not read the update notes kindly supplied by oldpcu.

If you cannot take experienced peoples advice …

I have just been through this myself, this afternoon. Trying to “update” from 11.3 to 12.1 was a FUBAR, so I backed up and did a clean install. Perhaps I could add a few points.

It is an even better idea to get that Nvidia driver download in the bag <before> you do anything else. I am on 64-bit with a Geforce 6800GT and the file was called NVIDIA-Linux-x86_64-290.10.run

I found no need to amend Grub; it has a “safe” mode on the menu with nomodeset already there as a parameter.

Having installed 12.1 and working (not very well) in VGA (Safe) mode, I re-booted at Level 3 (type “3” when the Grub menu is showing - it echoes in the box near the bottom). That boots in CLI mode, in which you change directories to where your driver download is and type “sh ./<driver file name>”. This led into a script which seemed to work well - I accepted all of its suggestions that it would modify existing config files.

Rebooted again and I found it already in 1600x900 resolution for my monitor. Looks great, and stable so far.

This was my guide :-

ftp://download.nvidia.com/XFree86/Linux-x86/1.0-8178/README/chapter-01.html

Thanks to all for replying.

My point was not that I could not solve the problem but that it must be a very common issue and really if the OpenSuse install process gives you the possibility of updating it should help a bit in solving the issue.

I could have done a clean install and gone back and then found and re-installed all the applications that I use, I could have switched to Ubuntu. This is not the issue.

My point was that the Installation and Update process should be so straightforward and simple so that someone (perhaps my mum) would have no difficulty sorting out the issue.

Understood (I was thinking of helping others) and I agree. I have been using Linux for 10 years and still have problems with drivers. Look for advice and you are told for example about modprobe and a modprobe.conf file, but there is no such modprobe.conf in 12.1; the the goalposts keep moving. Again, I have several thick textbooks on Linux, and “Device Drivers” is not even in their indexes, and when I searched the pages of one it said it is “not very hard” and “fun” to write a DD (!) but does not say how to install one, let alone write one.

Perhaps it does not really help that the vendors who DO support Linux, like Nvidia and HP, have their own install scripts rather than doing it “traditionally” whatever that is.

And the video device driver is the most important of all as you cannot do anything without a screen. Even in “Safe” VGA mode my 12.1 installation kept
giving me a black screen or freezing, hardly long enough to download the driver I needed. As for requiring the user to install at Level 3, most people out there are terrified of the CLI let alone changing run levels.

No disrespect to oldpcu, but I’ve never heard of him. I don’t spend all my time here. It would have been nice if you could have given a link to that stuff.

http://forums.opensuse.org/english/get-technical-help-here/how-faq-forums/new-user-how-faq-read-only/467087-new-users-opensuse-12-1-pre-installation-please-read.html

oldcpu is one of the Global Moderators and been here a long time. The link above is an example of what he does here.

Thank You,

Excuse typo, read oldcpu for oldpcu

My comment was with reference to,

](http://forums.opensuse.org/english/get-technical-help-here/how-faq-forums/new-)http://forums.opensuse.org/english/get-technical-help-here/how-faq-forums/new-user-how-faq-read-only/424611-new-users-opensuse-pre-install-general-please-read.html](http://forums.opensuse.org/english/get-technical-help-here/how-faq-forums/new-)

Have a read of post #3

IMHO its a very good point you raise.

SuSE-GmbH stopped having proprietary graphic drivers installed by default with either openSUSE-10.0 or 10.1 … At that time they made a philosophical decision for openSUSE to start using as much as possibly only open source software code (and its been a gradual process still being implemented). I think it was 10.1 when this happened. It did cause a massive debate/discussion at the time, but to a large extent major problems with openSUSE-10.1’s software package management took ‘all the heat’ from dissatisfied users, and perhaps this SuSE-GmbH/Novell decision at that time (of 10.1) was not debated enough ?

Anyway, it is now water under the bridge.

OpenSUSE as many of my GNU/Linux friends who are Ubuntu fans note: is NOT Ubuntu. In openSUSE note the emphasis on ‘open’. Like it or not (and many of my friends do NOT like it) openSUSE adopts a more puritan open source approach than Ubuntu (although still not as open as the true purists like Richard Stalman would like). This means the openSUSE will NOT install the proprietary graphic drivers by default, as they are not open source.

In an effort to make open source graphics more automatic changes were made to :

  • X window to automatically configure graphics - but this does not always work
  • around the same time GNU/Linux kernel to work with automatic configuring of graphics via kernel mode setting (KMS) but this also does not always work.

So its when the automatic configuration does not work, that openSUSE with its philosophy can land in some trouble, requiring users to do something extra.

When the KMS (kernel mode setting) does not work with graphics, what helps sometimes is to turn KMS OFF with the boot code ‘nomodeset’.

The SuSE-GmbH packagers, KNOWING this, put right inside the openSUSE release notes instructions to use the boot code ‘nomodeset’.

… but of course new users simply ignore the release notes … which is unfortunate and results in pain to them in some cases. One should ALWAYS read the release notes for any software.

Anyway, good luck with your graphics efforts, and please note that a GNU/Linux distribution is judged not only by its automatic way to use / integration of proprietary software code, but also judged by other factors as well, including the support given in forums (such as ours) and in IRC chat channels, mailing lists … etc …

As for ‘oldcpu’ handle - my wife does not know who it is either ! (me thinks), as she often refers to me as ‘oldercpu’ (like I’m not old enough already ? … :smiley: ).

Thanks, that stuff looks very useful and I shall now be reading it, and I can see that oldcpu does a lot of good work here. I had looked at it briefly before, but there were a lot of further links there which I did not pursue at the time. I do not remember having much problem with v11.3 a year(?) ago so I just went ahead with installing v12.1.

I think the point still stands that the video driver is the most serious OpenSUSE installation issue - just see how much it comes up in the threads here. It is an area of weakness that could be improved. Bear in mind that there must be many people, the majority probably, who install OpenSUSE (or try) but never come to this forum; I first installed it from a magazine cover DVD myself.