Updating kernel -- command not working

Hi all, I am trying to update my kernel version from to (I am trying to get my wireless card to work, as I posted here. I have been following a tutorial. I am stuck on this step:
"5 Configure The Kernel

It’s a good idea to use the configuration of your current working kernel as a basis for your new kernel. Therefore we copy the existing configuration to /usr/src/linux:

make mrproper
cp /boot/config-`uname -r` 


The make command was not installed at first, so I ran zypper install make, but now when I input “make mrproper,” Output: make: *** No rule to make target `mrproper’. Stop.

Does anybody know what “make mrproper” is supposed to do, why it isn’t working on my machine and how I can make it work/bypass this step? Thanks so much.

Just download your linux flavor from kernel.org and extract to your own
folder in your home directory, then follow user lwfingers nice simple

Note only the install is done with sudo.

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 21:42, 2 users, load average: 0.15, 0.12, 0.09
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 195.36.15

Great, your proposed method seems much easier than the tutorial I was trying to follow.

I extracted the version I want into /home/upgrade/
(I created the directory upgrade) Then I tried to run

cp /proc/config.gz  .
gunzip config.gz
cp config  .config

It said access denied, so I logged into root (although he says to only use root for the install) and was able to run the three commands above.

When I then tried

 make modules_install install 

I got “make: *** No rule to make target `modules_install’. Stop.”

Right now, the contents of /home/upgrade/ are config, .config, and linux- Am I on the right track on far/ why isn’t make modules_install install working? Thanks for the help.

One of the reasons not to be root when running these commands :frowning: In
your previous attempts from the other procedure, where you running as

Can you check who owns your directory(s) in your home now, it should
be /home/<your_user_name>/upgrade not /home/upgrade??

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 23:31, 2 users, load average: 0.01, 0.03, 0.01
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 195.36.15

In my previous attempts at the other procedure, I was running as root.

I ran the same steps to get the files in a directory, /home/xait9/upgrade1/ but I am getting the same errors when I try to use the make command.

In the thread that you referred me too, another person suggested going through YaST to upgrade the kernel version. Would this be easier?

Thanks for your responses, hopefully I can figure out some way to update my version so that I can browse the old internet with some mobility.

Some sample lines from my machine:

xait9@linux-1kp7:~/upgrade1> dir
total 108
-r--r--r--  1 root root 103289 2010-05-17 18:42 config
drwxrwxr-x 23 root root   4096 2010-01-18 13:30 linux-
xait9@linux-1kp7:~/upgrade1> make
make: *** No targets specified and no makefile found.  Stop.
xait9@linux-1kp7:~/upgrade1> sudo make modules_install install
root's password:
make: *** No rule to make target `modules_install'.  Stop.

See if th e files are actually in that directory sometimes a new sub directory is made.

OK, my apologies for missing the link you gave. First off you don’t
need to build the kernel from source unless (as was my impression) you
want to make some other specific changes to the current kernels

In your case all your wanting to do is update your kernel, which means
all you need to do is run the online updates and it will pull the
latest kernel in???

Do you have the online updates repository enabled? If so all you need
to do is run the following;

sudo zypper ref
sudo zypper lu
sudo zypper up

The first command refreshes, second lists and the third applies all the
updates available. If it shows no updates, can you post the output from
the following commands;

uname -a
zypper lr -d

You should see the kernel update in the list? You will also need to
reboot your system

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.2 (i586) Kernel
up 0:06, 2 users, load average: 0.62, 0.66, 0.37
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME