updating java -- firefox no 'plugins' directory??

Hello,

According to java, to update, i need to create a symbolic link to the firefox plugin directory…
my firefox is version 3.0.7 and is installed under /usr/lib/firefox
but it does not have a plugin directory.

Do I just create one? I’m lost.

PS: Java installation was successful, just cant get it to work in firefox.

it will be in your /home/.mozilla directory the “.” ( sometimes known as a period ) denotes it is a hidden file. Open your home folder,then,if using konqueror,select view - show hidden folders & look for Mozilla folder

Andy

in the .mozilla folder i have a folder called Firefox and Extensions, neither of which contains the ‘plugins’ folder… ?

if no one knows of a fix, can someone give me a quick guide as to how to remove everything firefox, and reinstall it cleanly from the firefox download on mozilla.org?
Seems that even when I remove it through yast and then reinstall it (one click install from the opensuse get software link) it does not include the plugins folder. Donno how that’s possible lol, but it -is- included from the download off mozilla.org. Just doesnt seem to want to install.

You need to create the symbolic link in /usr/lib/browser-plugins

Hope this helps!

Edit: Also, did you install via Yast2 or from the Sun Java .rpm?

hi,

i installed via yast, the one click install from this website, and the rpm.

I just tried your suggestion, didnt work. The java test on java.com states that the driver is still outdated, and government of canada website reports that the java applet cannot be started.

Nothing seems to work.

I’m in the process of making a nice little How-to, but for now check out my other thread where I explained how to install java by both Yast and the rpm way. You’ll just need the “create a symbolic link” part of it for whichever method you chose.

help installing jre-6u12-linux-i586-rpm.bin. - openSUSE Forums

The first two posts from me are for Yast

The second two posts from me are for the .rpm.

Hope this helps!

Edit: Unless you’re using the 64-bit version, then there’s already a nice detailed how-to
http://forums.opensuse.org/how-faq-read-only/unreviewed-how-faq/410702-install-up-date-java-jdk-64-bit-firefox-plugin.html

I just tried installing it the Yast way. Now the java test is telling me that Java is not working properly. That’s a step back. lol
I’ll try it the rpm way after I have a smoke. lol frustrated

update: just installed from a yast a plugin called sun java browser plugin or something, and now its back to saying my version of java is outdated. so we’re back to where I once came.

My step by step guide for the .rpm is done. You can view it here.
Installing 32-bit Java from Java.com (rpm terminal yast) - openSUSE Forums

I would recommend uninstalling the Yast version before trying this way out.

Otherwise…

I’m in the process of making another How To for installing from Yast, although this method gets kind of tricky sometimes, so you can wait for that or use the .rpm way which I just wrote and tested out as I was installing from the .rpm.

hello, just tried it out.
When installing the binary, says its already installed.

When trying to create the symlink, says it already exists.

Where is it hanging up on me?

So when you go to the verify site, it still says it’s either not installed or it’s outdated?

Do you have OpenJDK or IcedTea installed?

And also what does

java -version

give you?

Here’s my How To for installing from Yast.
http://forums.opensuse.org/how-faq-read-only/unreviewed-how-faq/410949-installing-32-bit-java-yast-way.html

roger@linux-a16b:~> java -version
java version “1.6.0_0”
IcedTea6 1.4 (suse-24.3.1-i386) Runtime Environment (build 1.6.0_0-b14)
OpenJDK Client VM (build 14.0-b08, mixed mode)

When verifying java version on java.com it says:
Oops! You don’t have the recommended Java installed.
Your Java version is 1.6.0_0. Please click the button below to get the recommended Java for your computer.

When typing about:plugins in firefox, it states IcedTea is installed.

You’ll need to uninstall OpenJDK and IcedTea.

In Yast search for OpenJDK and uninstall any of those packages.

Then search for IcedTea and uninstall any of those packages.

Sorry, I just remembered this after I couldn’t edit you can also try

# update-alternatives --auto java

In a terminal.

Then try java -version again and see what it says.

Looks like I owe you a beer:

roger@linux-a16b:~> java -version
java version “1.6.0_12”
Java™ SE Runtime Environment (build 1.6.0_12-b04)
Java HotSpot™ Client VM (build 11.2-b01, mixed mode)

i uninstalled OpenJDK, and it works good now. geez…

thanks.

Haha I’m only 19, and in the US I’m not “legally” allowed to drink beer yet.

So a good ol’ click on that reputation button will do :wink:

Glad to be of some assistance,

Ian

legal shmegal. lol