updating bios?

ok… this is probly not the best place to ask… but im asking everywhere else too…
basically, i have Opensuse 11.1 installed on my Acer Aspire Netbook… my netbook like many others has a fault where the battery stops charging after a while… fortunately it is not a hardware fault… the fix is to update the bios with a patch from Acer…

problem is… its an .exe file…
i have read about a work around… and that is to install FreeDos on a usb stick… put the patch on the usb stick, and execute it through freedos… So far i have managed to boot into freedos, access the bios folder… but i can’t execute the patch. The patch is named InsydeFlash.exe… everytime i try and execute it i get a bad command etc… i read to execute you just type in the name… but i tried everything… InsydeFlash… InsydeFlash.exe … run InsydeFlash.exe… i’ve tried renaming it to a .bat file and executing that… still get a bad command entered error…

anybody know where im going wrong?

That exe file is a windows utility not a dos one and not a BIOS patch?

Have you downloaded and extracted the update to the USB stick, it
should be a <something>.bat file.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 (i586) Kernel
up 1 day 10:59, 1 user, load average: 0.17, 0.18, 0.17
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME

i’ve never used FreeDos, but THINKING OUT LOUD, if it is like the old
MS-DOS and DR-DOS then it can only accept a file name with up to eight
characters then a dot and then three more…

so, i GUESS if you change the name of the executable InsydeFlash.exe
to something like flash.exe it might work…

BUT, if you brick your computer do NOT come crying to me because my
ONLY advice to you is to contact Acer and ask them why they provide
you an executable for an operating system which is NOT on the product
they sold you, and to please send you a Linux executable RIGHT NOW!!!


all the files contained in the folder they gave me are .exe’s and .dll’s. no .bat’s…
i also tried renaming it to under 8 characters and still no luck… argghhhh frustrating… how hard is it to update your bios i linux?? lol… stupid acer and their faulty battery

I did a search on insydeflash and it seems it’s a Windows program so there’s no avoiding Windows if you need to use it.

Do you not have a Windows partition left on your netbook? Sometimes that’s the only reason to retain that partition, to do things manufacturers won’t let you do with other OSes.

Finally got it fixed! I chose to ignore the stupid patch Acer sent me which contained .exe’s etc… and downloaded the latest bios update for my model from their website and installed it via via Freedos Live usb stick thanx to UnetBootin and typed in the name of the bat file which was simply… 3309 and it flashed my bios and fixed my battery charge problem. wooohoooooo. hope this helps somebody else too

:slight_smile: im happy now

> how hard is it to update your bios i linux??

have a look at these:

i didn’t take the time to try to find WHERE you got the bios update
package from…but, did you happen to look THERE to see if Acer
provided any instructions on exactly HOW to flash the bios?

manufacturers usually do because it is rather IMPORTANT to do it
right, or you turn your machine into a door stop (are you listening??)

so, go back to the acer site and have a LOOK again…


as i said… All fixed now :slight_smile: Those links are not from Acer… and Acer doesn’t explain how to do it in Linux on their website.
I found out how to do it in linux via a non official method…ie same method in the links you posted. Acer was not much help in this matter, although they did arrange to send a usb stick in the mail to me with a linux friendly patch for my bios…I don’t know why they just didn’t tell me I could use the 3306 bios update and boot from a Freedos live usb to fix the problem. but i couldn’t wait a whole week or more to get it, so I did it with a live FreeDos usb. I guess Acer doesn’t support this method, But Works perfect now. wooot

oh, and the original patch i was trying to use was Sent to me by Acer to my email address… I told them i use linux, not windows… but the guy sent me a patch with .exe’s and .dll’s… He didn’t tell me I could just use the 3306 bat file on their website that would do the same **** thing. arghhh. Crap telephone support for linux! and they even sell Linux on some of their products…:sarcastic: