updating ask 500 other updates

trying to update my leap 15.1 and yast ask me a lot of things, is it safe to accept? or what I have to do?
for example updating dolphin,but many others ask me this:


```php
#### YaST2 conflicts list - generated 2020-06-04 16:52:21 #### 
 
dolphin-20.04.1-lp151.214.2.x86_64 richiede libQt5Core.so.5(Qt_5.15)(64bit), ma non è possibile fornire questa richiesta 
provider non installabili: libQt5Core5-5.15.0-lp151.2.1.x86_64[KDE:/Qt5] 
     ] Verranno eseguite le azioni indicate: 
disinstallazione di python3-qt5-5.13.2-lp151.161.1.x86_64 
disinstallazione di openshot-qt-2.4.1-lp151.2.61.noarch 
disinstallazione di libqt5-qtwebengine-5.14.1-lp151.7.1.x86_64 
disinstallazione di libdigikamcore6-6.4.0-lp151.205.4.x86_64 
disinstallazione di falkon-kde-3.1.0-lp151.18.2.x86_64 
disinstallazione di falkon-3.1.0-lp151.18.2.x86_64 
disinstallazione di digikam-plugins-6.4.0-lp151.205.4.x86_64 
disinstallazione di marble5-20.04.0-lp151.277.2.x86_64 
disinstallazione di plasma5-addons-5.18.5-lp151.264.1.x86_64 
disinstallazione di libksysguard5-5.18.5-lp151.256.1.x86_64 
disinstallazione di signon-ui-0.17+20171022-lp151.9.3.x86_64 
disinstallazione di messagelib-20.04.0-lp151.169.1.x86_64 
downgrade di marble-20.04.0-lp151.1.2.x86_64 a marble-15.04.3-lp151.13.1.x86_64 
installa marble-15.04.3-lp151.13.1.x86_64 (con cambio di fornitore) 
  obs://build.opensuse.org/KDE  -->  obs://build.opensuse.org/home:wolfi323 
disinstallazione di libmarblewidget-qt5-28-20.04.0-lp151.1.2.x86_64 
disinstallazione di libksieve-20.04.0-lp151.151.1.x86_64 
disinstallazione di libKPimGAPICore5-20.04.0-lp151.142.1.x86_64 
downgrade di kontact-20.04.0-lp151.121.1.x86_64 a kontact-4.14.10-lp151.12.1.x86_64 
installa kontact-4.14.10-lp151.12.1.x86_64 (con cambio di fornitore) 
  obs://build.opensuse.org/KDE  -->  obs://build.opensuse.org/home:wolfi323 
installa libkde4-4.14.38-lp151.78.3.x86_64 (con cambio di fornitore) 
  obs://build.opensuse.org/KDE  -->  obs://build.opensuse.org/home:wolfi323 
disinstallazione di kdepim-runtime-20.04.1-lp151.224.1.x86_64 
disinstallazione di kdepim-addons-20.04.0-lp151.162.1.x86_64 
disinstallazione di kaccounts-providers-20.04.1-lp151.181.1.x86_64 
downgrade di akregator-20.04.0-lp151.137.1.x86_64 a akregator-4.14.10-lp151.12.1.x86_64 
installa akregator-4.14.10-lp151.12.1.x86_64 (con cambio di fornitore) 
  obs://build.opensuse.org/KDE  -->  obs://build.opensuse.org/home:wolfi323 
disinstallazione di marble5-lang-20.04.0-lp151.277.2.noarch 
disinstallazione di marble5-data-20.04.0-lp151.277.2.noarch 
disinstallazione di kontact5-lang-20.04.0-lp151.210.1.noarch 
disinstallazione di akregator5-lang-20.04.0-lp151.238.1.noarch 
disinstallazione di plasma5-addons-lang-5.18.5-lp151.264.1.noarch 
disinstallazione di plasma5-workspace-libs-5.18.5-lp151.517.1.x86_64 
disinstallazione di plasma5-workspace-5.18.5-lp151.517.1.x86_64 
disinstallazione di plasma5-desktop-5.18.5-lp151.422.1.x86_64 
disinstallazione di libksysguard5-lang-5.18.5-lp151.256.1.noarch 
disinstallazione di ksysguard5-5.18.5-lp151.262.1.x86_64 
disinstallazione di messagelib-lang-20.04.0-lp151.169.1.noarch 
downgrade di kmail-20.04.0-lp151.146.1.x86_64 a kmail-4.14.10-lp151.12.1.x86_64 
installa kmail-4.14.10-lp151.12.1.x86_64 (con cambio di fornitore) 
  obs://build.opensuse.org/KDE  -->  obs://build.opensuse.org/home:wolfi323 
disinstallazione di marble-lang-20.04.0-lp151.1.2.noarch 
disinstallazione di marble-kde-20.04.0-lp151.1.2.x86_64 
downgrade di marble-doc-20.04.0-lp151.1.2.noarch a marble-doc-15.04.3-lp151.13.1.noarch 
installa marble-doc-15.04.3-lp151.13.1.noarch (con cambio di fornitore) 
  obs://build.opensuse.org/KDE  -->  obs://build.opensuse.org/home:wolfi323 
downgrade di marble-data-20.04.0-lp151.1.2.noarch a marble-data-15.04.3-lp151.13.1.noarch 
installa marble-data-15.04.3-lp151.13.1.noarch (con cambio di fornitore) 
  obs://build.opensuse.org/KDE  -->  obs://build.opensuse.org/home:wolfi323 
disinstallazione di libksieve-lang-20.04.0-lp151.151.1.noarch 
disinstallazione di libkgapi-lang-20.04.0-lp151.142.1.noarch 
disinstallazione di kontact-lang-20.04.0-lp151.121.1.noarch 
disinstallazione di kdepim-addons-lang-20.04.0-lp151.162.1.noarch 
disinstallazione di akregator-lang-20.04.0-lp151.137.1.noarch 
disinstallazione di signon-plugin-oauth2-0.24-lp151.15.3.x86_64 
disinstallazione di libKF5MailCommon5-20.04.0-lp151.145.1.x86_64 
disinstallazione di akonadi-import-wizard-20.04.0-lp151.127.1.x86_64 
disinstallazione di libastro-qt5-1-20.04.0-lp151.277.2.x86_64 
downgrade di libastro1-20.04.0-lp151.1.2.x86_64 a libastro1-15.04.3-lp151.13.1.x86_64 
installa libastro1-15.04.3-lp151.13.1.x86_64 (con cambio di fornitore) 
  obs://build.opensuse.org/KDE  -->  obs://build.opensuse.org/home:wolfi323 
downgrade di knemo-0.7.7git.20191016T164055~e5a3984-lp151.3.2.x86_64 a knemo-0.7.7-lp151.1.2.x86_64 
installa knemo-0.7.7-lp151.1.2.x86_64 (con cambio di fornitore) 
  obs://build.opensuse.org/KDE:Extra  -->  obs://build.opensuse.org/home:wolfi323 
disinstallazione di pim-sieve-editor-20.04.0-lp151.117.1.x86_64 
disinstallazione di showfoto-6.4.0-lp151.205.4.x86_64 
downgrade di digikam-6.4.0-lp151.205.4.x86_64 a digikam-4.14.0-lp151.66.1.x86_64 
installa digikam-4.14.0-lp151.66.1.x86_64 (con cambio di fornitore) 
  obs://build.opensuse.org/KDE:Extra  -->  obs://build.opensuse.org/home:wolfi323 
disinstallazione di libKPimGAPITasks5-20.04.0-lp151.142.1.x86_64 
disinstallazione di libKPimGAPIContacts5-20.04.0-lp151.142.1.x86_64 
disinstallazione di libKPimGAPICalendar5-20.04.0-lp151.142.1.x86_64 
disinstallazione di kmailtransport-20.04.0-lp151.166.1.x86_64 
downgrade di ktnef-20.04.0-lp151.146.1.x86_64 a ktnef-4.14.10-lp151.12.1.x86_64 
installa ktnef-4.14.10-lp151.12.1.x86_64 (con cambio di fornitore) 
  obs://build.opensuse.org/KDE  -->  obs://build.opensuse.org/home:wolfi323 
downgrade di korganizer-20.04.0-lp151.126.1.x86_64 a korganizer-4.14.10-lp151.12.1.x86_64 
installa korganizer-4.14.10-lp151.12.1.x86_64 (con cambio di fornitore) 
  obs://build.opensuse.org/KDE  -->  obs://build.opensuse.org/home:wolfi323 
disinstallazione di kdepim-runtime-lang-20.04.1-lp151.224.1.noarch 
downgrade di kaddressbook-20.04.0-lp151.122.1.x86_64 a kaddressbook-4.14.10-lp151.12.1.x86_64 
installa kaddressbook-4.14.10-lp151.12.1.x86_64 (con cambio di fornitore) 
  obs://build.opensuse.org/KDE  -->  obs://build.opensuse.org/home:wolfi323 
disinstallazione di kaccounts-providers-lang-20.04.1-lp151.181.1.noarch 
disinstallazione di falkon-lang-3.1.0-lp151.18.2.noarch 
disinstallazione di falkon-gnome-keyring-3.1.0-lp151.18.2.x86_64 
disinstallazione di powerdevil5-5.18.5-lp151.260.1.x86_64 
disinstallazione di plasma5-workspace-lang-5.18.5-lp151.517.1.noarch 
disinstallazione di plasma5-workspace-branding-openSUSE-84.87~git20190606T185118~3d37a0c-lp151.418.2.noarch 
disinstallazione di plasma5-session-5.18.5-lp151.517.1.noarch 
disinstallazione di plasma5-desktop-lang-5.18.5-lp151.422.1.noarch 
disinstallazione di plasma5-desktop-emojier-5.18.5-lp151.422.1.x86_64 
disinstallazione di ksysguard5-lang-5.18.5-lp151.262.1.noarch 
disinstallazione di kmail5-lang-20.04.0-lp151.259.1.noarch 
disinstallazione di kmail-lang-20.04.0-lp151.146.1.noarch 
disinstallazione di akonadi-import-wizard-lang-20.04.0-lp151.127.1.noarch 
disinstallazione di pim-data-exporter-20.04.0-lp151.121.1.x86_64 
disinstallazione di mbox-importer-20.04.0-lp151.119.1.x86_64 
disinstallazione di libKPimImportWizard5-20.04.0-lp151.127.1.x86_64 
downgrade di ktorrent-5.1.2-lp151.56.4.x86_64 a ktorrent-4.3.1-lp151.26.60.x86_64 
installa ktorrent-4.3.1-lp151.26.60.x86_64 (con cambio di fornitore) 
  obs://build.opensuse.org/KDE:Extra  -->  obs://build.opensuse.org/home:wolfi323 
disinstallazione di systemsettings5-5.18.5-lp151.257.1.x86_64 
disinstallazione di khotkeys5-5.18.5-lp151.247.1.x86_64 
disinstallazione di kde-cli-tools5-5.18.5-lp151.270.1.x86_64 
downgrade di kget-20.04.0-lp151.1.1.x86_64 a kget-17.08.3-lp151.17.3.x86_64 
installa kget-17.08.3-lp151.17.3.x86_64 (con cambio di fornitore) 
  obs://build.opensuse.org/KDE  -->  obs://build.opensuse.org/home:wolfi323 
disinstallazione di sddm-theme-openSUSE-84.87~git20190606T185118~3d37a0c-lp151.418.2.noarch 
disinstallazione di knemo-lang-0.7.7git.20191016T164055~e5a3984-lp151.3.2.noarch 
disinstallazione di pim-sieve-editor-lang-20.04.0-lp151.117.1.noarch 
downgrade di digikam-lang-6.4.0-lp151.205.4.noarch a digikam-lang-4.14.0-lp151.66.1.noarch 
installa digikam-lang-4.14.0-lp151.66.1.noarch (con cambio di fornitore) 
  obs://build.opensuse.org/KDE:Extra  -->  obs://build.opensuse.org/home:wolfi323 
disinstallazione di libKF5MailTransportAkonadi5-20.04.0-lp151.166.1.x86_64 
disinstallazione di libKF5MailTransport5-20.04.0-lp151.166.1.x86_64 
disinstallazione di kmailtransport-lang-20.04.0-lp151.166.1.noarch 
disinstallazione di korganizer5-lang-20.04.0-lp151.208.1.noarch 
disinstallazione di kaddressbook5-lang-20.04.0-lp151.205.1.noarch 
disinstallazione di ktnef-lang-20.04.0-lp151.155.1.noarch 
disinstallazione di korganizer-lang-20.04.0-lp151.126.1.noarch 
disinstallazione di kaddressbook-lang-20.04.0-lp151.122.1.noarch 
disinstallazione di powerdevil5-lang-5.18.5-lp151.260.1.noarch 
disinstallazione di plasma5-session-wayland-5.18.5-lp151.517.1.noarch 
disinstallazione di pim-data-exporter-lang-20.04.0-lp151.121.1.noarch 
disinstallazione di mbox-importer-lang-20.04.0-lp151.119.1.noarch 
disinstallazione di kget5-lang-20.04.0-lp151.258.1.noarch 
disinstallazione di systemsettings5-lang-5.18.5-lp151.257.1.noarch 
disinstallazione di khotkeys5-lang-5.18.5-lp151.247.1.noarch 
disinstallazione di kde-cli-tools5-lang-5.18.5-lp151.270.1.noarch 
disinstallazione di kget-lang-20.04.0-lp151.1.1.noarch 
downgrade di ktorrent-lang-5.1.2-lp151.56.4.noarch a ktorrent-lang-4.3.1-lp151.26.60.noarch 
installa ktorrent-lang-4.3.1-lp151.26.60.noarch (con cambio di fornitore) 
  obs://build.opensuse.org/KDE:Extra  -->  obs://build.opensuse.org/home:wolfi323 
disinstallazione di sddm-branding-openSUSE-0.18.1-lp151.79.2.x86_64 
disinstallazione di patterns-kde-kde_plasma-20181130-lp151.88.1.noarch 
disinstallazione di libKF5IncidenceEditor5-20.04.0-lp151.145.1.x86_64 
disinstallazione di libKF5AkonadiCalendar5-20.04.0-lp151.171.1.x86_64 
disinstallazione di kmail-account-wizard-20.04.0-lp151.123.1.x86_64 
disinstallazione di patterns-kde-kde_imaging-20181130-lp151.88.1.noarch 
disinstallazione di patterns-kde-kde-20181130-lp151.88.1.noarch 
installa kdebase4-workspace-libs-4.11.22-lp151.72.1.x86_64 (con cambio di fornitore) 
  openSUSE  -->  obs://build.opensuse.org/home:wolfi323 
disinstallazione di akonadi-plugin-calendar-20.04.0-lp151.171.1.x86_64 
disinstallazione di akonadi-calendar-lang-20.04.0-lp151.171.1.noarch 
disinstallazione di kmail-account-wizard-lang-20.04.0-lp151.123.1.noarch 
disinstallazione di libKF5EventViews5-20.04.0-lp151.145.1.x86_64 
disinstallazione di libKF5CalendarSupport5-20.04.0-lp151.145.1.x86_64 
disinstallazione di akonadi-calendar-tools-20.04.0-lp151.122.1.x86_64 
installa akonadi-server-20.04.1-lp151.360.1.x86_64 (con cambio di fornitore) 
  obs://build.opensuse.org/KDE  -->  obs://build.opensuse.org/home:wolfi323 
disinstallazione di akonadi-calendar-tools-lang-20.04.0-lp151.122.1.noarch 
     ] non installare dolphin-20.04.1-lp151.214.2.x86_64 
 
     ] interrompi dolphin-20.04.1-lp151.214.2.x86_64 ignorando alcune delle sue dipendenze 
 
 
 
 
#### YaST2 conflicts list END ### 
 

Again, your repos please


zypper lr -d

To get output in english use prefix:

LANG=EN

Better use


LANG=C zypper lr -d

As EN locale does not exist, it falls back to C anyway :slight_smile:

here is:

procuste@server3TW:~> su -
Password: 
server3TW:~ # LANG=C zypper lr -d
#  | Alias                                               | Name                                                | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                                      | Service
---+-----------------------------------------------------+-----------------------------------------------------+---------+-----------+---------+----------+--------+----------------------------------------------------------------------------------------------------------+--------
 1 | Emulators:/Wine                                     | suse-Emulators:/Wine                                | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/Emulators:/Wine/openSUSE_Leap_15.1/                            |        
 2 | GNOME:/Apps                                         | GNOME:/Apps                                         | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/GNOME:/Apps/openSUSE_Leap_15.1/                                |        
 3 | KDE:/Applications/KDE_Frameworks5                   | KDE:/Applications/KDE_Frameworks5                   | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Applications/KDE_Frameworks5_openSUSE_Leap_15.1/          |        
 4 | KDE:/Frameworks5                                    | KDE:/Frameworks5                                    | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_Leap_15.1/                           |        
 5 | KDE:/Qt5                                            | KDE:/Qt5                                            | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Qt5/openSUSE_Leap_15.1/                                   |        
 6 | agg-driver-scanner-epson                            | agg-driver-scanner-epson                            | No      | ----      | ----    |   99     | NONE   | dir:/home/procuste/agg/agg-hardware/driver-scanner-epson                                                 |        
 7 | download.opensuse.org-non-oss                       | Repository principale (NON-OSS)                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.1/repo/non-oss/                                        |        
 8 | download.opensuse.org-non-oss_1                     | Repository degli aggiornamenti (Non-Oss)            | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.1/non-oss/                                                   |        
 9 | download.opensuse.org-oss                           | Repository principale (OSS)                         | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.1/repo/oss/                                            |        
10 | download.opensuse.org-oss_1                         | Repository principale degli aggiornamenti           | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.1/oss                                                        |        
11 | google-chrome                                       | google_(chrome)                                     | No      | ----      | ----    |   99     | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64                                                      |        
12 | home:/AndnoVember:/LXQT(copyq)                      | home:/AndnoVember:/LXQT(copyq)                      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/AndnoVember:/LXQT/openSUSE_Leap_15.1/                    |        
13 | home:/wolfi323:/branches:/KDE:/Frameworks5(beclock) | home:/wolfi323:/branches:/KDE:/Frameworks5(beclock) | Yes     | (r ) Yes  | Yes     |  110     | rpm-md | http://download.opensuse.org/repositories/home:/wolfi323:/branches:/KDE:/Frameworks5/openSUSE_Leap_15.1/ |        
14 | http-download.opensuse.org-7ba65c3b                 | KDE:Extra                                           | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_Leap_15.1/                                 |        
15 | openSUSE_Leap_15.0                                  | suse-security:/chipcard(pcsclite)                   | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/security:/chipcard/openSUSE_Leap_15.1/                         |        
16 | openSUSE_Leap_15.0_1                                | home:/luckyb69(luckybackup)                         | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/repositories/home:/luckyb69/openSUSE_Leap_15.0/                             |        
17 | openSUSE_Leap_15.1                                  | suse-LibreOffice:/6.4                               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/LibreOffice:/6.4/openSUSE_Leap_15.1/                           |        
18 | openSUSE_Leap_15.1_1                                | suse-server:/messaging(telegram)                    | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/server:/messaging/openSUSE_Leap_15.1/                          |        
19 | openSUSE_Leap_15.1_2                                | suse/graphics (libpoppler97)                        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.opensuse.org/repositories/graphics/openSUSE_Leap_15.1/                                  |        
20 | opensuse-guide.org-repo                             | Libdvdcss Repository                                | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_15.1/                                                       |        
21 | packman.inode.at-suse                               | Packman Repository                                  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_Leap_15.1/                                                         |        
22 | repo-debug                                          | openSUSE-Leap-15.1-Debug                            | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/debug/distribution/leap/15.1/repo/oss/                                      |        
23 | repo-debug-non-oss                                  | openSUSE-Leap-15.1-Debug-Non-Oss                    | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/debug/distribution/leap/15.1/repo/non-oss/                                  |        
24 | repo-debug-update                                   | openSUSE-Leap-15.1-Update-Debug                     | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/debug/update/leap/15.1/oss/                                                 |        
25 | repo-debug-update-non-oss                           | openSUSE-Leap-15.1-Update-Debug-Non-Oss             | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/debug/update/leap/15.1/non-oss/                                             |        
26 | repo-source                                         | openSUSE-Leap-15.1-Source                           | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/source/distribution/leap/15.1/repo/oss/                                     |        
27 | repo-source-non-oss                                 | openSUSE-Leap-15.1-Source-Non-Oss                   | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/source/distribution/leap/15.1/repo/non-oss/                                 |        
28 | suse-Printing(hplip_cups)                           | suse-Printing(hplip cups)                           | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/Printing/openSUSE_Leap_15.1/                                   |        
29 | suse-Publishing(pdfchain)                           | suse-Publishing(pdfchain)                           | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/Publishing/openSUSE_Leap_15.1/                                 |        
30 | suse-Virtualization(virtualbox)                     | suse-Virtualization(virtualbox)                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/Virtualization/openSUSE_Leap_15.1/                             |        
31 | suse-filesystems                                    | suse-filesystems                                    | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.opensuse.org/repositories/filesystems/openSUSE_Leap_15.1/                               |        
32 | suse-hardware(cyanogen)                             | suse-hardware(cyanogen)                             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/hardware/openSUSE_Leap_15.1/                                   |        
33 | suse-network(nextcloud)                             | suse-network(nextcloud)                             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/network/openSUSE_Leap_15.1/                                    |        
server3TW:~ # 


That is a mess, and a guarantee for problems. I’ve told you a number of times before, as well have others. In other words ‘totally self inflicted’. Sorry to say so. And since you persist in ignoring advice I see no use in wasting my time to try help and fix this.

All of this comes from the fact that dolphin and Qt are most probably installed from different repos or maybe some repo is not yet fully rebuilt, which is not a surprize considering this horrible mess of repos you have. Ability to have many repos comes at a price of REALLY understanding what you are doing and where do you want the specific package to come from. Right now solver cannot find the proper place to get libQt5Core from and suggests to uninstall a load of things and basically switch your apps from current 20.04 back to KDE4 era (version 4.14.0, thanks to home:wolfi323 repo you have enabled).
If that’s what you had in mind when “updating” dolphin then yes, please accept the suggestion, but it seems to me that it’s not your expected result.
The proper way of solving this is manually updating desired packages using zypper with “–from” key to specify the desired repo for updated package.

manythanks, it worked lol!, I didn’t used zypper --from but directly yast, I updated from every single repo leaving unupdated the packages that was requiring the 500 update, and a reboot after the firsts updates solved also becouse there wasn’t any other 500update requests

sorry to gives you the impression to waste your time :(, but, with these repos my system works as I like excluding sometimes updates problems and language mixing, I’ll wait leap 15.2 to see if it works better with less repos :shame:

Well, really sorry to say so, but given the fact that you run into the same problems over and over again and I’ve told you a number of times not to try and create some kind of untested TW from Leap I can’t see how you state ‘it works as I like’. It doesn’t. Applying updates without trouble is part of how a system runs.

Hi
Not really sure why you just don’t run Tumbleweed? You do realize that you can request any package on the build service to be included in Tumbleweed, as long as it’s in a development repository, if a home repository then you would need to submit to a development project? Now, it is up to the maintainer if they want it there and maintain, but at least you (as an end user) know the decision…

For your current hybrid setup, what are you looking at by using home/development repositories for different packages, is it package features, or some idea that having the latest is important? These sorts of issues can be mitigated via a bug report (esp if you think it’s security related) and say hey, is it possible to back port such-and-such, it happens all the time with the likes of the kernel, a user needs driver x in kernel y for hardware z…

Do you ever look at the changelogs as to why the package has been updated to a newer version, I have some in Tumbleweed that upstream have a later release, but have not bothered to update, why because upstream have released a new version and it might just be a minor change to the README, or a translation fix, all do not change any features or functionality present…

How do you know that for argument sake that a hplip fix will be in release X.Y.Z is in the development repository, but you have installed from there, but this fix may have been back ported into the Leap release A.B.C.

Just my 2 cents worth :wink:

I would agree. I have wondered why pier_andreit is not using Tumbleweed.

I do understand the idea of using Leap for stability. That’s why I am using Leap. But using Leap in a way that brings a lot of instability – I just don’t see the point of that.

I tried to use TW in my desktop, that is also a small sftp/smb/http/server, in the past but it didn’t worked very well, much many instabilities than the stable with added repositories, and the last time I tried on my laptop but this happens:
https://forums.opensuse.org/showthread.php/540070-tumbleweed-hang-after-boot-afteer-dup
and until now, for my lack of time and skills of course, I didn’t recovered my TW installation and I’m using a leap 15.1 installation to use my laptop trying to recover many things from the TW partition and installing many packages I use and again I didn’t succeed to use vpn as in the TW installation I did, so, TW is too dangerous for me, and as I said in the thread:

…yes, may be TW is not for me lol!, I was prepared to have a non stable release as said in
Portal:Tumbleweed - openSUSE Wiki

[QUOTE]“…Tumbleweed is updated once Factory’s bleeding edge software has been integrated, stabilized and tested. Tumbleweed contains the latest stable applications and is ready and reliable for daily use…”
, I didn’t expected the perfection not everything “integrated, stabilized and tested …stable applications and is ready and reliable for daily use”

but at least the fundamental, boot, login, network. but it seems not:sarcastic:[/QUOTE]
and manythanks again for the help lol!

Hi
Your welcome… if your running local services, consider the likes of the Raspberry Pi, the new RPi4’s have 8GB of RAM now, they were available for $35 last week… I use two (Leap 15.1 and SLES 15 SP1) for just DNS/Pihole services, but they run the likes of nextcloud fine, just attach USB storage (or an adapter for SATA)… good low cost solution…

I don’t know what you did to TW, but I’m running it on a couple of servers without any instabilities. The repolist you showed for Leap 15.1 is a guarantee for those.

manythanks for the suggestion, I considered it about 4 years ago, but the desktop is also used by my son and nephews as PC to do things with scanner, gimp, internet, printers, music and many other softwares, it has olso 8 hard disks where tv series and movies are stored and viewed in the network, at the end I needed a big container for storage and a pc and a raspberry, so I unified all the things, but now the prices and the performances are very better and the next hardware renewing I’ll consider it againlol! the concept of separate functions with raspberrys appear a good thing

…you are better skilled and expert than me, so for you problems are less dangerous and easily solvable, with the last TW I used the standard TW repositories, but after a zypper dup it stopped to works, probably due to a plymouth crash and instability, in the past I don’t remember what was the instabilities but I preferred to pass to opensuse 42.x or leap I don’t remember.
about the repolist in my leap 15.1 maybe, but without adding that repositories the system didn’t works as I like, for many reasons, hardware and many other things that likes to my nephews :slight_smile: