Updating amarok with zypper

I added Index of /repositories/KDE:/Backports/openSUSE_11.2

The opensuse.org says: If you just want the latest versions of e.g. amarok, digikam etc. you don’t need to upgrade all of KDE, just add the Backports repo maintained by the openSUSE KDE Team.

I want to update the Amarok to the new version (2.3) with zypper but I cant.

linux-5kpn:/home/saeed # sudo zypper wp amarok
Loading repository data…
Reading installed packages…
S | Name | Type | Version | Arch | Repository
v | amarok | package | 2.3.0-6.1 | i586 | Backport
i | amarok | package | 2.1.1-7.6 | i586 | openSUSE-11.2-Oss

I tried

zypper install --repo Backport amarok

And I get:
saeed@linux-5kpn:~> sudo zypper install --repo Backport amarok
Loading repository data…
Reading installed packages…
‘amarok’ is already installed.
Resolving package dependencies…

Please help.

Please post

zypper lr -d

Did you try removing amarok first ?

zypper rm amarok


zypper in Backport:amarok

I don wanna Remove, then Install new version.
Look, when you choose “Update” for some packages in Yast |Software Manager, it only installs new versions and it doesnt remove any older package. What’s behind this kind of updating with Yats?
I need what Yast does!
Anyone knows?

updating and changing is two different things. Updates are patches normally.

If you try to install two different version you will likely tun into problems. I suspect the Yast removes the old package and replaces with new. In any case you could do it from Yast. You just need the repository.

Yast doesnt remove anything.
If it removes, when you click Accept, it shows what is doing. There is no “Removing x” .
Please help, I want to do it with zypper.

Something’s going terribly wrong here. AFAIK the Backport repo is for KDE, not KDE4 …
If you want the latest Amarok, you need the Community and Playground repo’s for your openSUSE&KDE4 version.

Like Caf wrote, post output of

zypper lr -d

zypper in $PACKAGENAME=$VERSION # all versions

zypper in $PACKAGENAME-$VERSION # zypper >= 1.2.8 from 11.2 not sure with older version



will work.