updates "stuck:" not updating

I have 2 updates on 11.0 that are stuck:

# zypper list-updates
Reading installed packages...

Repository            | Name                         | Version | Category    | Status
openSUSE-11.0-Updates | fileshareset                 | 124     | recommended | Needed
openSUSE-11.0-Updates | kdenetwork3-InstantMessenger | 235     | recommended | Needed

I have rebuilt the rpm database, refreshed zypper, manually installed the updated rpms from the update repo, downgraded with yast and updated with zypper and I even went so far as to uninstall these 2 packages.

Nothing has worked so far, zypper still thinks that 1) they are still installed, and 2) that they need updating.

How do I get zypper completely refresh its cache so it no longer tries to update packages that aren’t installed, or at least mark packages it has updated as updated?

Just tried moving /var/cache/zypp to /var/cache/zypp.brainded and running zypper ref -f. Still having the problem.

That was a bug, which should have been fixed. You don’t want them.!

Check in bugs about it