Updates failed - happens every time I boot up

I still have the update widget in the taskbar tray. Since the upgrade to 15.2 from 15.2, it never completes an automatic updates check.
I have to do it manually.
Is this inherent with 15.2?
or with an upgrade from 15.1 to 15.2?

Where do I look for a ‘fix’? (if there is a fix)

TIA Bill_L

That sometimes happens here – but not every time. This was a clean install of 15.2, though the install was back at the beta testing stage.

Good to know it is not just me, but it does happen with every boot, even if I reboot just to ‘test’ it out.
Not a ‘killer’ but very disconcerting.

You can probably run

pkcon refresh

from a terminal (konsole) – no need for root – and that will likely clear the problem for the current login session.

Did that, thanks. I’ll see if ti helps.
Now I have to go learn about that command via searches and man pages.(still got a lot to learn)

There is a man page for “pkcon”. It is just a way of accessing “packagekit” from the command line.

If the KDE update applet is saying that it failed, then “pkcon refresh” seems to wake it up.

At the very least you need to tell what desktop environment you are using and what is this “update widget”. On clean installation with XFCE update icon never indicates any available updates - always “Up to date” - even though “zypper patch” is willing to install quite a lot.

And yes, it looks like it has own cache - after “pkcon refresh” it suddenly jumped up with updates. It is set to refresh cache daily; I assume - system being notebook - system is switched off most of the time so refresh never happens via update applet. Leap 15.1 with Xfce on the same system (another VM) displayed updates every time I booted VM. Need to compare settings …

pkcon refresh

worked for a day or so, then right back to ‘check for updates failed’.
If it really matters I am using:

Operating System: openSUSE Leap 15.2KDE Plasma Version: 5.18.5
KDE Frameworks Version: 5.71.0
Qt Version: 5.12.7
Kernel Version: 5.3.18-lp152.26-default
OS Type: 64-bit
Processors: 2 × Intel® Core™2 CPU 6300 @ 1.86GHz
Memory: 3.8 GiB of RAM

And the ‘widget’ is the PackageKit Software Updates. It was put there by the previous version(s) installs and carried over with upgrades.

It happens on the old HP desktop(legacy), but the upgrade to 15.2, on the laptop(UEFI) doesn’t have the ‘failed to get updates’ error.
Another of those things I will just have to get used to doing manually.

I did an ‘unconditional’ update to the PackageKit in YaST, but that didn’t help either.

May just put the 15.2 USB iso in and do another upgrade from there, if I get the inclination to sit behind this thing for a couple of hours or more(easier to just check manually).

The same happened here today (in a virtual machine). It was fine on the previous check.

On my main desktop, I have the update applet disabled, so I’m not checking it there – I update at root command line.

Looks like I will have to update form a command line as well. The packagekit thing worked for a day, then failed again next day.
Odd thing is, I forgot to do a manual check last night, and after about an hour and a half. I got the popup notification that there were updates.
This evening, right back to the failed message. Something weird going on with 15.2?
Maybe I SHOULD put in the KDE repos and see if their latest updates for KDE and KDE framework help.

Leap 15.2 does contain the latest version of the update applet (plasma5-pk-updates) in the standard repos.

It would probably make more sense trying to install an older version… (e.g. the package from 15.1)

A possible reason for the problem is that the network is not yet up when the applet tries to check for updates.
Are you using Wireless?
You could set it up as “system connection” then (“Allow all users to connect”) and store the password system-wide, the connection should be made during boot already before you login then.

It does not seem to be that.

Here’s what happened today. This is in a KVM virtual machine, where Tumbleweed and Leap 15.2 are both installed.

(1) Booted Tumbleweed. Logged into Icewm, so the update applet was not being used.
(2) Update to 20200717.
(3) Rebooted. Logged into KDE. The update applet showed up, and said that the system is up to date.
(4) Switched to using “wicked” for networking.
(5) Rebooted, and logged into KDE. The network is working fine. But the update applet (in the hidden tray) says “Checking for updates failed”.

(6) Rebooted, but this time I booted Leap 15.2. The update applet showed up, and said that I had 10 updates.
(7) Updated the system.
(8) Switched to using “wicked” for networking.
(9) Rebooted (again, to Leap 15.2). Update applet said “Checking for updates failed”.

Here’s what happened in another (different) KVM virtual machine, with Tumbleweed.
(1) Booted, and logged into “icewm”. Update to 20200717.
(2) Rebooted, logged into KDE. The update applet showed up and said that the system is up to date. Note that this system is using NetworkManager, and I did not attempt to change that.
(3) Rebooted again, logged into KDE. This time the update applet said “Checking for updates failed”.

To me, it looks like a weird timing problem. I’m not sure if the problem is within KDE or in the base system.

And I suppose I should mention that both VMs are using ethernet via a bridge.

The applet (or PackageKit actually) can only correctly check the online status with NetworkManager AFAIK.
Maybe that plays a role here.

And actually in your test it already checked for updates immediately before on the previous login, so maybe just the displayed status is wrong because it didn’t check again in the first place.

IIRC, the 15.1 applet did ask PackageKit about the update status on login, but that caused a full refresh of the repos on every login regardless what the settings say (which also resulted in bug reports), so it got removed again.

Then maybe the displayed message (which says “failed”) is just wrong.

I booted up the VM again – the one using “wicked”. Again, no update applet showing, so I looked at the hidden tray. There, the update applet said “Checking for updates failed”. So I clicked on that Icon. And that gave me a more detailed message.

Checking for updates failed

Last check 2 hours and 32 minutes ago.

Updates are automatically checked daily.
Click the 'Check for updates' button below to search for updates manually.

So instead of “Checking for updates failed”, maybe it should say
“Check for updates not done because it ls less than 24 hours since previous check” or even
“It is less than 24 hours since previous check for updates”.

That would not be as confusing as the current message.

Here is an odd footed thought,
I have been ignoring the PackageKit update notification on my laptop because I had other things to do, and just forgot when I shut down.
Today I remembered to do the updates. One of them was the Kernel update to


, and a Restart was required.
After the restart. the network showed as connected, so as a thought I hovered over the Packagekit icon and it gave me that ‘Checking for updates failed’ message.

So, the odd footed thought is, DOES that kernel update have something to do with it not checking for updates?

Just asking…

I don’t think so.

From earlier discussions in this thread, it looks as if the “failed” might only mean that it didn’t even bother to check for updates because it is less than 24 hours since the previous check.