Updater says I need to update Compat-Wireless....?

. . . But when I try, I get this?

http://www.mpr75.talktalk.net/CompatWireless.png

Can anyone translate for me. I’m terrified of breaking my HostAPD application!

Regards, Martin

There shouldn’t be any harm in downgrading compat-wireless-kmp-default (the first option).

Hi Quantamm,

Ahhhh… but is it a downgrade? What do the numbers mean? If we have a close look, it says:

Downgrade
2.6.34_2.6.31.12_0.2.2.1.i586 to
2.6.34.1_2.6.31.12_0.2.3.1.i586

I would have expected, 2.6.34 to be less than 2.6.34.1? And also, later in the string, there is _0.2.2.1.i586 and _0.2.3.1.i586
All this smacks of “finger problems” and makes me hesitate. Can anyone in the know, comment?

Regards, Martin

Choose not to install it.

If your computer is running well, then simply don’t install it.

It is likely that upgrade was put it in place before a dependency was met, so until what is needed is there, then simply choose the option do not install.

Hi Bruce,

Yes, good advice. I am just on a quest for understanding. It is the wording “downgrade” that puzzles me.
Is it a switch/decision made by the package maintainer irrespective of any sequential version numbering? Or is just an automated logic function within YaST?

Regards, Martin

If this is the package from driver:wireless, then the answer would be “No”.

(The package maintainer)