Updater looking for a non-existent file.

Hi everyone. Yesterday, I tried to install openSuse 11.1. I got the main system installed and when I reached the checking for updates part, the updater kept throwing up an error that it couldn’t find repodata/repomd.xml in Index of /distribution/11.1/repo/oss.

Isn’t this an error in the installer? Should the updater really be looking in Index of /distribution/11.1/repo/oss for updates? I ask, because after waiting over 24 hours to see if the directory and file would turn up (I thought that perhaps someone might have just made an error whilst updating the repos) I noticed that the most recent modification in that directory was made on the 10th of December 2008. Hardly characteristic of a well-maintained source of updates.

Anyone got any info? Should I wait for the repomd.xml file to appear? Should I just delete it from the list because the installer shouldn’t have put it there in the first place or what?

Has this happened to anyone else? I can imagine it would be rather off-putting to a Linux newcomer.

probably doing that because that isn’t an update repo but an install source

Andy

So I should just delete it from the list then?

Yep,should solve the problem

Andy

Well rather than deleting the repo, I just disabled it instead. Disabling the repo did indeed fix the complaints from the updater, but it also caused problems with installing software. Unsurprisingly, I couldn’t install anything that depended on a package from the main OSS repo.

Re-enabling the main OSS repo allowed me to install software which had dependencies for packages in the main OSS repo again, but also caused the updater to start complaining again about not being able to use the repo as a source of updates.

Not having much of an idea of what I should do to try and fix it, I decided to do the only thing I could think of: rename the repo entry set by the Suse installer, and then make my own identical entry. I gave it exactly the same URL and even the same name as the one the installer sets. It seemed like a pretty pointless thing to do, but I couldn’t really think of anything else. Nevertheless, it worked and I can now use the OSS repo as normal and my updater doesn’t complain about it either.

I’m guessing this means I must have encountered a bug, but I have no idea how to find the cause of it or to where I should report it. I’d be happy to try to find the cause of the error if someone is willing to help me find it.

I’ve been having the same problems with openSUSE 11.1 and KDE 4.1.3. I’m going to try your idea, Stephen.

rusty