updater error

Almost every time I use the updater-applet to either check for updates or install available updates I get an error message popping up

DBus error : Unable to get transaction id from packagekit.

And sometimes when I’m trying to do installs or updates via Yast and I have to put the Suse DVD in the drive I also get an error

The application KPackageKit (kpackagekit) crashed and caused the signal 6 (SIGABRT).

I have checked kpackagekit, packagekit and the updater and I have the latest versions.

I have not idea, if I should ignore those messages or if there’s a way of fixing them.

Any help is greatly appreciated.

> Any help is greatly appreciated.

try this:

Open a terminal type

su -

then give your root password when asked

then do;

zypper ref

be patient…this might take a while…when all activity has stopped,
then do

zypper up

be patient…this might take a while…when finished close the
terminal and maybe your error will be history…
let us know, please.

Note: Accuracy, completeness, legality, or usefulness of this posting
may be illusive.

Try Yast>Repositories, then select the openSUSE 11.1-0 repo, then uncheck enable.

Then select openSUSE-11.1-Source, check enable and auto refresh and set priority to 99.

Maybe that will help.

First of all you need to remove the entry for the DVD in your Software repos.
Please post output from command below. Open a terminal window and do:
zypper lr

Hi,thanks for all your replies, I haven’t been able to answer any out sooner.

I have done all you suggested and here’s the readout:

| Alias | Name | Enabled | Refresh

1 | openSUSE 11.1-0 | openSUSE 11.1-0 | No | No
2 | repo | NVIDIA Repository | Yes | Yes
3 | repo-non-oss | openSUSE-11.1-Non-Oss | Yes | Yes
4 | repo-oss | openSUSE-11.1-Oss | Yes | Yes
5 | repo-source | openSUSE-11.1-Source | Yes | Yes
6 | repo-update | openSUSE-11.1-Update | Yes | Yes
7 | repo_2 | Packman Repository | Yes | Yes

Now my kupdateapplet shows a read triangle, because a new security update is available. When I try to install it, I get an error with the following message

User is not permitted: org.freedesktop.packagekit.system-update

I googled it and the Suse FAQs tell me I have to have Policy-kit-kde installed (which I have and running. I don’t know how to check that.
But Yast shows the version number red, with only a lower version ( )avaible. Do I downgrade?

Many thanks.

This might not be the correct answer but I presume you have setup the online update correctly? Did you run the online update configuration in YAST - Software - Online Update Configuration?

Try setting the policy kit to it’s default settings with the suggestions in this thread.
System Policy Denies Access to Various Things
Found it whiles looking up the policykit since it’s totally new to me :slight_smile:
Hope it helps.

Thanks Dexter,

I’ve had a look and reset the policies with this command

set_polkit_default_privs that resets privileges to the values defined in /etc/polkit-default-privs

That seemed to have worked, at least for this update. I’m keeping my fingers crossed. Thanks again.

No problem. It’s always a good idea to have a look through the forums to see if someone else has had a similar problem. Glad it worked!