Updater doesn't update, doesn't give error either

Maybe some of you out there are having the same problem I am…

The little suse updater that sits near the clock suddenly alerts me (via a balloon message) that I have updates. So I click on it and it prompts me for the root password. So I give the root password and it and nothing happens. I can click on details and it shows me the pending updates.

The icon almost immediately changes again (back to “you have critical updates”) and tells me I have updates. The process repeats if I click on it… it never ever installs the updates.

I’m having this same problem on two workstations… one is a desktop, the other is a laptop. One uses KDE 4.1, the other uses KDE 3.5. Both are x86_64.

I’ve tried closing the updater and doing updates via YAST… it shows the updates that are pending, and when I click next it immediately finishes and closes before it does anything.

So I’m just wondering what’s going on there, and if there’s a way to fix it.

I normally close that window and click on the updater icon to review
the changes… You could try the zypper command;

sudo /usr/bin/zypper ref
sudo /usr/bin/zypper lu
sudo /usr/bin/zypper up

ref = refresh, lu = list updates and up = apply updates.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 6 days 1:00, 1 user, load average: 1.18, 0.46, 0.22
GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12

I have the same problem. When I click on the updater and watch the list of available upgrades, it get’s longer every week. Most upgrades are applied flawlessly and disappear from the list but some don’t.

When checking the versions of the installed programs they respond with the updated version.

zypper ref/lu/up reports no available updates/nothing to do.

It seems it’s just the displayed list in the updater which is faulty, the upgrades are already successfully applied.

openSUSE 11.0, x86_64, KDE4

I think I just found a bug.

While watching the list of available updates, I clicked on “Add/Remove Update Repositories” and disabled all repositories from “download.opensuse.org/repositories” (build service repositories), leaving only the default and update repository enabled.

The list of available updates did not change but when clicking on install it actually installed older versions. :X
(e.g. It downgraded wine from 1.1.4 to 1.0-rc3)

The update list is now empty, zypper shows no updates, too. Unfortunately this does not change when I switch the disabled repositories back to enabled. No updates available. :sarcastic:

Luckily, it is possible to upgrade the applications back to a current version within the package manager by clicking on
Package->All Packages -> Update if newer version available

The rug commands seemed to have worked. The updater appears to be broken.

I’m not sure if this has anything to do with it or not, but there is one update that it won’t install (rug or the updater applet) because of a dependency issue. It’s libpulse-browse0. I’m on x86_64, opensuse 11.

Hmm… I got one update that won’t install, too. (openSUSE 11.0, too)

I can not update DirectFB to 1.2.3-2.1.x86_64 because of something named splashy.

More precisely:
“splashy-0.3.8-53.1.x86-64 requires libdirect-1.1.so.0()(64bit), but this requirement cannot be provided”

Indeed DirectFB-1.2.3 doesn’t provide libdirect-1.1. It provides the newer libdirect-1.2. Splashy doesn’t seem to understand this.

Since splashy is involved in the boot process I didn’t dare to fiddle with it.

I have the same problem concerning DirectFB installation.

And my updater does not do anything either besides signalling me there are two updates to apply, asking my password, getting to green about 3 seconds, then to orange again and signalling me there are two upates to apply, and so on.

Is there some way to reorder the installed packages database, event if that process takes a lot of time, in order to get things back to normal ? :frowning:

(People in Redmond, please do not laugh; at least, slight problems like in Opensuse are transparent and public, not hidden :sarcastic:)

I am devoted to the gui. That command line stuff was for my TI-99-4a! But, zypper is so useful and fast that its got me looking to things in konsole that I never would do before. I just used these 3 commands and found an update that didn’t show up with the updater icon.

Ahhh good to see and welcome to the darkside :slight_smile:
It’s especially useful if your compiling something and need some
development package installed, don’t have to leave the window.

If an application won’t start, try starting from the cli as it will
generally show some errors for you to debug.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 1 day 5:04, 1 user, load average: 0.29, 0.19, 0.30
GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12