Updater Does Not Function

Just installed, Opensuse 11 as my first linux distro and are pleased however my updater is broken forcing me use a beta version of firefox amoungst 47 other unknown problems due not being updated.

I also would like help setting the the default boot option to clear the vga=0 x 300 option. I would like it at startup to read empty or vga=normal.

I recieve the following error message when attemping to do an update.

kdsedu(3483)/kdesu(kdelibs)KDESU::KDEsuClient::command: [usr/src/packages/BUILD/kdelibs-4.0.4/kdesu/client.cpp : 196] no reply from daemon

I also tried changing, the backend to “PackageKit Backend”. This changed the error message to DBus error : Unable to get transaction id from packagekit. DBUS/PackageKit not running?

Hi, and Welcome!

If, your updater doesn’t work, try to download your updates trough YaST.
YaST -> Software Management -> In the filter list select repositories and search for Main update repo. or something similar. Select it, after in the right panel right click and select All In This List -> Update if newer version available.

Change your default boot options under:
YaST -> Boot Loader.

Good luck

I have the same issue.
Downloaded OpenSuse11.0, installed it. Set up the Updater and get a
kdesu(3738)/kdesu(kdelibs) KDESu::KDEsuClient::command:[/usr/src/packages/BUILD/kdelibs-4.0.4/kdesu/client.cpp:196] no reply from daemon
I first tried the Gnome, where the updater worked. But other things like my printer driver did not. Then I formatted the disk again and switched to the KDE4.0. No the updater does not work.
Is there any hint out here to get the automated updater working under KDE4.0 or do I have to wait for 11.1??
Have a great day!

I’ve got the same/similar problem. I try to install the updates and I get an error:
‘kdesu(3489)/kdesu (kdelibs) KDESu::KDEsuClient::command: [/usr/src/packages/BUILD/kdelibs-4.0.4/kdesu/client.cpp : 196 ] no reply from daemon’

The first number (3489) was different before I tried ram88’s advice.

After several crashs of the KDE4.0 I switched back to the Gnome desktop. Still here the updater seems to work.
Now I am going to try to find help in one of the other threads to solve my printer/scanner item, since they work under KDE but somehow they do not want to with the gnome. But at least it is possible to update Gnome :-))