Updater applet prompt to update packages from different repos

I’m using openSUSE 11.3 with KDE 4.5.4. The updater applet works fine for me, however I think it only checks for updates from the update repo. I tried to modify this behaviour by right clicking the icon and checking “show available updates, when the backend provides it(for experts)” (translation from polish so it may not be 100% accurate) but the behaviour is the same, it only prompts me when there are updates available in the update repo but I would like it also to prompt me when there are updates available in the packman and KDE stable repo. Is it possible to force the updater applet to do this ?

Best regards,
Greg

I found the following thread on the subject here:

kupdateapplet-zypper missing in 11.3rc?

It seems that you can get what you want by adding in this repository:

Index of /repositories/YaST:/Head/openSUSE_11.3

You then must downgrade Kupdateapplet & Kupdateapplet-packagekit to 0.9.9.-1.1 and then load the package Kupdateapplet-zypp of the same version. Then, in the configuration of the update applet, you will find the new backend called ZYpp Plugin which will do what you request. I found the following link that shows what the added icons mean:

Kupdateapplet - openSUSE

I can’t say if such a change is recommended or not as the older version may no longer be supported, but I don’t really know for sure.

Thank You,

That’s too much messing around in the system. I thought packagekit could do it also. Thanks for help anyway.

Best regards,
Greg

                 That's too much messing around in the system. I thought packagekit could do it also. Thanks for help anyway.

Best regards,
Greg
Hey glistwan, you asked and I looked it up. I should get an E for Effort right? lol! Anyway, I kind of wondered about this myself as I had remember that same function had existed, but went away for some reason. Don’t know the whole story, but we have part of it anyway.

Thank You,