Updater applet doesn't seem to work

I’ve installed the unofficial openSUSE 11.1 KDE3.5 Live CD that can be found here because I don’t want KDE4.

At the startup, the updater applet says new packages are available. I then click on it, and it shows a long list of updatable packages. I select them all and click on “install”, but nothing happens.

I’ve also checked Control Center -> Online Update Configuration, and noticed that under “Update Repository” -> “Current Update Repository”, no repository is listed, and can’t seem to do anything useful to make one appear there. Don’t know if this could be related to the updater problem, but I thought I should point this out.

Any help for updating my installation would be greatly appreciated.

Try ‘zypper up’ in a root terminal, may ‘clear the blockage’ as it were.

Otherwise there’s YaST Software Management. Put it on Repositories view, then select ‘all in this list -> update if newer version available’.

You may have too many repositories enabled - that I think can cause tangles that confuse the auto update applet.

LOL, you need to add an alias then :wink:

alias software_enama='sudo zypper up'

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.2 RC 1 (i586) Kernel
up 5:55, 1 user, load average: 0.42, 0.61, 0.42
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME

Ok, I’ll try this ASAP.

That’s what I’ve done so far, but I can’t see the reason of having an updater applet if it does not work :slight_smile:

I’ve just installed openSUSE, therefore I don’t think I have too many repositories enabled. I’ve only enabled the “classic” ones, and those for Packman and Wine… I’m not running openSUSE right now, but going from memory I don’t think I’ve enabled more than 8-10 repositories…

can you explain this? I did not understand… doesn’t ‘sudo zypper up’ force a refresh of the repositories’ content?


He was just kidding.

It’s not that the updater applet doesn’t work generally, it’s that 11.1 seemed to ship with something strange going on with updates for quite a few people, which was then fixed. Although again, it depends to a huge extent on how you’re configured - many people would suggest that 10 repos is too many, I’m not experienced enough to venture an opinion.

I suggest just updating manually a few times, and seeing if it starts working. If it doesn’t, remove a few repos, see if it does then - if so, you’ve found your problem.

The above command was a joke command, but it would create an alias for
you that is functional :slight_smile:

But yes, zypper up should refresh the repositories at the same time (it
does on 11.2)

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.2 RC 1 (i586) Kernel
up 16:50, 2 users, load average: 0.25, 0.12, 0.04
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME

Thanks for the clarification. Not being an english mothertongue, and not having much experience with openSUSE, I didn’t know whether to take that suggestion seriously. :slight_smile: