Updated today - Now error: 'Could not create python ScriptEngine for widget'

OpenSuse 12.3 64bit -
OpenSuse ran an update when i booted up now the error shows for plasma wigets
‘Could not create python ScriptEngine for widget’

any help ?

:slight_smile:

Are you trying to use Apper/PackageKit?

Try using YaST > Software > Online Update

You might have to YaST > Software > Online Update Configuration

You need to install the package “python-kde4-plasma”.
Type the following into a konsole:

sudo zypper in python-kde4-plasma

or use YaST->Software Management to install it…

Hmm “python-kde4-plasma” was not required in a clean 12.3 KDE, and update to KDE-4.10.2 on any of the systems I manage. Anyway I would hope that YaST would fix any dependencies.

On 04/25/2013 05:16 AM, alienbee wrote:
> OpenSuse ran an update when i booted up

ok, on the 16th of this month you wrote “So new to linux I sqeek - I
don’t have a clue”…so, i’m gonna forgive you for thinking like a
MS-Windows (only) user as i explain (nicely i hope) that what you
wrote above is just not the way it is actually is…

that is not what happens in openSUSE or Linux in general (i do not
know about all of the distros)

here YOU are in control! YOU are the user and the System
Administrator…

NO updates flow into your machine until the System Administrator (aka
‘Root’) has approved them…

so, when you have a problem you suspect was caused by an update,
instead of writing it like “OpenSuse ran an update” (its NOT my fault
that ‘they’ broke the system) you could write "My system
administrator updated the system today without having clear knowledge
of the potential implications of that action and more egregiously,
with no idea of how to reverse the damage!

or, you could just write you think the update YOU put in broke the
system…

ok?


dd
openSUSE®, the “German Engineered Automobile” of operating systems!
*

Upto KDE 4.10.1 this was contained in python-kde4. Then that package got split up in smaller subpackages.
From the changelog:

  • Split out sub-packages for seldomly-used modules that also have heavy
    requirements: akonadi, khtml, knewstuff, phonon, plasma, nepomuk, soprano

Which sub-packages you need depends on which plasmoids you use. A standard KDE installation with default settings doesn’t need any of them AFAIK.

For the next version all of them will be installed by default, but you can individually uninstall them if you want to.

  • Recommend all sub-packages for the main package, so users don’t
    have go guess which module is required (bnc#816432, bnc#816562)

Most of the time this message originates in older (no longer maintained) widgets. Check whether the problem arises on a new clean user account. If it doesn’t, remove your non-default widgets and see if the problem persists.

Or just install the package “python-kde4-plasma” as I wrote earlier…:wink:

I had been checking to thread for reply’s and realized that no one was answering…up to two minutes ago i just logged in and wow…all these replys!!:stuck_out_tongue:
know now to** log in to view my reply’s…**

anyhow i just installed the package python-kde4-plasma and it my SOHO widget works again!!! (solved)

nice going guys!
:slight_smile:

thanks again!! peace!!!

It was a reference point - the word ‘update’ was not to attached to blame rather in my mind it was a point of reference to a sequence.
Im happy to seek out a resolution to my problem. and am happy to report that WE ( people who helped) fixed MY problem-
I find the linux community to be a really nice and generous and…patient group of folk.

i am slowly finding my way …much lov …cheers

thanks*

> i am slowly finding my way

believe me: we have all been there…

lots to learn.


dd

Yast online update is giving me error message as follows:

Kindly let me know how to fix this problem:
There was an error in the repository initialization.
|] Valid metadata not found at specified URL
History:

Well, Yast couldn’t connect to that server. I tried and could reach it just fine, so it may have been a temporary problem.

But why are you using that repo at all? If it keeps causing you errors, you could just disable it in YaST->Software Repositories.

And what does this have to do with the original problem, i.e. “Updated today - Now error: ‘Could not create python ScriptEngine for widget’”? :sarcastic:

On 2013-05-07 09:26, wolfi323 wrote:

>> ‘http://repo.meego.com/MeeGo/builds/trunk/latest/repos/oss/ia32/packages/repodata/repomd.xml’:
>> Error code: Connection failed
>> Error message: Could not resolve host:* repo.meego.com*; Name or
>> service not known

> Well, Yast couldn’t connect to that server. I tried and could reach it
> just fine, so it may have been a temporary problem.
>
> But why are you using that repo at all? If it keeps causing you errors,
> you could just disable it in YaST->Software Repositories.

Meego is another distribution, not openSUSE.

We can not answers questions about it here.

> And what does this have to do with the original problem, i.e. “Updated
> today - Now error: ‘Could not create python ScriptEngine for widget’”?
> :sarcastic:

Absolutely, we should not answer to this anymore here.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)