Updated to Leap 15.3 and cannot print anymore

The update de-configured my HP printer and when I try to reconfigure it says, “Nope. Sorry. I can’t do that.” Or, more properly:

/u/bkorb/.hplip/hplip-3.20.11-plugin.run file does not match its checksum. File may have been corrupted or altered

Also, I renamed ~/.hplip out of the way, so this must be a new download.

I really hate updates.

Unlikely, more likely you don’t have the asc file in ~/.hplip?

Manual download of both and re-install, all good here after the last updates on Leap 15.3 (no re-install of plugin required)…

wget https://developers.hp.com/sites/default/files/hplip-3.20.11-plugin.run -O hplip-3.20.11-plugin.run
wget https://developers.hp.com/sites/default/files/hplip-3.20.11-plugin.run -O hplip-3.20.11-plugin.run.asc
hp-plugin -i -p .

When I first tried upgrading my Linux boxes, my printer, X and NFS configurations would always get trashed, so for nearly 2 decades I’ve been re-installing and porting my home dir. I tried an upgrade once again. Sigh. It’s still fragile – at least for me. Thank you. Works now.