Updated to KDE 4.10, plasma crashes at login with system tray plugin


I have just updated to KDE 4.10. I love it, except that plasma crashes at login if I have system tray in my panel.
If I remove the entry with “plugin=systemtray” from ~/.kde4/share/config/plasma-desktop-appletsrc then I can login, and sometimes I can add systemtray back without crash. But in this case logout - login and it again crashes.

It seems to be this bug: https://bugs.kde.org/show_bug.cgi?id=311751 and I was wondering if other people who upgraded to 4.10 are having the same issue … because I haven’t seen any other thread about this. Is there a workaround?


Not seeing this

Test a new user. See if it is the same…

Not seeing this either. But I’ve seen some reports on odd systray behaviour, in many cases related to “external” apps, i.e. Skype, Mumble. Do you have any of such?

IME editing / commenting out single lines from KDE config files doesn’t always bring the desired result. If you’re sure it’s plasma that crashes, remove all the plasm* files from your .kde4/share/config folder whilst not being logged in. That will leave all application settings intact, just restore the desktop appearance to default.

In fact I have several. Such as autokey, nabi (IME), spideroak. I should try that as well - but I have never had any problems til KDE 4.9 with current setting.

I did not comment out single line - I took out the whole



Sorry for lack of description. Anyway, I just tried restarting plasma with systemtray with

kbuildsycoca4 && kquitapp plasma-desktop && kstart plasma-desktop 

and it restarted normally. So hopefully it was caused by some wrong settings in that contianmetns part in


and it is now fixed. I will post again after I do logout/login later. Thanks!

In fact I have several. Such as autokey, nabi (IME), spideroak.

I have spideroak running here in with KDE upgraded to 4.10 and I do not have any issues, so you can probably rule out spideroak.
autokey?? I never could get that to run properly. I would like to know your secret on that one.

Relogin worked fine. I think when I firstly edited plasma-desktop-appletsrc, I did not properly removed the whole container part. Thanks for your input.

I remember there were some repos which had autokey, but now the search only returns source packages: software.opensuse.org:

But building it from the source is not hard at all. The following is from my note:

Install dependencies:

$ sudo zypper install python-xlib python-notify python-pyinotify python-qscintilla wmctrl
  1. download autokey source from autokey - Desktop automation utility for Linux and X11 - Google Project Hosting
  2. extract the files
  3. cd to the directory
  4. build and install it:
$ sudo python setup.py install

It should work. If not, please let me know.


Oh actually, there are packages - you are supposed to install the sub packages:


and one of the


depending on your DE. I would use the ones in devel:languages:python repo.


It should work. If not, please let me know.

Works, Thanks :slight_smile:

The only issue I have now is that it does not recognize Dvorak keyboard layout. You have to put in aho for the shortcut to adr, no big deal though. I am happy with it.

Glad it worked out for you.
It’s strange that you have issues with Dvorak though … I’m using Colemak and mine works as follows:

abbreviation: if I have .mail for myemail@gmail.com, then when I type .mail in any keyboard layout (qwerty, colemak), it correctly inputs the email address.

hotkey: The key location changes depending on the layout I’m in. For example, for ctrl+p, I press ctrl+p in colemak, which is r key in qwerty. (Hope you see what I mean - sorry for lack of better description)

Does it work differently for you?


I found the culprit. My plasma crashes at login if I have paste widget in the system tray. It was reported at https://bugs.kde.org/show_bug.cgi?id=312075

If you have this, edit ~/.kde4/share/config/plasma-desktop-appletsrc, and just remove the part with plugin=paste.