Updated this morning to 12.1. Very smooth.

Updated with zypper dup to an existing modified Tumbleweed install.

The functionality of NetworkManager-kde4 is being missed. Is there a replacement package for this?
(knemo is not an alternative)


  1. first re-boot hung on black screen, ok after --forced uninstall of proprietary drivers via safe boot
  2. re-installed AMD graphics drivers to run Googleearth.
  3. re-installed Samsung Unified Driver before reliable scanning possible on USB SCX-4200.
  4. boot splash now back on 64bit install
  5. kaffeine stated installation ‘not correct to play mp3’ files and did an auto update of files;
    -then ok for sound tracks and DVD playing.

OS: AMD Phenom™ II X4 940 Processor, Linux 3.1.0-1.2-desktop x86_64
openSUSE 12.1 (x86_64), KDE_4.7.2 (4.7.2) “release 5”
ATI Radeon HD 3200 Graphics, Catalyst™ Version 11.11

I use ifup+dhcp instead of network manager and i had never failed me :slight_smile:

You should have plasmoid-networkmanagement

If it isn’t installed, then install it.

You will probably have to reconfigure your networks. The new NetworkManager seems to not be compatible with old settings.


plasmoid-networkmanagement was not installed.

No reconfiguration was necessary.

Thanks for the pointer.


ignore my post #4 its totally wrong!!

plasmoid-networkmanagement does not work in 12.1!!!

The response on two systems is identical, 32bit and 64bit,
its impossible to setup the network with Yast2.

When Yast2, --System, --Network Settings, --Global Options, User Controlled with NetworkManager button is selected,
Yast2 exits with an error message 'Network not available.

As creatura85 stated, never fails with ifup+dhcp.

Any work arounds found?

I have not tried on 12.1 final. But, yes, that happened to me on Beta1, rc1, rc2.

However, the network does function after reboot. Possibly running
/etc/init.d/network restart
would also get it working. It seems to be a problem with starting NetworkManager after switching from “ifup” to “NetworkManager”.

Thanks nrickert, creatura85

got there at last,

warn-rebooting does not reset the network,

after setting things up in Yast2, a cold-boot was necessary

Fwiw the only thing you should do to start using plasmoid network manager is enable network manager in YaST, obviously, and then right click on system panel > system panel management (or properties, whatever) > Enable Network Manager