Updated Postgresql from 9.2 to 9.3

We’ve upgraded our OpenSuse to 13.2 and with that, Postgres to 9.3 from 9.2. This have put Postgres in a bit of weird state. All binaries, in path, are 9.3 but

whereis psql 

psql: /usr/bin/psql /usr/share/man/man1/psql.1pg92.gz /usr/share/man/man1/psql.1pg93.gz 
/usr/bin/psql --version 
psql (PostgreSQL) 9.3.6 


systemctl status postgresql.service 
postgresql.service - LSB: Start the PostgreSQL master daemon 
   Loaded: loaded (/etc/init.d/postgresql) 
   Active: active (exited) since Sun 2015-08-09 18:37:56 CEST; 3 days ago 
  Process: 36322 ExecStop=/etc/init.d/postgresql stop (code=exited, status=0/SUCCESS) 
  Process: 36558 ExecStart=/etc/init.d/postgresql start (code=exited, status=0/SUCCESS) 


Aug 09 18:37:55 server postgresql[36558]: Your database files were created by PostgreSQL version 9.2. 

Aug 09 18:37:55 server postgresql[36558]: Using the executables in /usr/lib/postgresql92/bin. 

Aug 09 18:37:55 server su[36571]: (to postgres) root on none 

Aug 09 18:37:55 server su[36571]: pam_unix(su-l:session): session opened for user postgres by (uid=0) 

Aug 09 18:37:55 server su[36600]: (to postgres) root on none 

Aug 09 18:37:55 servers su[36600]: pam_unix(su-l:session): session opened for user postgres by (uid=0) 

Aug 09 18:37:56 server postgresql[36558]: Starting PostgreSQL 9.2.7 ..done 




And when I try to access a database with psql I get this.

psql postgres 

psql: could not connect to server: No such file or directory 
    Is the server running locally and accepting 
    connections on Unix domain socket "/var/run/postgresql/.s.PGSQL.5432"? 


That worked previously. Now this is the only thing that works 
psql -h localhost -U db -d db 
Password for user db: 
psql (9.3.6, server 9.2.7) 
Type "help" for help. 


db => 



So it looks like Postgresql is in some sort of limbo, and I’m thinking this is because the cluster was not upgraded to 9.3
But I’m unsure no how to go about that on OpenSuse. On Debian there is a pg_upgradecluster tool, that I can’t seem to find in OpenSuse. I’m also not sure on how much was done during the upgrade, so I’m looking for all the advice i can get before I start dabbling with pg_upgrade, and I haven’t been able to find a guide related to OpenSuse.
Maybe it’s not even pg_upgrade I have to do, so any advice is greatly appreciated.

A questions about you using the forums.

Can you please NOT change the default font that is used in the forums. And specialy not inside the CODE block because it nullyfies the main task of the CODE block: to have a fixed font, like on your terminal window.

Ah, sorry. Sure. This was a copy paste job from my evernote, so that’s probably why.

HI,

did you check, that the socket file exists and has the right permissions?
Check your postgresql.conf for the network and socket options.

Hendrik