Updated kernel will not boot (2.6.37.6)

Just updated to kernel 2.6.37.6-0.5 from:
http://download.opensuse.org/update/11.4/

No error. then rebooted and grub gives following error:
Booting Deskyop – openSUSE 11.4 - 2.6.37.6-0.5

root (hd2,2)
Filesystem type unknown, partition Type 0x83

kernel /vmlinux-2.6.37.6-0.5-desktop root=/dev/sdc2 resume
=/dev/disk/ata-ST31000528AS-9VP6KV4Y-part 1 splash=silent
quit showopts vag=0x31a

Press Any Key to Continue

this goes to grub boot menu where I then select my old kernel
2.6.37.1-1.2-desktop and it boots OK.

Question: Should root(hd2,2) be (hd0,2) like the working
kernel?

sdc 1 TB Seagate Drive.
sdc1 = swap 10 GB
sdc2 = / 75 GB
sdc3 = boot 1 GB
sdc4 extended 301 GB
sdc4 = usr 75 GB
sdc = home 200 GB

My menu.lst is:

Modified by YaST2. Last modification on Sat Apr 30 10:25:07

PDT 2011

THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader

Configure custom boot parameters for updated kernels in

/etc/sysconfig/bootloader

default 0
timeout 8
gfxmenu (hd0,2)/message
##YaST - activate

###Don’t change this comment - YaST2 identifier: Original
name: linux###
title Desktop – openSUSE 11.4 - 2.6.37.6-0.5
root (hd2,2)
kernel /vmlinuz-2.6.37.6-0.5-desktop root=/dev/sdc2
resume=/dev/disk/by-id/ata-ST31000528AS_9VP6KV4Y-part1
splash=silent quiet showopts vga=0x31a
initrd /initrd-2.6.37.6-0.5-desktop

###Don’t change this comment - YaST2 identifier: Original
name: failsafe###
title Failsafe – openSUSE 11.4 - 2.6.37.6-0.5
root (hd2,2)
kernel /vmlinuz-2.6.37.6-0.5-desktop root=/dev/sdc2
showopts apm=off noresume edd=off powersaved=off nohz=off
highres=off processor.max_cstate=1 nomodeset x11failsafe
vga=0x31a
initrd /initrd-2.6.37.6-0.5-desktop

###Don’t change this comment - YaST2 identifier: Original
name: linux###
title Desktop – openSUSE 11.4 - 2.6.37.1-1.2
root (hd0,2)
kernel /vmlinuz-2.6.37.1-1.2-desktop root=/dev/sdc2
resume=/dev/disk/by-id/ata-ST31000528AS_9VP6KV4Y-part1
splash=silent quiet showopts vga=0x31a nomodeset
initrd /initrd-2.6.37.1-1.2-desktop

###Don’t change this comment - YaST2 identifier: Original
name: failsafe###
title Failsafe – openSUSE 11.4 - 2.6.37.1-1.2
root (hd0,2)
kernel /vmlinuz-2.6.37.1-1.2-desktop root=/dev/sdc2
showopts apm=off noresume edd=off powersaved=off nohz=off
highres=off processor.max_cstate=1 nomodeset x11failsafe
vga=0x31a
initrd /initrd-2.6.37.1-1.2-desktop

###Don’t change this comment - YaST2 identifier: Original
name: linux###
###title openSUSE 11.4 (Production)

root (hd0,2)

kernel /vmlinuz-2.6.37.1-1.2-desktop root=/dev/sdc2

resume=/dev/disk/by-id/ata-ST31000528AS_9VP6KV4Y-part1
splash=silent quiet showopts nomodeset vga=0x31a

initrd /initrd-2.6.37.1-1.2-desktop

###Don’t change this comment - YaST2 identifier: Original
name: failsafe###
###title Failsafe – openSUSE 11.4 (Production)

root (hd0,2)

kernel /vmlinuz-2.6.37.1-1.2-desktop root=/dev/sdc2

showopts apm=off noresume edd=off powersaved=off nohz=off
highres=off processor.max_cstate=1 nomodeset x11failsafe
vga=0x31a

initrd /initrd-2.6.37.1-1.2-desktop

###Don’t change this comment - YaST2 identifier: Original
name: windows 1###
title windows 1
map (hd3) (hd0)
map (hd0) (hd3)
rootnoverify (hd3,0)
makeactive
chainloader +1

###Don’t change this comment - YaST2 identifier: Original
name: windows 2###
title windows 2
map (hd4) (hd0)
map (hd0) (hd4)
rootnoverify (hd4,0)
makeactive
chainloader +1

sda and sdb are not used at this time, sdb will have 12.1 Ms
soon. The two windows drives are used by virtualvox for WIN
XP backup. Not used often.

This problem could be related to Bugzilla bug:
https://bugzilla.novell.com/show_bug.cgi?id=690895

Any help would be appreciated.

Russ
openSUSE 11.4(2.6.37.1-1.2-desktop)|Platform Version 4.6.2
(4.6.2) “release 3”|Intel core2duo 2.5 MHZ,|8GB DDR3|GeForce
8400GS (NVIDIA-Linux-x86_64-270.18)

Yes, I think.
#1 Your menu.lst is using /dev/sdx instead of /dev/disk/by-id/
Using /dev/disk/by-id/ allows udev to correctly assign and reassign drives and partitions vs. hard coded assignment by /dev/sdx.

#2 Because it’s using /dev/sdx menu.lst is pointing to /dev/sdd instead of /dev/sdc

#3 For some reason sdc3 is not recognized as a Linux formatted partition.
Could you post a

 su -c  "fdisk -l" 

Please use SUSE Paste
or paste output between [foo]~~ output~~[/foo] replacing the word “foo” with the word “code”.

tararpharazon wrote:

>
> Yes, I think.
> #1 Your menu.lst is using /dev/sdx instead of
/dev/disk/by-id/
> Using /dev/disk/by-id/ allows udev to correctly assign and
reassign
> drives and partitions vs. hard coded assignment by
/dev/sdx.
Not sure what happened but it must have been when I install
11.4 GM. Only sdc1 and sdc6 are /disk/by-ID/ others are
/disk/by-name. Will change next install.
>
> #2 Because it’s using /dev/sdx menu.lst is pointing to
/dev/sdd
> instead of /dev/sdc
Yes sdd is a Windows Fat32 partition
>
> #3 For some reason sdc3 is not recognized as a Linux
formatted
> partition.
> Could you post a
> Code:
> --------------------
> su -c “fdisk -l”
> --------------------
> Please use ‘SUSE Paste’ (http://susepaste.org)
> or paste output between ~~ output~~ replacing the word
“foo” with the word “code”.
http://susepaste.org/94247825
>
I know the partition is EXT4 and it is working for
2.6.37.1-1.2 since I’m sending this from there. I have multi
versions enabled.

Since safe mode also gives error I may change it and try it.
/Boot looks good, have both versions there.

Let me know if you need anything else. Again thanks for the
help.

Russ
openSUSE 11.4 MS1 (2.6.37.1-1.2-desktop)|Platform Version
4.6.2 (4.6.2) “release 3”|Intel core2duo 2.5 MHZ,|8GB DDR3|
GeForce 8400GS (NVIDIA-Linux-x86_64-270.18)

Not really. IMHO, I think you might need to straighten out the by-id, or change menu.lst to try booting (hd1,2 highlighted below instead of hd2,2), or if sdd is a USB remove it to see if everything boots properly.


default 0
timeout 8
gfxmenu (hd0,2)/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original
name: linux###
title Desktop -- openSUSE 11.4 - 2.6.37.6-0.5
** root (hd1,2)**
kernel /vmlinuz-2.6.37.6-0.5-desktop root=/dev/sdc2
resume=/dev/disk/by-id/ata-ST31000528AS_9VP6KV4Y-part1
splash=silent quiet showopts vga=0x31a
initrd /initrd-2.6.37.6-0.5-desktop

I have to say your fdisk -l is confusing, I’ve never seen drives in a sequence as you are showing. I assume the sdb is defective.

tararpharazon wrote:

>
> Not really. IMHO, I think you might need to straighten out
the by-id,
> or change menu.lst to try booting (hd1,2 highlighted below
instead of
> hd2,2), or if sdd is a USB remove it to see if everything
boots
> properly.
Can I change these with the partitioner and not lose
anything? If not it will have to wait for clean install, when
things slow down.
>
> Code:
> --------------------
>
> default 0
> timeout 8
> gfxmenu (hd0,2)/message
> ##YaST - activate
>
> ###Don’t change this comment - YaST2 identifier: Original
> name: linux###
> title Desktop – openSUSE 11.4 - 2.6.37.6-0.5
> * root (hd1,2)*
> kernel /vmlinuz-2.6.37.6-0.5-desktop root=/dev/sdc2
> resume=/dev/disk/by-id/ata-ST31000528AS_9VP6KV4Y-part1
> splash=silent quiet showopts vga=0x31a
> initrd /initrd-2.6.37.6-0.5-desktop
>
> --------------------
I changed it to (hd0,2) yesterday and everything is working
normal. I think. it shows corect kernel and everything boots
fine. both my older kernel and new one boot. hd1 is
partitioned but nothing on it except maybe Grub. here’s my
device map, appears that the boot loader is still on sda. I
guess the easist way to correct this is remove sda and sdb
and propose a new boot configuration so everything is on sdc
(hd2 here).

(hd1) /dev/disk/by-id/ata-ST3320620AS_6QF161JQ
(hd2) /dev/disk/by-id/ata-ST31000528AS_9VP6KV4Y
(hd3) /dev/disk/by-id/usb-Maxtor_6_L120P0_############-0:0
(hd4) /dev/disk/by-id/usb-
WD_10EACS_External_57442D574341534A30353730353230-0:0
(hd0) /dev/disk/by-id/ata-ST3320620AS_9QF1Q6Q0
device.map (END)
>
> I have to say your fdisk -l is confusing, I’ve never seen
drives in a
> sequence as you are showing. I assume the sdb is
defective.
Actual sda and sdb are spares at this time. Sda had 11.2 and
sdb had 11.3 but I had a system problem and instlled just
11.4, did not put back older stuff. Plan to use sdb for 12.1
when I geet some time to do testing.
>
Thanks for your help, We that work?

Russ
openSUSE 11.4 MS1 (2.6.37.6-0.5-desktop)|Platform Version
4.6.2 (4.6.2) “release 3”|Intel core2duo 2.5 MHZ,|8GB DDR3|
GeForce 8400GS (NVIDIA-Linux-x86_64-270.41.06)

Ok in summary (hd0, 2) is booting consistently as it should?
If that’s true then I’d wouldn’t change anything for awhile, ie, if it’s not broke don’t fix it.
Enjoy a successful 11.4, 11…3, 11.2 and whatever.
You can use


ls -l  /dev/disk/by-id/   |   grep ata 

to compare the by-id ata to /dev/sdx ids.

I still don’t understand how you’re configured with the drives.
Could you still post to SUSE Paste
Copy and paste output from


su -c "fdisk -l" 
su -c "cat /boot/grub/menu.lst"

tararpharazon wrote:

>
> Ok in summary (hd0, 2) is booting consistently as it
should?
> If that’s true then I’d wouldn’t change anything for
awhile, ie, if
> it’s not broke don’t fix it.
> Enjoy a successful 11.4, 11…3, 11.2 and whatever.
> You can use
>
> Code:
> --------------------
>
> ls -l /dev/disk/by-id/ | grep ata
>
> --------------------
> to compare the by-id ata to /dev/sdx ids.
>
> I still don’t understand how you’re configured with the
drives.
> Could you still post to ‘SUSE Paste’ (http://susepaste.org)
> Copy and paste output from
>
> Code:
> --------------------
>
> su -c “fdisk -l”
> su -c “cat /boot/grub/menu.lst”
>
> --------------------
>
Posted to suse paste:

http://susepaste.org/42149677

Thanks again for your help.


Russ
openSUSE 11.4 MS1 (2.6.37.1-1.2-desktop)|Platform Version
4.6.2 (4.6.2) “release 3”|Intel core2duo 2.5 MHZ,|8GB DDR3|
GeForce 8400GS (NVIDIA-Linux-x86_64-270.41.06)

And thanks for the suse paste.

The reason the su -c didn’t work is because commands should be quoted, ie, su -c fdisk -l vs su -c fdisk -l .