Updated kernel today - black screen + cursor after "loading initial RAM disk"


Updated the install of 15.1 KDE (no extra repos, except Mozilla) on my Dell Precision M6400 this morning, after reboot I get a black screen with a cursor after “loading initial RAM disk”, no further boot messages even after sitting there for 20 min. (Two other Leap 15.1 just doing fine after the update…).

Booting to the older kernel 4.12.14-lp151-27default works just fine.

Any ideas how to debug this? Many thanks in advance…

Boot into the new kernel, shutdown, than boot into the old working kernel and post (to get an Xorg.log from the non working one):

cat /var/log/Xorg.0.log.old


Same with me. Installed Leap 15.1 last week, basically worked fine. Updated to 4.12.14-lp151.28.4 this morning, resulting in blackscreen at boot. Previous snapshot 4.12.14-lp151.27 works.

…removed Nouveau-stuff and rebooted, didn’t help.

Don’t think this will help:


Is there any way to remove the nonfunctional kernel? Don’t want to have it as default boot option…

Is there any way to remove the nonfunctional kernel? Don’t want to have it as default boot option…

Yast----Software----search for kernel----versions------

Thats an Xorg.0.log from the working (old) kernel…

…as I wrote, the black screen is directly after the “loading initial RAM disk”, so I don’t think there will be anything XOrg…

I marked the new kernel in YaST for deletion, will recreate the bootloader afterwards and hope I have a functional boot config afterwards, or?

Worked! The functional is default boot option again…

The same thing. On May 31 successfully upgraded opensuse leap 15.0 to 15.1 via zypper dup, and today, on June 03 upgraded kernel from 4.2.14-lp151.27-default to 4.2.14-lp151.28.4-default. The system hangs at black screen after reboot. When booting 4.2.14-lp151.28.4-default in recovery mode, the last message is ‘fb switching to nouveaufb from EFI VGA’, the system still hangs. I tried ‘nomodeset’ linux parameter in boot options, the system boots, but in VGA 640x480 mode. With the previous 4.2.14-lp151.27-default kernel the boot process finishes OK.


As implied by comment #3, if your gfxchip is nvidia, continue using the previous kernel (lp151.27). The current kernel (lp151.28) broke nouveau. To make not using the current lp151.28 kernel easier, and avoid accidentally using it, remove lp151.28.

… I don’t get why removing the nouveau stuff didn’t resolve the problem. But I’m a noob…

You can’t remove nouveau stuff that is part of the kernel without building your own kernel to exclude it.

You can prevent auto-loading of module during hardware probe: modprobe.blacklist=nouveau. Unless module is forcibly loaded manually (e.g. by /etc/modules-load.d).

Does the bug 1137067 oops seem to be in any module?

hi I have the same problem when update the Kernel to 4.12.14.lp151.28.4 . after that there isn’t any graphical login screen , so i using the kernel 4.12.14.lp151.27 . i hope the OpenSuse leap team fix it soon.

In my (second) re-install of openSUSE Leap 15.1 I checked the online repositories when invited to use them as part of the install and the 4.12.14.lp151.28.4 was still there (and it is in YaST main update directory). How will we be advised when it’s safe for those with nvidia cards to update?

I’m just a user and I’m holding off updating anything.

…tried it just some 10 min about. Same fu** up. It’s a pain…

Tried what?