updated firmware for broadcom 4318 now have no wireless at all

First I am a newb using an HP laptop dv8000 series FYI.

I started with a fresh install of OS11.2. The first thing I tried was to connect to a network through the gui net manager. This got me nowhere (nothing detected). I then noted that the card was not getting any signal/not functioning. My card is enabled from on the laptop.

I connected my laptop via ethernet and executed this command:

sudo /usr/sbin/install_bcm43xx_firmware

which returned no errors and seems to have completed successfully.

using the dmesg | grep firmware command I now get the following:

SuSE-Laptop:~ # dmesg | grep firmware
   41.246079] b43 ssb0:0: firmware: requesting b43/ucode5.fw
   41.268643] b43 ssb0:0: firmware: requesting b43/pcm5.fw
   41.320790] b43 ssb0:0: firmware: requesting b43/b0g0initvals5.fw
   41.369098] b43 ssb0:0: firmware: requesting b43/b0g0bsinitvals5.fw
   41.591065] b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
SuSE-Laptop:~ #

now the option to enable wireless in my systray (i know wrong name) has become unselectable. Now what do I do?

nevermind, it works now. retried the install script, rebooted and then did iwconfig a couple times as i pressed my internet kill switch. Turns out that was blocking the card after all. My killswitch is lit up even when it is off. Can anybody help me get it to function properly so the LED is only on when the wireless is actually enabled? Thanks. (HP DV8000)