Updated ALSA, now modules won't load

I updated alsa to the latest 1.0.22, however now the alsa modules refuse to load! When I do

rcalsasound restart

I get:

Starting sound driver: hda-intelWARNING: Error inserting snd_timer (/lib/modules/2.6.31.5-0.1-desktop/updates/alsa/acore/snd-timer.ko): Invalid module format
WARNING: Error inserting snd_pcm (/lib/modules/2.6.31.5-0.1-desktop/updates/alsa/acore/snd-pcm.ko): Invalid module format
WARNING: Error inserting snd_hwdep (/lib/modules/2.6.31.5-0.1-desktop/updates/alsa/acore/snd-hwdep.ko): Invalid module format
WARNING: Error inserting snd_hda_codec (/lib/modules/2.6.31.5-0.1-desktop/updates/alsa/pci/hda/snd-hda-codec.ko): Invalid module format
FATAL: Error inserting snd_hda_intel (/lib/modules/2.6.31.5-0.1-desktop/updates/alsa/pci/hda/snd-hda-intel.ko): Invalid module format
hda-intelWARNING: Error inserting snd_timer (/lib/modules/2.6.31.5-0.1-desktop/updates/alsa/acore/snd-timer.ko): Invalid module format
WARNING: Error inserting snd_pcm (/lib/modules/2.6.31.5-0.1-desktop/updates/alsa/acore/snd-pcm.ko): Invalid module format
WARNING: Error inserting snd_hwdep (/lib/modules/2.6.31.5-0.1-desktop/updates/alsa/acore/snd-hwdep.ko): Invalid module format
WARNING: Error inserting snd_hda_codec (/lib/modules/2.6.31.5-0.1-desktop/updates/alsa/pci/hda/snd-hda-codec.ko): Invalid module format
FATAL: Error inserting snd_hda_intel (/lib/modules/2.6.31.5-0.1-desktop/updates/alsa/pci/hda/snd-hda-intel.ko): Invalid module format
failed

My audio codec is IDT 92HD81B1C5 and the problem is I can’t get the mic to work properly with the stock alsa.

Any help will be appreciated. Thanks.

Just to add that I do follow the guide at

Alsa-update - openSUSE

and made sure I got every steps right.

Can you show us what you have installed?

What is the output of :

rpm -qa '*alsa*'

Here you go:

alsa-plugins-32bit-1.0.21-3.3.x86_64
alsa-plugins-pulse-1.0.21-3.3.x86_64
alsa-driver-kmp-desktop-1.0.22.20091225_2.6.31.5_0.1-1.1.x86_64
alsa-plugins-pulse-32bit-1.0.21-3.3.x86_64
alsa-1.0.22-51.1.x86_64
alsa-plugins-1.0.21-3.3.x86_64
alsa-utils-1.0.21-3.1.x86_64
alsa-docs-1.0.22-51.1.noarch
alsa-oss-32bit-1.0.17-25.2.x86_64
alsa-oss-1.0.17-25.2.x86_64

The update does not look complete. Please go here:

http://download.opensuse.org/repositories/multimedia:/libs/openSUSE_11.2/x86_64/

and download and install:

  • alsa-plugins-32bit–1.0.17-27.1.x86_64.rpm
  • alsa-plugins-pulse-1.0.22-19.1.x86_64.rpm
  • alsa-plugins-pulse-32bit-1.0.22-19.1.x86_64.rpm
  • alsa-1.0.22-51.1.x86_64.rpm
  • alsa-plugins-1.0.22-19.1.x86_64.rpm
  • alsa-utils-1.0.21-19.1.x86_64.rpm
  • alsa-docs-1.0.22-51.1.noarch
  • alsa-oss-32bit-1.0.17-27.1.x86_64.rpm
  • alsa-oss-1.0.17-27.1.x86_64.rpm
  • ibasound2-1.0.22-51.1.x86_64.rpm
  • libasound2-32bit-1.0.22-51.1.x86_64.rpm

Don’t forget libasound2. Then restart your PC and test.

That looks ok, assuming your have the “kernel-desktop-2.6.31.5-0.1.1.x86_64”.

Done. Except for alsa-plugins-32bit–1.0.17-27.1.x86_64.rpm which I assume you really meant alsa-plugins-32bit–1.0.22-19.1.x86_64.rpm

Still getting the same error here. Do you think it might be cause by incompatibility of the modules and kernel?

I should have mentioned that I did the same update somewhere like 2 weeks before and it works, but didn’t solve the mic problem.

I need more information.

Please provide output of running:

rpm -qa '*alsa*'
rpm -q libasound2
cat /etc/modprobe.d/50-sound.conf

and

/usr/sbin/alsa-info.sh

and select SHARE/UPLOAD and post here the URL that it provides.

Here you go:

alsa-plugins-1.0.22-19.1.x86_64
alsa-driver-kmp-desktop-1.0.22.20091225_2.6.31.5_0.1-1.1.x86_64
alsa-oss-32bit-1.0.17-27.1.x86_64
alsa-1.0.22-51.1.x86_64
alsa-utils-1.0.21-19.1.x86_64
alsa-docs-1.0.22-51.1.noarch
alsa-plugins-pulse-1.0.22-19.1.x86_64
alsa-plugins-pulse-32bit-1.0.22-19.1.x86_64
alsa-plugins-32bit-1.0.22-19.1.x86_64
alsa-oss-1.0.17-27.1.x86_64

libasound2-1.0.22-51.1.x86_64

options snd slots=snd-hda-intel,snd-hda-intel

5Dex.ZbB0f0GpBR4:SBx00 Azalia (Intel HDA)

alias snd-card-0 snd-hda-intel

l4dC.wUHZNG0hlK1:RS780 Azalia controller

alias snd-card-1 snd-hda-intel

http://www.alsa-project.org/db/?f=cf2d605532375116ebe1db4955900289de1b88cf

I notice that the first output of /usr/sbin/alsa-info.sh is quite empty. So I ran zypper rm alsa-driver-kmp-desktop to remove the 1.0.22 driver and rcalsasound restart to ley it load the 1.0.20 driver

And here’s the output with more info, hope it somehow helps you to figure things out:

http://www.alsa-project.org/db/?f=5674f30fbeaed0333a90fb0b9aea7135cc89ae65

Did that work? Because I do not think it should

If you have all the various alsa apps installed now to the latest version, then you need alsa-driver-kmp-desktop.

After installing that, you need to reboot to unload the old kernel modules and reload the new/updated.

Sound output works, but the mic is the problem…

If I install alsa-driver-kmp-desktop again then the module load error is back.

The alsa versions are not consistent with each other. Possibly a bad build by the openSUSE packager?

I recommend you write a bug report against openSUSE-11.2 component “sound” . There is guidance for writing a bug report here: Submitting Bug Reports - openSUSE

In support of the bug report, please run the script:

/usr/sbin/alsa-info.sh --no-upload

which will create the file /tmp/alsa-info.txt. Attach that file to your bug report.

Also attach the ouput of:

rpm -qa '*alsa*'
rpm -qa '*pulse*'
rpm -q libasound2

Note the person who will look at the bug report is the openSUSE packager for sound, who is also an alsa developer, so any fix they create is typically sent upstream and benefits all Linux distributions.

Also note, they are not interested (and they will not) read forums, so you need to provide all the needed information into the bug report.

Thanks!

Reference your mic, you need to examine your PCs mixer settings:

!!Amixer output
!!-------------

!!-------Mixer controls for card 0 [SB]
Card hw:0 ‘SB’/‘HDA ATI SB at 0xf2300000 irq 16’
Mixer name : ‘IDT 92HD81B1C5’
Simple mixer control ‘Front Mic’,0
Front Left: Capture 0 [0%] [0.00dB]
Front Right: Capture 0 [0%] [0.00dB]
Simple mixer control ‘Mic’,0
Front Left: Capture 3 [100%] [30.00dB]
Front Right: Capture 3 [100%] [30.00dB]
Simple mixer control ‘Mic Jack Mode’,0
Items: ‘Mic In’ ‘Line In’
Item0: ‘Mic In’
Simple mixer control ‘Capture’,0
Front Left: Capture 15 [100%] [22.50dB] [on]
Front Right: Capture 15 [100%] [22.50dB] [on]
I note your front mic is switched OFF for capture. Should it be OFF ?

Also, when checking for mic functionality I recommend you look here: Microphone - openSUSE

and in particular in a terminal use this as your test:

arecord -vv -fdat foo.wav

where “foo.wav” is some arbitrary name. Call the .wav file by any name you want.

Actually the mic works for a brief moment after I start / restarted ALSA. Just that I’ll shut itself off after awhile and cause CPU to stuck at 100% which is very annoying. I’ll file a bug report soon and post back the link for reference.

Yeah I do notice that, and came across his name many many times in various changelogs and bugzilla / openFATE.

Bug report filed, link here:
https://bugzilla.novell.com/show_bug.cgi?id=567338

Also thanks for your time oldcpu! You’re doing a fantastic job here (especially at this time of the year)!

I tried the alsa-driver-kmp-desktop-1.0.22.20091226_2.6.31.5_0.1-1.1.x86_64.rpm just generated moments ago and it works now. Probably just a bad build for the previous rpms. Will test the microphone soon.

If the microphone does not work, post the output URL provided by the script file here:

/usr/sbin/alsa-info.sh

and I’ll take a look at the mixer settings.

Again, I recommend this for testing the mic:

arecord -vv -fdat foo.wav

I also recommend you remove or disable the alsa update repository in your repository list. As you have seen those rpms can be cutting edge, and sometimes they break things.

The problem isn’t that the microphone is not working. The problem is it DOES work but after awhile it’ll stop working and cause very high wakeup to CPU. The problem persist until I restart alsa.

Any experience with this kind of problem? I know this is definitely hard to debug, well…

You could look to see if there are any warning messages in the dmesg when the PC first boots, and then later when using the mic. Note the dmesg will fill up quickly with firewall messages, so its best to test the mic reasonably soon after the boot, to get a good dmesg. One can record the dmesg as a regular user by:

dmesg > yourdmesg.txt

and then open “youdmesg.txt” with a text editor. To share its contents, copy and paste the contents from the editor to a web site such as PasteBin.be and then submit (dump) the entry, so as to be given a URL where the URL can be shared.

Also, it appears to me that that problem announced in the title to this thread is now SOLVED and you are now chasing up another problem (which was what prompted you to update to 1.0.22 of alsa, but thats another story).

You may be better served by starting a new thread with an appropriate title.

There are likely lurkers to our forum who know a LOT more about alsa and a lot more about microphones than my feable knowledge on this subject.