Update Virtualbox conflicts with Virtualbox ...

I use the normal Oracle VirtualBox from the openSUSE Leap 15.2 's repo. Suddenly, updating virtualbox becomes impossible:
patch:openSUSE-2020-2262-1.noarch conflicts with virtualbox-kmp-default.x86_64
This happens in Leap 15.2 Host AND ALSO in Leap 15.2 guest …
Is this an error with the openSUSE updaters? Will it be solved that way, in a few days?
Or do I have to do something …
Or will Virtualbox be confined to its present state …
Thanks for helping me out!:slight_smile:

I uninstalled the whole virtualbox, I reinstalled it, and now Virtualbox gives this error :

supR3HardenedMainInitRuntime what: 4 VERR_VM_DRIVER_VERSION_MISMATCH (-1912) - The installed support driver doesn’t match the version of the user.

I’m startled …

PROBLEM SOLVED by restarting … now I have the new VirtualBox 6.1.16 but I had to go through Yast software for it (could have done it with zypper up to) and choosing “option 1”: install 6.1.16 and uninstall 6.1.14 … :\

Yes, there was a problem. Also when you update with zypper there was the preemt-kerenl installed with this update. Also an problem with virtualbox.

So everyone have to read carefully the update packages.

I can reinforce this statement – check for the following:


 > zypper search --installed-only kernel
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...

S  | Name                  | Zusammenfassung                                                   | Typ
---+-----------------------+-------------------------------------------------------------------+------
i+ | kernel-default        | The Standard Kernel                                               | Paket
i  | kernel-default-devel  | Development files necessary for building kernel modules           | Paket
i  | kernel-devel          | Development files needed for building kernel modules              | Paket
i+ | kernel-docs           | Kernel Documentation                                              | Paket
i+ | kernel-firmware       | Firmwaredateien für den Linux-Kernel                              | Paket
i  | kernel-macros         | RPM macros for building Kernel Module Packages                    | Paket
i  | **kernel-preempt**        | Kernel with PREEMPT support                                       | Paket
i  | **kernel-preempt-devel**  | Development files necessary for building kernel modules           | Paket
i+ | kernel-source         | Die Quellen des Linux-Kernels                                     | Paket
i+ | **kernel-syms**           | Kernel Symbol Versions (modversions)                              | Paket
i  | nfs-kernel-server     | Support Utilities for Kernel nfsd                                 | Paket
i  | purge-kernels-service | The service for removing old kernels when multiversion is enabled | Paket
 > 
 > zypper search --installed-only virtualbox
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...

S  | Name                   | Zusammenfassung                    | Typ
---+------------------------+------------------------------------+------
i+ | virtualbox             | VirtualBox is an Emulator          | Paket
i+ | virtualbox-kmp-default | Kernel modules for VirtualBox      | Paket
i+ | **virtualbox-kmp-preempt** | Kernel modules for VirtualBox      | Paket
i+ | virtualbox-qt          | Qt GUI part for virtualbox         | Paket
i  | virtualbox-websrv      | WebService GUI part for virtualbox | Paket
 > 

I thought that, “kernel-syms” caused this issue but, it may well be that, there are other issues here …

Some of my OpenSUSE user found no network and the default OS was now the kernel-preempt. I have helped over 100 folks move from Windows 8 and 10 to Opensuse - most have a Windows 10 image in virtualbox from the original disk install. I got quite a few calls about no network and errors. Everyone with no network had booted the kernel-preempt OS - the good news was the kernel-default was the 2nd entry on the grub menu - so booting that one and removing the kernel-preempt fixed all the issues.

I now recommend doing “zypper rm kernel-preempt” - It also removed virtualbox but I did a “zypper in virtualbox” to get it back.

Something is not right with the virtualbox in the repos as 6.1.16 still want virtualbox-kmp-default 6.1.14. - you have to force install the 6.1.16 to make it work.

Just ran into the same problem. Is there already a bugzilla entry for this? I feel its worth one…

A similar thread here: https://forums.opensuse.org/showthread.php/548220-Can-not-install-new-update?p=2991070#post2991070
A manual, orderly update solved the problem here.

Bug report here it seems: https://bugzilla.opensuse.org/show_bug.cgi?id=1180625

Yes, I can do a zypper up and the update works. But next time I see the same error when updating via the softwaremanagement icon.
And I have no preempt kernel installed…

@DocB
Maybe you open a new thread with all your errors and also your running openSUSE Version.
Because this problem was about switching from Virtualbox Version 6.14 to 6.16.

I just had a fresh test installation of Leap 15.2.
The virtualbox-kmp-default-6.1.16 could not be updated automatically from 6.14, as some dependencies needed to be resolved manually, as well w/o the preempt kernel. So somewhat as described in https://bugzilla.opensuse.org/show_bug.cgi?id=1180625#c2

THESE ARE THE STEPS TO CLEAN UP ALL THOSE UNWANTED “PREEMPTS”:
In Yast, you first UNINSTALL virtualbox-kmp-preempt AND kernel-preempt AND kernel-preempt-devel (with this last one, you choose the third alternative: “keep kernel-syms with broken capacities”)
THEN YOU REBOOT
Then, in Yast again, you put a TABU option (with right mouse) on these three: virtualbox-kmp-preempt AND kernel-preempt AND kernel-preempt-devel ; that way these three won’t bother you anymore, never: they’re “tabu” now.
THEN YOU REBOOT AGAIN
Then, in Yast again, you UPDATE kernel-syms (with this, you choose the third alternative option: “keep kernel-syms with broken capacities”) Don’t bother about those “broken capacities”: they refer to the unwanted preempts.
THEN YOU REBOOT AGAIN
And now your computer works fine, your kernel-default updates will not prompt you anymore to install those ********** “preempts”, and your VirtualBox (or what it was that pulled in those “preempts”) works like a charm.
The first reboot is needed so that you can put the “tabu” option on the three “preempts”;
the second reboot is needed so that the three tabus are fixed and so that you can update your kernel-syms with the right version;
the third reboot is needed to finalize all the steps you’ve taken and to clean up your computer for good.
Have a nice day!