Update via zypper

I am running Tumbleweed (/etc/os-release shows version 20200520) and usually apply patches via the command line (su’d to root) via zypper. I tried to get a listing of the updates using ‘zypper lu’ and all of the repositories come back with
Problem retrieving files from ‘Main Update Repository’.
Permission to access ‘http://download.opensuse.org/update/tumbleweed/repodata/repomd.xml’ denied.

[FONT=arial]Anything changed with the update repositories or access to them in the last week or so (when I last ran my update)?


The update repository is only used for security stuff, the rest comes from the distribution repos, that’s how TW works. But … download.opensuse.org that holds the repos currently has issues. Traffic is now redirected to some openSUSE mirror as a temporary solution, but that doesn’t do other mirrors, so it will work, but might be slower than usual.

Thanks - I was thinking it was probably a repository issue - I can use my browser to get to the xml files that zypper says I have denied access to, but the browser looks like it is at a mirror at Duke Uni and I am not sure where zypper is taking me. BTW, I have that error message for all of the opensuse repositories. I also tried it via YaST, but got the same repository access denied. I’ll give it a few days and try again.


The main repository is facing some issues: status.opensuse.org

Also, on TW zypper lu returns a subset of packages to upgrade to. If you just want to take a peek, use

zypper dup --dry-run --no-confirm --details
zypper dup -Dy  --details #or this shorter version

Thanks for the additional information


I just tried. And “zypper lu” told me that there were 10 updates, all from packman.

It was apparently working when I checked. But it was probably broken when you checked. There are now two posts on the problem, so I doubt that it was imaginary. And even though it worked for me, it might be broken again soon. But at least we know that the problem is being worked on.