/update/tumbleweed directory is not available

I’ve noticed the download/update/tumbleweed is down. ERROR 404

http://download.opensuse.org/update/tumbleweed

Is this a bug or feature :slight_smile:

Thanks,
Jeff

It is a user error. :wink:
Try this link instead: http://download.opensuse.org/update/tumbleweed/

Background:
The tumbleweed update repo doesn’t exist under this particular URL. That URL is just a server redirect to the actual repo. For this to work, the URL has to have a trailing slash.

It is not user user error.:frowning:

It is from here
https://en.opensuse.org/openSUSE:Tumbleweed_installation#Repositories

Yes, it is.
You are not supposed to enter it as-is into your web browser…

It is from here
openSUSE:Tumbleweed installation - openSUSE Wiki

It should work fine that way when you add it as repo, as that page suggests.

Is there any problem? (other than that clicking on those links in your web browser doesn’t work)

PS: I just tried running this on my 13.2 system:

sudo zypper ar -f -c http://download.opensuse.org/update/tumbleweed repo-update

(exactly as that page says)
It worked fine here.

But again, for actually accessing that URL you need to append a ‘/’ (otherwise the server-side redirection won’t work). zypper does that anyway.


Thanks for the quick reply…

I learned something about links. That trailing / stumped me.

Thanks.

that update repo is empty - when adding this e.g. ntp is still unpatched.

Yes, but what does that have to do with this thread? :stuck_out_tongue:

Btw, the latest ntp fixes are of course in Factory already, they will be in Tumbleweed as soon as it gets republished the next time. No idea when this will be though.
If you think that it should be added to the update repo ASAP, you should probably ask on the Factory mailinglist:
http://lists.opensuse.org/opensuse-factory/

I don’t really know how critical those two security fixes are. But maybe not that severe, or else the update would be in that repo already I suppose…