Update to Firefox 3.5.3 and Xulrunner breakage


I updated Firefox today (3.5.3 from Mozilla repo) and I cannot start it anymore, having this message:

Could not find compatible GRE between version and

It appears that xulrunner has also been updated to appropriate version. Xulrunner dependency in Firefox lists exactly the version I have installed:

AFAIK, when FF and xulrunner have issues it’s because of different versions. This time the versions appear correct, so what could be the problem? Perhaps there’s something lingering in the system that did not get updated/reinstalled?

I tried installing FF and xulrunner from Factory repo, and I get the same problem.

I currently have:

MozillaFirefox-3.5.3-1.4 (x86_64) from Factory
mozilla-xulrunner191- (x86_64) from Factory

But I tried reinstalling from Mozilla repo:

MozillaFirefox-3.5.3-3.1 (x86_64)
mozilla-xulrunner191- (x86_64) – mismatch?

Please help. OpenSuse 11.1 x86_64.

Not _64

Using Mozilla repo
have FF: 3.5.3-3.1 from Mozilla

mozilla-xulrunner190 from Updates

Updated today - all OK

Look for multiple copies of xulrunner. Remove them all but the latest.
Then run check for updates again.

Had similar issue. May want to try:

xulrunner -v

Then go to the application.ini that firefox is using and find:


and adjust appropriately.