Update stuck


Every time I update of install software it gets stuck after only one package. Usually it will install/update noarch packages without any trouble. But if have a package that has a arch it will get stuck at 100%. The CPU usage will be one core for rpm at this point.

I have this when I install manually(konsole), yast if I am logged on and what I find the most strange if I do an update from the 11.2 install disk.

The only way to kill rpm is a full reboot. After that the new package it was working on is installed but the old one isn’t removed!

The package I usually see having problems is glibc. But all the KDE and GNOME packages have the same problem.

What is my problem here. I’m getting a bit frustrated!



Hé, good to see people from “home” here !!

From what you write, I get the idea that there’s something terribly wrong with the install. It should have glibc installed, AFAIK it’s a basic part of a linux install. Could it be the used media are corrupt somehow? Did you perform a check on the downloaded iso, on the burnt media?
Edit: I see you installed from a retail DVD. Still a media check would make sense.

There’s nothing above Groningen :wink:

Don’t let it frustrate you, there’s tons of help and helpers here ( and in your city :wink: )

I don’t have a ISO :smiley: I have a 11.2 retail. And this problem is from the last 2 days.

glibc is installed! But if I want to update to newer/later/same version it will get stuck. But I have a small list of about 15 packages that have the same problem (I got depressed of writhing them down).

glibc is the first to get updated if there is an update. So it isn’t only glibc its about every package.

Oet Grûnn

What does it say when it gets stuck, or does it hang completely ?

Have you tried to rebuild the package database ?

Can you give us more info, like what’s in my signature?

  1. It will just hang… There is no error. It just will not start with the next package

  2. the database is rebuild every time yast is loaded. And I have don it manually

  3. Its an amd athlon x2 6000+ on a ASUS M2N32 SLI DELUXE/wireless edition
    KDE isn’t working due to the update problem. part is 4.3.1 the other 4.4.2
    4-5 TB space. (250 GB IDE (root/home), 500GB sata, 1TB eSata, 2x1,5TB RAID 0.
    4 GB of mem, nvidia 8600GT

If you need more please let me know.

@2, not true, it rebuilds the content of the configured repos, but not the package database. A

 su -c 'rpm --rebuilddb'

will rebuild the package database.
@3 Here’s where your problem might be: “part is 4.3.1 the other 4.4.2” . No way you’re going to have a stable desktop this way.

First, we need to get you back to a stable system. I don’t know whether your machine does a lot of extras (webserver/databases etc) and if your /home is on a separate partition, but if so, the quickest way might be to reinstall, update everything, then add the KDE4 repos, and use the “Switch system packages …” option from the software installer.
Yast can also be used from the console, without starting the desktop. Boot into runlevel 3, login with username and password, and do:
su -c yast

Repairing all this may take a lot more time.

KDE is broke due to this problem. ICEvm is working.

But getting the desktop running isn’t my biggest rush. I’m very handy with init 3.

I’m not able to reinstall due to a RAID 0 linux config I have. I will lose all the data.
The update software from the installation medium has the same problem. So I think a new install will not solve this problem.

I will restart the computer en try your rpm db rebuild right now.

No I can see an error! On screen one when running the using the CD

error: cannot open Packages database in

And that very often

THANKS now it works.

Eindelijk weet ik van iemand in Groningen met verstand van Linux :smiley:

Er zijn er veel meer…PM maar eens.