Update Repository has checksum error

Hi,
I have a problem. When I start Yast, and it tries to download the update repository, there is a checksum error. The problem is, that this error is always there, it occured about 2 weeks ago and never disappeared. When I change the update repository to a specific one, I chose a german one, there is still that checksum error. If I say yast I want to still use the repository with the error, there comes another checksum error, if i say i dont care about that one either, it says

"Download failed:
./repodata/primary.xml.gz could not be retrieved from http://download.opensuse.org/update/11.2/
Progress:
-[DownloadCommand.cc:195] caught EOF from server"

Can you help me, what is wrong here?

The address, Index of /update/11.2
is correct, so it should work. You can try deleting that repo and recreating it.

Is this happening when the repo refreshes, or when you try to download a particular package?

thanks for the reply!

this is happening when it refreshs the repository.

I tried to delete it and re-add the update repo, but the same checksum error occurs.

Try this url:

Index of /pub/ftp.opensuse.org/opensuse/update/11.2

same thing, the checksum error still appears

Maybe this helps to solve my problem:
When I try to add this repo in yast, and ignore these checksum errors another message shows up:

The Change of the Repository-Configuration could not be saved.
Details:
update:|] buffering of the Repo (4) failed.
Progress:
-‘repo2solv.sh’‘-0’‘/var/cache/zypp/solv/update/solv’‘/var/cache/zypp/raw/update’
repo_rpmmd: not well-formed (invalid token) at line 483643:0

try again?

Please post output of ‘zypper lr’

‘zypper lr’:

# | Alias                                                           | Name                                                            | Aktiviert | Aktualisieren
--+-----------------------------------------------------------------+-----------------------------------------------------------------+-----------+--------------
1 | Nvidia_11.2                                                     | Nvidia 11.2                                                     | Ja        | Ja
2 | Packman                                                         | Packman                                                         | Ja        | Ja
3 | VLC_11.2                                                        | VLC 11.2                                                        | Ja        | Ja
4 | http-download.opensuse.org-8cf14cd7                             | http-download.opensuse.org-8cf14cd7                             | Nein      | Nein
5 | http://download.opensuse.org/repositories/KDE:/43/openSUSE_11.2 | http://download.opensuse.org/repositories/KDE:/43/openSUSE_11.2 | Nein      | Nein
6 | openSUSE 11.2-0                                                 | openSUSE 11.2-0                                                 | Ja        | Nein
7 | repo-non-oss                                                    | openSUSE-11.2-Non-Oss                                           | Ja        | Nein
8 | repo-oss                                                        | openSUSE-11.2-Oss                                               | Ja        | Nein

The update repository is not there. I cant add it, because of that checksum error

Hi,
I just found out, I can’t add any repository in yast. So is this a yast problem? Should I reinstall yast?
please help me!

From a su terminal try this, copy and paste the following with your mouse:

zypper ar http://download.opensuse.org/update/11.2/ Update

You must then go to Yast - repositories and make sure Update is refreshing.

okay zypper command worked.

I’m not quite sure what you mean with “make sure Update refreshing”, but in Yast I selected the Update repository and clicked Refresh -> Refresh Now.

Then the same as always happend, it downloaded a few files, the file updateinfo.xml.gz had a checksum error. But I didn’t get a second checksum error, like before. just that ‘Download Failed’ error.

I’m watching this post too, it seems this guy has a similar problem: http://http://forums.opensuse.org/applications/432678-download-opensuse-org-down.html

In Yast - Software repositories
There are 2 check boxes. One for refresh and One for enable, make sure they are both checked.
Run updates from a terminal

zypper up

the update repository didn’t work there either, it was deactivated. It installed 119 packages anyway.
But I tried yast again, but still the update repo has checksum error

Does any one have a suggestion what I should do?
Would It help to make a clean install of SuSE?

It may well help to do a clean install
But I would try other options first

Did you ever delete ALL your repo’s?

No, but I did it now. I deleted all of them, but one:


# | Alias                               | Name   | Active | Refresh
--+-------------------------------------+--------+-----------+--------------
1 | http-download.opensuse.org-8cf14cd7 | weird | No     | No

I don’t even know why it is there and where I got that from.
For some Reasons I couldn’t delete it:

No Access to Installation-Medium
dir:///var/cache/zypp/raw/http-download.opensuse.org-8cf14cd7 (Medium 1).
Try If you can access the Directory.

I clicked “Abort” and it was gone.
I readded the update repository, but still doesnt work

Sorry for bugging you with that, but I really want this silly problem solved without doing a new install.

Any other suggestions?

Follow these steps:

  1. Delete all repos
  2. Use Dolphin Super user and Go to /var/cache/zypp/ - and delete everything from each folder /packages /raw, /solv
  3. Now lets try adding the main repos back
zypper ar -f http://download.opensuse.org/distribution/11.2/repo/oss/ OSS

zypper ar -f http://download.opensuse.org/distribution/11.2/repo/non-oss/ NON-OSS
zypper ar -f http://download.opensuse.org/update/11.2/ UPDATE

see how you get on

kannnte wrote:
> Any other suggestions?

i’m not at all sure if you actually ever deleted all repos and then
install JUST four:
oss
non-oss
update
packman

and click to enable AND auto-update

add NO other repos…then, in a terminal


su -

do not forget the -
give your root pass with asked (you won’t see what you type)

then


zypper up

and WAIT

then, try to avoid one-click installs as it is those that screw up
your repo list…use YaST or Zypper instead of one-clicks…if you
ever use another one click then IMMEDIATELY after using it, open YaST,
go to Software Repositories and DISable all but those four listed
above, AND click them to NOT automatically update…

LEAVE the four enabled and updating…

if that does not work then you have something else…


palladium

hello kannnte!

please ignore my post COMPLETELY!!

ALWAYS follow caf’s directions carefully and completely…

his was being written as i wrote mine…


palladium