Update Repo won't refresh

I’m getting the following error while running ‘zypper refresh’:

Retrieving repository ‘openSUSE-11.3-Update’ metadata |]
Failed to download ./repodata/ad60183f3f14b8bb3baaff68605d931f5c8a6a7f-updateinfo.xml.gz from http://download.opensuse.org/update/11.3/
Abort, retry, ignore? [a/r/i/?] (a):

I’ve turned off all my repos except for Main and Update (several others, KDE 4.5, Mozilla, etc. started having the same issue, or problems verifying the integrity of the download).

I’ve tried zypper clean --all + rpm --rebuilddb, re-adding the update repo, etc. but nothing seems to work. A manual download of the .xml.gz via aria2c fails, but wget is fine.

I also tried re-installing zypper from the main-repo, i.e. going back to 1.4.5 from 1.4.8, but that didn’t help.

Any suggestions?

You don’t need to deinstall repos. You can refresh repos one by one with:
zypper refresh -r repo
where repo can be a repo number, alias, or name.
Use zypper lr to view your repos.

?
Er, I’m not trying to de-install. Sorry if I wasn’t clear, there’s probably more info in my first post than there needs to be.

Simply, several repos fail to refresh, the most prominent and annoying being the 11.3 update repo.
It fails to download the repodata.

I’ve tried several workarounds to try to simplify things, but haven’t gotten anywhere.

Edit to the above - Thanks for the quick reply!

It was clear to me that you’re not trying to deinstall. I just suggested to isolate the problem by refreshig the repos one by one rather than deinstalling them. Btw you could also disable/reenable (zypper mr -d/zypper mr -e) repos.
The issue you describe looks like a network problem at one of both ends. Also check if the partition where you have /var/cache/zypp/packages is not getting full (in case you’re using a separate /var partition maybe). You might find some infos in /var/cache/zypp/aria2.stats

Try this UR|L

Index of /pub/opensuse/update/11.3

Ah, my bad. I misunderstood you.

I’ve gone down to only 2 repos: Main-OSS, and Update. Main is fine, Update has the download problem.

/var is on my root part. and ~2G free, but that’s a good thought.

Lots of failure messages in the aria2.stats log. Looks like it’s trying all the mirrors, including the one mentioned by caf4926, but with no luck.

Interestingly enough, out of the 3 11.3 machines I have at home, 2 are having this problem. The third one reads repos and updates like charm, just as they were all doing last week.

I’d wondered if maybe there was something mucked up in the repo data, but since one of my machines is working, that’s not it. AND, since one of my machines is working (consistently), it’s not as likely to be my home net or ISP. Something’s got to be mucked up on these two machines . . .

Are there any other zypper or aria2c configs/caches/etc that can be cleared out, set to default, ???

Tried the link, and no luck. As I mentioned in my last post, the aria2c log showed it was trying this mirror and failing, too. Still, it’s a bummer.

<sigh>
Alright, well, I figured it out - not surprisingly, it was an unintentional sort of self-inflicted wound.

After writing the above comments, I remembered that I’d installed dansguardian on the 2 broken machines last week.

A quick check in /etc/dansguardian/lists showed that .gz files (and .tar, .tgz, .zip, etc.) are being blocked both by extension and mime type (blockedextensionlist, blockedmimetypelist).

IMHO, since I was unwittingly bitten, I’d expect these extension to not be enabled by default - is this a feature or bug request to the package maintainer, or just a ‘duh’ for the user to figure out?

I’d rather go for feature request but most likely it was written somewhere in the documentation :slight_smile:

Best regards,
Greg