Update problems

I’m running OpenSUSE 11.0 and trying to update it.

First problem: When I click on the yellow triangle, I get the message “Helper program returned invalid xml”. I’ve tried various cache clears but that hasn’t helped. If I knew where that invalid xml file was located, I could try deleting it and letting it be regenerated, but I have no idea where it is.

I’ve tried clearing out my repository list and regenerating it with just the Main Update Repository (OSS) and the Main Update repository, but that didn’t help with either this problem or the second problem.

Second problem: If I call Online Update from Yast, I get a very long list of packages with dependency problems. Trying to fix them one by one does not seem to be the right thing to do, especially since in whatever state it’s in, each change takes a long time to compute the dependencies.

go into konsole and type zypper ref then zypper up -t packages

I found the problem but don’t have a full explanation. The repositories listed by Yast under Community Repositories were for OpenSUSE 10.3, not OpenSUSE 11.0. Yet when I refreshed the list of Community Repositories, the list appeared to be coming from an 11.0 source.

How can I get the Community Repositories list updated to 11.0?

I just looked at the URL download.opensuse.org/repositories/openSUSE. The list given there shows 10.3 but not 11.0.

here is a list of yast repo’s Additional YaST Package Repositories - openSUSE
you can go into yast and manually edit your repo’s