Update problem OpenSUSE 13.2

Yesterday I got alert new update is ready. But, ether I update using updater, or console command sudo zypper update, updating can not be executed. System message is:

Installation of libweed0-2.2.7-1.3 failed:
Error: Subprocess failed. Error: RPM failed: error: File not found: /var/cache/zypp/packages/Packman Repository/Multimedia/i586/libweed0-2.2.7-1.3.i586.rpm

What is wrong? How this error could be fixed?

Thank you for answer my question.

I wonder if this is related to the RPM zypper issue.

Try to update your rpm and zypper first;
zypper in rpm zypper

zypper ref
zypper up

It worked. Thank you. I had the same issue.

Thank you for help in the name of those who tried. I back from work one hour before, started my computer, then it offered me update different than yesterday. I did it. Then it offered me updates from yesterday, and it done it also! Ofcourse, I will save your advice to update zypper. Once again - thank you!

Cool zypper solved it, i almost pulled my hair and screamed =D