Update packages have wrong architecture

Hi
I have noticed that I cannot update today. There is 195 updates
There are a lot of warnings about changing of architecture in zypper.

Zypper want to install is a lot of i586 packages instead x86_64.
Is this a bug?
What should I do?

Post:

zypper lr -d

Also post:

zypper up

You can cancel and post.

zypper lr -d

[QUOTE]# | Alias | Nazwa | Włączono | Sprawdzaj GPG | Odśwież | Priorytet | Typ | Adres URI | Usługa
—±-------------------------------------±---------------------------------±---------±--------------±--------±----------±---------±--------------------------------------------------------------------------±------
1 | RPM | RPM | Tak | ( p) Tak | Tak | 99 | plaindir | dir:/home/rektal/Dokumenty/Instalki/RPM |
2 | brave-browser | brave-browser | Tak | (r ) Tak | Tak | 99 | rpm-md | https://brave-browser-rpm-release.s3.brave.com/x86_64/ |
3 | download.opensuse.org-non-oss | Repozytorium główne (NON-OSS) | Tak | (r ) Tak | Tak | 99 | rpm-md | http://download.opensuse.org/tumbleweed/repo/non-oss/ |
4 | download.opensuse.org-oss | Repozytorium główne (OSS) | Tak | (r ) Tak | Tak | 99 | rpm-md | http://download.opensuse.org/tumbleweed/repo/oss/ |
5 | download.opensuse.org-tumbleweed | Główne repozytorium aktualizacji | Tak | (r ) Tak | Tak | 99 | rpm-md | http://download.opensuse.org/update/tumbleweed/ |
6 | google-chrome | google-chrome | Tak | (r ) Tak | Tak | 99 | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64 |
7 | openSUSE_Leap_15.1 | KDE Extra | Tak | (r ) Tak | Tak | 99 | rpm-md | http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_Tumbleweed/ |
8 | openSUSE_Leap_15.1_1 | Firefox | Tak | (r ) Tak | Tak | 99 | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_Tumbleweed/ |
9 | packman.inode.at-openSUSE_Tumbleweed | Packman Repository | Tak | (r ) Tak | Tak | 99 | rpm-md | http://packman.inode.at/suse/openSUSE_Tumbleweed/ |
10 | repo-oss | Update | Tak | (r ) Tak | Tak | 99 | rpm-md | https://download.opensuse.org/update/tumbleweed/ |
11 | skype-stable | skype (stable) | Tak | (r ) Tak | Tak | 99 | rpm-md | https://repo.skype.com/rpm/stable/ /QUOTE]

I have got Tumbleweed. I use zypper dup to update.

I have noticed that there is a problem with inkscape, krita and libreoffice packages. These packages want to change architecture.

There is a problem with inkscape only. There is an info: inkscape-lang-1.0.1-1.1.noarch requires inkscape = 1.0.1, but this requirement cannot be provided.

I did update without inkscape package.

https://lists.opensuse.org/opensuse-factory/2020-09/msg00139.html

On Tue, 2020-09-15 at 21:29 +0200, Achim Gratz wrote:Dominique Leuenberger writes:[INDENT] inkscape (1.0 -> 1.0.1)

The inkscape x86_64 package was successfully built, but for some reason
doesn’t seem available in this update?
[/INDENT]
Sadly, at the time, inkscape did not build successfully for x86_64 -
which is why it’s missing. I had since retriggered a rebuild for this
package which then succeeded.

Next snapshot will bring it (0915 - just moving to QA these minutes)

Cheers,
Dominique