Update - no dd is dying silently

Hi!

TW 64bit, lastest updates

uname -a
Linux linux-iey6 4.10.4-1-default #1 SMP PREEMPT Sat Mar 18 12:29:57 UTC 2017 (e2ef894) x86_64 x86_64 x86_64 GNU/Linux

I try to dd a 3GB .img file (could do that with the SAME file in February on this machine, file lying around on desktop all the time) to a 4 GB CF-card (Transcend CF170 industrial), but dd falling asleep always underway:

~/Desktop> sudo dd if=OPNsense-17.1-OpenSSL-nano-i386.img of=/dev/sdd bs=16k
[sudo] password for root:
104537+0 records in
104537+0 records out
1712734208 bytes (1.7 GB, 1.6 GiB) copied, 30.8945 s, 55.4 MB/s
106510+0 records in
106510+0 records out
1745059840 bytes (1.7 GB, 1.6 GiB) copied, 49.0864 s, 35.6 MB/s
106573+0 records in
106573+0 records out
1746092032 bytes (1.7 GB, 1.6 GiB) copied, 94.4704 s, 18.5 MB/s
106746+0 records in
106746+0 records out
1748926464 bytes (1.7 GB, 1.6 GiB) copied, 235.726 s, 7.4 MB/s
106812+0 records in
106812+0 records out
1750007808 bytes (1.8 GB, 1.6 GiB) copied, 289.63 s, 6.0 MB/s
107106+0 records in
107106+0 records out
1754824704 bytes (1.8 GB, 1.6 GiB) copied, 529.598 s, 3.3 MB/s
111415+0 records in
111415+0 records out
1825423360 bytes (1.8 GB, 1.7 GiB) copied, 5185.66 s, 352 kB/s

… and never finishes. Any ideas how to solve this?

Was that with “zypper dup” (works) or “zypper up” (often has random failures)?

Hi! zypper dup --no-allow-vendor change actually… But yesterday it killed the VLC codecs for raspi cams. After next update it was back, but after update yesterday afternoon (?) VLC is gone again… Coming and going.

I use the VLC libs and codecs from Packman. Are yours from mixed repositories? The more frequently you change Tumbleweed versions from live repositories, the more likely you are to catch them in a state of flux. There does not appear to be any advantage in changing versions more than once in every week or two – mostly you are just changing to another (automated} build of the same code.

FWIW I have never observed any difficulty in using “dd” which is in the “coreutils” package. How do you kno that the problem is with “dd” and not the block device access? Try copying the image to another file on the same hard drive. If /dev/sdd is a USB drive have you tried repartitioning it with “parted”?

Recently nearly every time I update TW something breaks, so I do frequent updates to get something fixed… ot break something new.

sdd is a USB-cardreader with CF-card inside.

Did a fresh download in the meantime. Tried a second card-reader. Tried a second CF-card. Nothing boots after dd finished without error for this new .img

dd may use /tmp so be sure you have space enough to deal with the large file

/tmp is on root? Root has 9.1 GB free, /home has 9.8 GB free… Was one of my first thoughts… …and: Yes, I checked the sha256 sum of the download :wink:

Does that include snapshots?

/root and /home are ext4…

Believe it or not, after latest updates and reboot

dd if=OPNsense-17.1-OpenSSL-nano-i386.img of=/dev/sdd bs=16k
76091+0 records in
76091+0 records out
1246674944 bytes (1.2 GB, 1.2 GiB) copied, 4.48755 s, 278 MB/s
85138+0 records in
85138+0 records out
1394900992 bytes (1.4 GB, 1.3 GiB) copied, 14.5674 s, 95.8 MB/s
170706+0 records in
170706+0 records out
2796847104 bytes (2.8 GB, 2.6 GiB) copied, 92.0915 s, 30.4 MB/s
196608+1 records in
196608+1 records out
3221233664 bytes (3.2 GB, 3.0 GiB) copied, 181.458 s, 17.8 MB/s
196608+1 records in
196608+1 records out
3221233664 bytes (3.2 GB, 3.0 GiB) copied, 181.459 s, 17.8 MB/s

…and this time the copy boots just fine!

No idea what’s that.

It is a bit beside the subject of this thread, but take note: /root is not the same as /.
Maybe it does not matter and people may understand what you mean instead of what you say, but this could confuse others.

Hi to The Netherlands!

I regret and unsay, are 15 lashes an appropriate punishment? Unfortunately I cannot edit the post anymore… :shame:

I do not know who you will hire for those lashes, but I allow you to change them for a beer. :wink:

… only one???

I think trading 15 lashed for one beer is a good business. But you are allowed to negotiate.

AK

Yes, that is a good on line course on how to do it rotfl!