update kernel

the system says it has an update to install but when i connect to install it i get the message :

Failed to update system: Authorisation could not be obtained

how can i get the authorization?

Many thanks

How are you trying to update?

The GUI should have asked you for the admin password.

You can do it easier from a terminal, try these 2 commands:

sudo zypper refresh
sudo zypper up

It will ask for the root password.

it works with “zypper” but when i try to load a repository i get the message :
“Permission denied”

If you loaded your graphical desktop through the CLI or terminal, this problem may happen. I’ve had the same thing happen multiple times. Restarting and tryin again should solve the problem. If you cannot reboot because the options are grayed-out, open a terminal, login as root with the su command and the root password, and then enter the command reboot. When OpenSUSE reboots, log back in and try to update again.

Hope this helps. :slight_smile:

many thanks but…
i reboot and try under root and i can’t install repositories frm this web site :

Index of /update/11.0/rpm/i586

any idea?

Sorry, I worded that wrong. :frowning:

I meant to reboot and login as a normal user and then try again.

Sometimes if you booted into OpenSUSE through the CLI or used the CLI while logged in, this problem may occur.

Again, sorry for the misunderstanding.

Try deleting and re-adding the repository in YaST Software Repositories. The correct url is:

Index of /update/11.0

I am having the same problem with the auto update, and none of the suggestions here have helped, any other suggestions?

We need more information, as complete and precise a description as possible. Also, might get more attention if you opened a new thread . . .

I am also having the same issue.

I tried:

sudo zypper refresh
sudo zypper up

However it says the following:

A Zypp transaction is already in progress. This means, there is another application using the libzypp libary for package management running. All such applications must be closed before using this command.

I am assuming it is the PackageKit Update applet. So if anyone knows how ot shut that down so I can run the zypper commands please let me know.

You are probably right. The updater periodically checks for, well, updates. Right-click the icon to bring up a menu, then just click on Quit. If you still get that error message, run ksysguard and search/filter on “zypper” and “opensuseupdater”, and delete it (or both).

Ok I got that guy shut down and ran zypper commands and stuff apeared to work correctly till I rebooted. Any other ideas on how to “fix” this problem.

If you login as root and got to System Monitor and shut down the process Packagekitd. You should then be able to run the zypper commands. This still does not fix the issue of not being able to update.

> If you login as root and got to System Monitor

never ever log into the gui as root…never…

always log in as a normal user and then use root powers via yast, or a
terminal and kdesu or su - or . . .

there are just too many easy ways to kill your system by logging into
KDE, Gnome or whatever as root…

do NOT do it…ever.

if you do there is no telling what kind of strange stuff will go wrong…

DenverD (Linux Counter 282315)
A Texan in Denmark

Well I am sure just killing a processes and running two commands at the terminal will be fine. But if you don’t know what your doing and plan on staying logged in as root for a long time then yes that is good advice :slight_smile:

Also a bug report is already opened in bugzilla