update keeps looping back

I’ve had openSUSE for a week. The update says that there are 10 updates. When I run it, first I get a flag saying that something can’t be removed. Then when I run the rest of the up date, it loops back and starts over.
I need a patch to fix the patch that fixes the patch that…etc.
Any way to fix the fixer?

Please open a terminal and post result of

zypper lu
zypper lp

linux-kluc:/home/pottzie/Desktop # zypper lu
Retrieving repository 'PK_TMP_DIR' metadata [done]
Retrieving repository 'openSUSE-11.2-Update' metadata [done]
Building repository 'openSUSE-11.2-Update' cache [done]
Loading repository data...
Reading installed packages...
S | Repository           | Name            | Current Version | Available Version | Arch  
--+----------------------+-----------------+-----------------+-------------------+-------
v | openSUSE-11.2-Update | apparmor-parser | 2.3.1-11.12.1   | 2.3.1-11.13.1     | i586  
v | openSUSE-11.2-Update | apparmor-utils  | 2.3.1-12.2      | 2.3.1-12.3.1      | noarch
v | openSUSE-11.2-Update | libopenssl0_9_8 | 0.9.8k-3.6.1    | 0.9.8k-3.7.1      | i586  
v | openSUSE-11.2-Update | libtheora0      | 1.0.0-2.5       | 1.0.0-2.6.1       | i586  
v | openSUSE-11.2-Update | openssl         | 0.9.8k-3.6.1    | 0.9.8k-3.7.1      | i586  
v | openSUSE-11.2-Update | paprefs         | 0.9.9-2.5       | 0.9.9-2.6.1       | i586  
v | openSUSE-11.2-Update | pavucontrol     | 0.9.9-2.5       | 0.9.10-1.1.1      | i586  
v | openSUSE-11.2-Update | perl            | 5.10.0-72.5     | 5.10.0-72.6.1     | i586  
v | openSUSE-11.2-Update | perl-base       | 5.10.0-72.5     | 5.10.0-72.6.1     | i586  
v | openSUSE-11.2-Update | perl-doc        | 5.10.0-72.5     | 5.10.0-72.6.1     | i586  
v | openSUSE-11.2-Update | yast2-pam       | 2.17.1-2.1      | 2.18.1-0.1.1      | noarch
linux-kluc:/home/pottzie/Desktop # zypper lp
Loading repository data...
Reading installed packages...

Repository           | Name                        | Version | Category    | Status
---------------------+-----------------------------+---------+-------------+-------
openSUSE-11.2-Update | apparmor-parser             | 2200    | recommended | needed
openSUSE-11.2-Update | cifs-mount                  | 2128    | security    | needed
openSUSE-11.2-Update | cron                        | 2026    | security    | needed
openSUSE-11.2-Update | cups                        | 1650    | security    | needed
openSUSE-11.2-Update | cups                        | 2102    | security    | needed
openSUSE-11.2-Update | ghostscript-library         | 1630    | recommended | needed
openSUSE-11.2-Update | gmime                       | 1997    | security    | needed
openSUSE-11.2-Update | gnome_2_28_2                | 1848    | recommended | needed
openSUSE-11.2-Update | libopenssl-devel            | 1554    | security    | needed
openSUSE-11.2-Update | libopenssl-devel            | 2232    | security    | needed
openSUSE-11.2-Update | libpulse-browse0            | 1967    | recommended | needed
openSUSE-11.2-Update | libtheora                   | 2069    | security    | needed
openSUSE-11.2-Update | openssl-CVE-2009-4355.patch | 1833    | security    | needed
openSUSE-11.2-Update | perl                        | 2185    | recommended | needed
openSUSE-11.2-Update | yast2-pam                   | 2186    | recommended | needed
linux-kluc:/home/pottzie/Desktop # 



So what happens if you run as su

zypper up

Guess that’s it.


linux-kluc:/home/pottzie/Desktop # zypper up
Retrieving repository 'PK_TMP_DIR' metadata [done]
Loading repository data...
Reading installed packages...

The following packages are going to be upgraded:
  apparmor-parser apparmor-utils libopenssl0_9_8 libtheora0 openssl paprefs 
  pavucontrol perl perl-base perl-doc yast2-pam 

11 packages to upgrade.
Overall download size: 15.9 MiB. After the operation, additional 20.0 KiB will 
be used.
Continue? [y/n/?] (y): y
Retrieving package libtheora0-1.0.0-2.6.1.i586 (1/11), 135.0 KiB (686.0 KiB unpacked)
Retrieving delta: ./rpm/i586/libtheora0-1.0.0-2.5_2.6.1.i586.delta.rpm, 11.0 KiB
Retrieving: libtheora0-1.0.0-2.5_2.6.1.i586.delta.rpm [done (0 B/s)]
Applying delta: ./libtheora0-1.0.0-2.5_2.6.1.i586.delta.rpm [done]
Installing: libtheora0-1.0.0-2.6.1 [done]
Retrieving package apparmor-utils-2.3.1-12.3.1.noarch (2/11), 232.0 KiB (1.1 MiB unpacked)
Retrieving delta: ./rpm/noarch/apparmor-utils-2.3.1-12.2_12.3.1.noarch.delta.rpm, 27.0 KiB
Retrieving: apparmor-utils-2.3.1-12.2_12.3.1.noarch.delta.rpm [done (0 B/s)]
Applying delta: ./apparmor-utils-2.3.1-12.2_12.3.1.noarch.delta.rpm [done]
Installing: apparmor-utils-2.3.1-12.3.1 [done]
Retrieving package apparmor-parser-2.3.1-11.13.1.i586 (3/11), 364.0 KiB (1.2 MiB unpacked)
Retrieving delta: ./rpm/i586/apparmor-parser-2.3.1-11.12.1_11.13.1.i586.delta.rpm, 43.0 KiB
Retrieving: apparmor-parser-2.3.1-11.12.1_11.13.1.i586.delta.rpm [0% (34.3 KiB/sRetrieving: apparmor-parser-2.3.1-11.12.1_11.13.1.i586.delta.rpm [done (34.3 KiB/s)]
Applying delta: ./apparmor-parser-2.3.1-11.12.1_11.13.1.i586.delta.rpm [done]
Installing: apparmor-parser-2.3.1-11.13.1 [done]
Retrieving package libopenssl0_9_8-0.9.8k-3.7.1.i586 (4/11), 673.0 KiB (1.9 MiB unpacked)
Retrieving: libopenssl0_9_8-0.9.8k-3.7.1.i586.rpm [done (75.1 KiB/s)]
Installing: libopenssl0_9_8-0.9.8k-3.7.1 [done]
Retrieving package perl-base-5.10.0-72.6.1.i586 (5/11), 1.2 MiB (4.0 MiB unpacked)
Retrieving delta: ./rpm/i586/perl-base-5.10.0-72.5_72.6.1.i586.delta.rpm, 52.0 KiB
Retrieving: perl-base-5.10.0-72.5_72.6.1.i586.delta.rpm [done (0 B/s)]
Applying delta: ./perl-base-5.10.0-72.5_72.6.1.i586.delta.rpm [done]
Installing: perl-base-5.10.0-72.6.1 [done]
Retrieving package pavucontrol-0.9.10-1.1.1.i586 (6/11), 111.0 KiB (556.0 KiB unpacked)
Retrieving delta: ./rpm/i586/pavucontrol-0.9.9_0.9.10-2.5_1.1.1.i586.delta.rpm, 35.0 KiB
Retrieving: pavucontrol-0.9.9_0.9.10-2.5_1.1.1.i586.delta.rpm [done (0 B/s)]
Applying delta: ./pavucontrol-0.9.9_0.9.10-2.5_1.1.1.i586.delta.rpm [done]
Installing: pavucontrol-0.9.10-1.1.1 [done]
Retrieving package paprefs-0.9.9-2.6.1.i586 (7/11), 60.0 KiB (228.0 KiB unpacked)
Retrieving delta: ./rpm/i586/paprefs-0.9.9-2.5_2.6.1.i586.delta.rpm, 21.0 KiB
Retrieving: paprefs-0.9.9-2.5_2.6.1.i586.delta.rpm [done (0 B/s)]
Applying delta: ./paprefs-0.9.9-2.5_2.6.1.i586.delta.rpm [done]
Installing: paprefs-0.9.9-2.6.1 [done]
Retrieving package openssl-0.9.8k-3.7.1.i586 (8/11), 494.0 KiB (1.1 MiB unpacked)
Retrieving: openssl-0.9.8k-3.7.1.i586.rpm [done (31.7 KiB/s)]
Installing: openssl-0.9.8k-3.7.1 [done]
Retrieving package yast2-pam-2.18.1-0.1.1.noarch (9/11), 27.0 KiB (108.0 KiB unpacked)
Retrieving delta: ./rpm/noarch/yast2-pam-2.17.1_2.18.1-2.1_0.1.1.noarch.delta.rpm, 8.0 KiB
Retrieving: yast2-pam-2.17.1_2.18.1-2.1_0.1.1.noarch.delta.rpm [done (0 B/s)]
Applying delta: ./yast2-pam-2.17.1_2.18.1-2.1_0.1.1.noarch.delta.rpm [done]
Installing: yast2-pam-2.18.1-0.1.1 [done]
Retrieving package perl-5.10.0-72.6.1.i586 (10/11), 6.6 MiB (29.2 MiB unpacked)
Retrieving delta: ./rpm/i586/perl-5.10.0-72.5_72.6.1.i586.delta.rpm, 294.0 KiB
Retrieving: perl-5.10.0-72.5_72.6.1.i586.delta.rpm [done (30.3 KiB/s)]
Applying delta: ./perl-5.10.0-72.5_72.6.1.i586.delta.rpm [done]
Installing: perl-5.10.0-72.6.1 [done]
Retrieving package perl-doc-5.10.0-72.6.1.i586 (11/11), 6.0 MiB (9.6 MiB unpacked)
Retrieving delta: ./rpm/i586/perl-doc-5.10.0-72.5_72.6.1.i586.delta.rpm, 343.0 KiB
Retrieving: perl-doc-5.10.0-72.5_72.6.1.i586.delta.rpm [done (51.6 KiB/s)]
Applying delta: ./perl-doc-5.10.0-72.5_72.6.1.i586.delta.rpm [done]
Installing: perl-doc-5.10.0-72.6.1 [done]
There are some running programs that use files deleted by recent upgrade. You may wish to restart some of them. Run 'zypper ps' to list these programs.
linux-kluc:/home/pottzie/Desktop # 



Looks good
So now what do you get from

zypper lu

linux-kluc:/home/pottzie/Desktop # zypper lu
Loading repository data...
Reading installed packages...
No updates found.


But while this shows no updates found, the icon on the bottom panel shows 7 updates (including something about Sanyo printers that I’m sure I have no use for.)
When I use the GUI the updates freeze/hang,the “spin” icon sits there while nothing changes, and no download takes place. Also I still get the “unable to remove a protected system package” flag that says


Subprocess failed. Error: RPM failed: error: package cron-4.1-195.196.1.i586 is not installed

Right click the updater applet
Configure - and UNCHECK the Start at boot.
Quit the applet

Reboot. It should be gone.

Now open a terminal and do this as su -

rpmdb --rebuilddb

From now on, to update. Just do

zypper up

I just rebooted before logging on and reading this.As of right now, there is no update icon to concern myself with. I’ll wait until it shows up again and see what happens.
Wonder what happened to all those updates?