update installation from 11.4 to 12.1 with RAID, DM_CRYPT LUKS, LVM2 not failed partially

Correction: thread title s/not//
Update installation from 11.4 to 12.1 with RAID, DM_CRYPT LUKS, LVM2 failed partially

My previous 11.4 system had a file system similar to Root filesystem over LVM2, DM-Crypt and RAID - Gentoo Linux Wiki

i.e.
2x 160 MB sda1,sdb1 RAID1 with non-encrypted /boot
2x 1 TB sda2, sdb2 RAID1 with LUKS encryption and LVM2 with / and /swap

I updated the system with the OpenSuse 12.1 DVD and got a wrong menu.lst in /boot/grub which needed manually repair, because kernel and initrd were not found on (hd0). I changed this to (hd0,0) to get the system started.

My observation:

(1) The wrong grub menu.lst entries appear to be the result of a buggy OpenSuse 12.1 installer which can not correctly set up grub on encrypted 11.4 system LVM/RAID file systems.

The remaining problem is that md0 (/boot) is correct but instead of md1 my system mounts md127 and requires to enter the password for cr_md127 and soon later during the boot for cr_md1.

cat /etc/mdadm.conf shows the correct previous values
ARRAY /dev/md0 UUID=…
ARRAY /dev/md1 UUID=…

but these values are apparently ignored during boot.

My Questions:

(2) How can I change md127 “cr_md127” to the correct “cr_md1” md1 ?
The internet knows some tricks [li] mdadm --stop (old layout) and mdadm --assemble (new layout), but this trick cannot be applied because the LVM is mounted and blocking this.[/li][li] linux - How do I rename an mdadm raid array? - Server Fault[/li]
(3) Is a “second update” installation OpenSuse 12.1->12.1 a way to overcome the problem ?

12.1 uses *systemd *by default, whic is incompatible with linux raid.

You could use init=/sbin/init as a kernel parameter in grub.
There is a raid-compatible systemd at:
http://download.opensuse.org/repositories/home:/fcrozat:/systemd/openSUSE_12.1/

addendum
https://bugzilla.novell.com/show_bug.cgi?id=731230

On 2011-12-07 03:06, eng-int wrote:
>
> 12.1 uses -systemd -by default, whic is incompatible with linux raid.

Is this known and reported? I see no mention in the release notes or the
“Most annoying bugs 12.1” pages.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

apology
The correct boot parameter for a traditional (System V) init is
*init=/sbin/sysvinit *
This also has the advantage of not resetting the console when presenting the text login. That bug remains in the alternate systemd, which is annoying when trying to see what is happening during boot.

On 2011-12-07 03:26, eng-int wrote:
>
> addendum
> https://bugzilla.novell.com/show_bug.cgi?id=731230

This should be added here:


http://en.opensuse.org/openSUSE:Most_annoying_bugs_12.1


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

I already tried to manually set - pressing F5 and selecting - “System V” during the boot selection menu, which has basically the same effect: the systems starts, but has cr_md127 instead of cr_md1 mounted.

As far as I understand, your proposed solution does the same, but this does not solve my problem of starting and continuing with /dev/md127 (12.1) instead of /dev/md1 (11.4).

Questions:

Is the md127 vs. md1 problem related to initrd ?
Should I generate a new initrd, how can I do using my running system ?