Update Install Error

System tray shows one critical update, but when I go to install I get an error message:

patch:openSUSE-2012-233-1.noarch conflicts with plasmoid-networkmanagement.x86_64 < 0.9.1+0.9.0-1.6.1 provided by plasmoid-networkmanagement-0.9.1git20120319-242.1.x86_64

Suggestions how to fix please.

Hello WallaceGalloway,

Welcome here to these forums.

You fail to tell us which version of openSUSE you use. And as you talk about a “system tray”, I assume you use a desktop environment, but again you do not tell which one (KDE, Gnome, …).

Lacking this information the following is a guess!

When you use KDE with the Apper applet, please switch it off, or better deinstall Apper.

When you want to update with Security (and Recommended) patches, start YaST > Software > Online update.

My apologies. OpenSuse 12.1 KDE 4.8.3.

Did as you said. Installed using Yast online update.The trick was the option for vendor change. Thanks. Really liking 12.1. Rock solid!

To WallaceGalloway

I’ve had the same message using the Yast Online Update. However, when prompted about the patch, I always select the patch.
Once the patch has been applied, you can update KDE later using the repositories with the command “zypper dup” (without the quotes).

I always set my priorities number for each repository to the same number " 99 " in order for “zypper dup” to work correctly.

You can also do this with Yast.

Good Luck!

Wow, thanks hcvv! I had merely updated KDE to 4.83 and thought that solved it, but using the online update fixed that pesky conflict.