Update hangs at 48% (64 bit)

I recently downloaded 11.2 to a flash drive and while updating it from online the updates hangs at 48% and the last line reads:

Installing ./rpm/x86_64/libexpat1-32bit-2.0.1-92.4.1.x86_64.rpm: “XML Parser Toolkit”

This fist loading bar is at 100% and total is at 48%.

Is there a way to safely exit this program it appears to be frozen.

That’s not good. There is no real safe way to kill the software installer. I’ll try to explain what you can do.

Hit Ctrl-Alt-Esc, the cursor will become a skull !! Click on the installer, it will be killed.

Now, in a terminal window, do:
su -c ‘killall yast2’
su -c ‘killall y2base’

su -c ‘zypper ref’
su -c ‘zypper dup’

Enter the rootpassword when prompted for. This action is going to pull in a lot of packages, but at it’s end you should be back in business

Welcome to this beautiful place BTW

I tried ctrl-alt-esc to no avail it is still hanging as though it is thinking. And the title bars one the windows are black. Should I just do a hard restart?

igriego wrote:
> I tried ctrl-alt-esc

try hold down ctrl+alt and hit Backspace twice…then follow the
command line directions…

remember, he said “There is no real safe way to kill the software

my guess is maybe the backspace will work, maybe not…


happening elsewhere also…sounds like one of you needs to log or
comment on an existing bug, see


I went ahead with the hard reset then ran a check and it threw a md5sum error so probably just a bad .iso any other ideas as to why that md5sum error occurred

Bad Download, bad burn, cheap disks. Just some of the reasons the checksum might be bad.

It’s on a flash drive, is it possibly the drive itself or should I reformat it differently?

If it more or less runs it is formated properly ie you get the install menu. It is possible that the flash is bad but less likely then a bad CD/DVD. So most likely it is a bad iso download in the first place.

Alright thank you I’m downloading the DVD image now so that’ll be awhile but thanks for the help

Another question is there a way to test the image prior to burning?

Yes just check the md5 checksum after you download. If Windows this might help

Free MD5 Checksum or Hashing Utilities (Free MD5sum Software) (thefreecountry.com)

or Windows CL
Download it here: http://www.etree.org/cgi-bin/counter.cgi/software/md5sum.exe
Put it in your windows/system32 or /windows/command folder. (In XP it’s C:/Windows/system32)

If Linux md5sum. at CL type info md5sum

igriego wrote:
> Alright thank you I’m downloading the DVD image now so that’ll be awhile
> but thanks for the help

there is no need to re-download, instead point a torrent at it and it
will self-repair the bits that are broken…

find that and lots of other important info in: