Update: Firefox cant connect to https anymore

Hi,
I installed the latest updates for openSUSE 13.2, and since then Firefox cant connect to ssl-pages anymore. Error message:
Firefox weiß nicht, wie mit dem Server kommuniziert werden soll. Bitte stellen Sie sicher, dass auf Ihrem System der Personal-Security-Manager installiert ist.
[Firefox does not know how to communicate with this server. Make sure the Personal Security Manager is installed]

May this be related to this updates?
2016-03-06 15:09:56|install|mozilla-nss-certs|3.22.2-2.1|i586||download.opensuse.org-mozilla|cf84837353a8cd40cea0f582102a20bfd8465582d0a15c32c0293c715957f5d1|
2016-03-06 15:09:56|install|libsoftokn3|3.22.2-2.1|i586||download.opensuse.org-mozilla|99efb6d845fd6c81d97883e97d8d18847a3637a53519df8f1a0089572c2df157|

Or to
2016-03-06 15:10:07|install|openssl|1.0.1k-2.33.1|i586||repo-update|a180fa7c377981aca0aef7df09a28bf0d765ad09cd172e25c09d195d07e67c7f|
2016-03-06 15:10:07|install|libssh2-1|1.5.0-9.7.1|i586||repo-update|cf468e17a268192595e292144044301dc7ae4f490e192e6b0aaf88412901b140|

These are the only ones related to ssl. But as konqueror works, I assume it is not the SSL update.
Any ideas?

Seemed to be a mix of versions.
After installing 2016-03-07 19:01:16|install|MozillaFirefox|44.0.2-62.1 from repo-update plus depending packages it worked again!