Update Error - REALLY?

patch:SUSE-2021-1526-1.noarch conflicts with readline-doc


Looks like it is the BASH patch. WHY??? More OpenSUSE to SUSE glitches??

Yes, really.

It was only a minor problem here – a mere 2036 conflicts and it wanted to uninstall everything.

I chose to not apply that patch.

Something is broken with patches at present. My advice:

Use only

zypper up

at the root command line for updating. Avoid “zypper patch”; avoid Yast Online Update; avoid your desktop update applet.

I will see what

zypper up

https://susepaste.org/46003272 is an image of YaST output for that error, and it’s ramifications. The “1824 more…” is a long list of what seems like the whole system, not just some readline-doc.

I will not update my wife’s laptop for a while! She doesn’t need to put up with this sort thing.

BTW, that error came up on all 3 machines I have upgraded.
Disappointed I AM!

Now to find out how to disable PackageKIt.

For me, it was 2032 more.

Yes, it wanted to uninstall a whole lot of my system. It probably wanted to uninstall every package that had a dependency on “readline”.

I’m using KDE, so I just disable the updater in system tray settings.

I am also using KDE, And darn! I uninstalled PackageKit (3 machines), and didn’t even think about tying to disable it in the tray!
I May put it back in and then disable it there.
try to learn how to write a script(yeah right! me ???) that will auto run every week at start up for

zypper up


BTW, just what is that “readline” thing anyway? I thought it was a ‘man’ page thing.

To automate “zypper up” see:

For readline see GNU Readline.

But think at least twice before you decide to update system software unobserved My (very) personal idea is that it is not a wise thing to do.

Without doubt there will sometime be a situation where some software is updated that a user is using at that moment in time. Something strange will happen and nobody will even think about the possibility that it was an update that broke the running session, because what is “automatic” will be forgotten about.

Thanks marel & hcvv for your response.
No, I Would never let things go without a watchful eye. Learned that lesson 30+ years ago setting up HP-UX workstations for Pro-E cad systems. IT Fella at our remote location said ‘sure, go ahead and let it build on it’s own’. They didn’t!

I shut my machines down every day, & all I would like it to do is run ‘zypper up’ say every Sunday on start up.

In that case, better make a reminder.

You can use likely your email program for that (at least Thunderbird), on KDE Kalarm and there are many other methods.

In case you forget it is Saturday? :wink:

I would say think thrice at least. I ran into a great deal of trouble with this ‘patch’. Reverted and installed 15.3 , then patch came up again. I blocked the patch in YaST. Bad checking for this to happen immediately after release.

I also had this problem, but now it seems the conflicting patches have been multiplied.

zypper up is able to apply a handful of patches after rejecting some 255 (at the time of this writing), and it also complains about missing valid metadata on some of the SUSE:SLE-15 repos (which were configured at the time of leap 15.3 installation).

The output of my most recent zypper up is here: https://susepaste.org/41705368

Best regards,


Yes, they have.

My advice is to use only “zypper up” (at a root command line) for updating.

It looks as if some SUSE patches are not compatible with openSUSE and cause problems. Using only “zypper up” avoids the patches and looks only at the package versions.

I also had an invalid metadata issue this morning with the SUSE update repo, but it went after an hour or so. It was probably due to a mirror being not fully synchronized.

Well, now that the readline-doc vs. Bash error has been solved (I think), we have a new one: “the to be installed patch:SUSE-2020-3792-1.noarch conflicts with 'gzip.x86_64” (yes, there’s a stray ’ there).

Leap 15.3 is the first openSUSE version I’ve encountered that constantly seems to have conflicts with itself. Hopefully this will go away soon and we’ll get a stable platform again.

Sit back and chill down!


Leap 15.3 is stable. There are some conflicting patches. Never install all of them. Install what you need, if any.

Since the initial release june 2nd I did some configuring and ran ‘zypper update’ several times without a single failure:

Leap-15-3:~ # zypper lr -uEP
#  | Alias                 | Name                                                         | Enabled | GPG Check | Refresh | Priority | URI
 5 | Kernel_stable         | Kernel builds for branch stable (standard)                   | Yes     | (r ) Yes  | Yes     |   50     | https://download.opensuse.org/repositories/Kernel:/stable/standard/
 1 | KDE-Applications      | KDE-Applications                                             | Yes     | (r ) Yes  | Yes     |   75     | https://download.opensuse.org/repositories/KDE:/Applications/KDE_Frameworks5_openSUSE_Leap_15.3
 2 | KDE-Extra             | KDE-Extra                                                    | Yes     | (r ) Yes  | Yes     |   75     | https://download.opensuse.org/repositories/KDE:/Extra/KDE_Applications_openSUSE_Leap_15.3
 3 | KDE-Frameworks        | KDE-Frameworks                                               | Yes     | (r ) Yes  | Yes     |   75     | https://download.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_Leap_15.3
 4 | KDE-Qt5               | KDE-Qt5                                                      | Yes     | (r ) Yes  | Yes     |   75     | https://download.opensuse.org/repositories/KDE:/Qt5/openSUSE_Leap_15.3
 6 | mozilla               | Mozilla based projects (openSUSE_Leap_15.3)                  | Yes     | (r ) Yes  | Yes     |   90     | https://download.opensuse.org/repositories/mozilla/openSUSE_Leap_15.3/
 8 | packman               | packman                                                      | Yes     | (r ) Yes  | Yes     |   90     | http://ftp.fau.de/packman/suse/openSUSE_Leap_15.3/
 7 | openSUSE-Leap-15.3-1  | openSUSE-Leap-15.3-1                                         | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/distribution/leap/15.3/repo/oss/
10 | repo-backports-update | Update repository of openSUSE Backports                      | Yes     | (r ) Yes  | Yes     |   99     | https://download.opensuse.org/update/leap/15.3/backports/
15 | repo-non-oss          | Non-OSS Repository                                           | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/distribution/leap/15.3/repo/non-oss/
17 | repo-sle-update       | Update repository with updates from SUSE Linux Enterprise 15 | Yes     | (r ) Yes  | Yes     |   99     | https://download.opensuse.org/update/leap/15.3/sle
19 | repo-update           | Hauptaktualisierungs-Repository                              | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/update/leap/15.3/oss
20 | repo-update-non-oss   | Aktualisierungs-Repository (Nicht-Open-Source-Software)      | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/update/leap/15.3/non-oss/
Leap-15-3:~ # 

Operating System: openSUSE Leap 15.3
**KDE Plasma Version: 5.22.0
KDE Frameworks Version: 5.82.0
Qt Version: 5.15.2
Kernel Version: 5.12.9-3.gf4da13e-default (64-bit)**
Graphics Platform: X11
Processors: 8 × AMD Ryzen 5 3400G with Radeon Vega Graphics
Memory: 29.3 GiB of RAM
Graphics Processor: AMD Radeon™ Vega 11 Graphics
Leap-15-3:~ # zypper if MozillaFirefox
Loading repository data...
Reading installed packages...

Information for package MozillaFirefox:
Repository     : Mozilla based projects (openSUSE_Leap_15.3)
**Name           : MozillaFirefox**
**Version        : 89.0-lp153.1.1**
Arch           : x86_64
Vendor         : obs://build.opensuse.org/mozilla
Installed Size : 212.5 MiB
Installed      : Yes (automatically)
Status         : up-to-date
Source package : MozillaFirefox-89.0-lp153.1.1.src
Summary        : Mozilla Firefox Web Browser
Description    : 
    Mozilla Firefox is a standalone web browser, designed for standards
    compliance and performance.  Its functionality can be enhanced via a
    plethora of extensions.

Leap-15-3:~ #

Well, yeah, zypper up works as it seems simply to ignore the conflicting packages. Trouble is KDE Plasma’s Software Updates applet that keeps pushing those updates and then complains they cannot be installed.

I can keep calm all right, but I wouldn’t recommend this release yet to “ordinary” people, who I usually advise to install every g*****n update the system pushes forward :slight_smile:

You can turn off the update applet in System Tray Settings. I use “zypper up” twice a week, and it is doing fine.

Apart from that, I expect this “problem” to be solved with the release of Leap 15.4 in about 1 year from now. By then, they should have worked out what is going wrong and have a plan to avoid it. In the meantime, things are mostly going well - as long as we stay with “zypper up” for updating.


Maybe you can add a lock, zypper al -t patch SUSE-* while the problem are fixed so if you use zypper patch for mistake, there’s no conflict

This kind of misses the point of the reason I went to suse and openSuse Leap in the first place: Stability and ease of use. If it wasn’t finished, maybe it should not have been released. My 86 year old Mom is running a copy of the last version of Leap and likely stay on it until support is gone. With the updating GUI widget completely useless, she can no longer maintain her setup on her own for 15.3.

I understand that this is a volunteer effort, but this type of thing is problematic for *normal users *that don’t want to become Linux gurus. They want to access zoom calls, read books on-line, watch movies or listen to music, send e-mail and browse the web. The systems I’ve built for people enable them to do that without either paying the Microsoft tax or buying state-of-the-art hardware. I thought I was helping them but now I’m not so sure I have. For some of these folks I have to help them remember or reset passwords on a pretty regular basis. Now I have to make sure they know the commands to update their system on a fairly regular basis instead of having the system monitor that status for them.

Breaking the KDE updater widget hasn’t exactly done anyone a favor. I *will *help those I was trying to before but this really as made my efforts for family and friends harder than it was. If it was just my system I wouldn’t mind so much. Now I have to explain how to use the command line for folks that didn’t have to going back most of a decade.